Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    postfix+LDAP QUOTA


    iam using Rehat ES5.5 Postfix with LDAP , Dovecot and squirrelmail. I configured virtual users (from LDAP) in postfix using
    virtual_mailbox_maps paramter. it is working fine. (sending & receiving files). Now i want to read quota from LDAP attribute.
    i configured like below... it is not working... but postmap -q username ldap:/etc/postfix/ returns quotasize "1000000" correctly.

    virtual_transport = virtual
    virtual_mailbox_base = /var/postfix/maildirs
    virtual_mailbox_domains = $mydomain
    virtual_mailbox_maps = ldap:/etc/postfix/
    virtual_gid_maps = static:501
    virtual_uid_maps = static:89
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = ldap:/etc/postfix/
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = Sorry, the user's maildir has no space available in their inbox.
    virtual_overquota_bounce = yes

    what may be the problem???

    when i give "postconf virtual_mailbox_limit_maps" command , it gives unknown paramter....
    Any patch i have to install???
    Last edited by kalidoss; 08-08-2011 at 08:40 AM.

  2. #2
    I believe you need to patch and recompile your postfix to add support of that parameter:

    I hope that helps

  3. #3

    Postfix+ldap quota+patch

    i have installed postfix-2.3.3 VDA patch And rebuild postfix 2.3.3-2 with VDA package. It is now telling "OVER QUOTA" message in maillog file.
    But it should send to user's mailbox. How can i do it??

  4. $spacer_open
  5. #4
    I never used the patch so I can't help you here

    You will have to contact them unfortunately. I believe there's a forum and mailing list.

  6. #5

    Quota warning to user's mailbox

    I have searched internet. I got one email script. I have copied in my system. Now it is sending warning message to user's mailbox. i am now happy. It's all worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts