Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am about to work on getting the workstations on my network here to be connected to the Active Directory on my Windows 2003 server using Likewise Identity Service. One ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27

    Syncing time with Windows Server Dual Booting systems


    I am about to work on getting the workstations on my network here to be connected to the Active Directory on my Windows 2003 server using Likewise Identity Service. One of the security requirements is a good time sync, so I am trying to setup my Windows server time server on my CentOS machines. These machines dual boot Windows 7 and CentOS 5.5. I am using the Windows server as a time server and it's getting its time from its CMOS. Following a microsoft kb article. I removed all the time servers from the CentOS box I am experimenting with and added the IP of my Windows server, it seems to connect ok but the time never gets updated.

    Oh, and this network has no connection to the internet, it's cut off from the world, so sad and lonely and cannot get internet time!

    Any ideas?

    Thanks,
    DemiSheep

  2. #2
    Linux Newbie nplusplus's Avatar
    Join Date
    Apr 2010
    Location
    Charlotte, NC, USA
    Posts
    106
    Posting your ntp.conf might help. Otherwise, you should make sure the ntpd service is running. i.e.
    chkconfig ntpd on
    service ntpd start

    If your time still doesn't sync, then you might try setting up a cron job that runs ntpdate periodically.

    N

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27
    Quote Originally Posted by nplusplus View Post
    Posting your ntp.conf might help. Otherwise, you should make sure the ntpd service is running. i.e.
    chkconfig ntpd on
    service ntpd start

    If your time still doesn't sync, then you might try setting up a cron job that runs ntpdate periodically.

    N
    Where do I find the ntp.conf file?

    Thanks,
    DemiSheep

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Location
    Cobleskill, NY
    Posts
    51
    Have you tried using Wireshark to compare what happens when syncing with an Internet server and the Win 2003 server? It helps if you know how to do filtering with Wireshark but not essential.

  5. #5
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27
    Quote Originally Posted by ProfTheory View Post
    Have you tried using Wireshark to compare what happens when syncing with an Internet server and the Win 2003 server? It helps if you know how to do filtering with Wireshark but not essential.
    ...don't have internet.

  6. #6
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27
    As a side note, I just noticed that when I reboot the system, when CentOS is shutting down and all the text is running by I see it say "syncing hardware clock something or another"

    As another side note, these machines have never had the correct time, and then I try setting them to the correct time manually they always go back to having some crazy time. Like right now here it's 8:30AM but the CentOS machine says it's 4:15AM or something like th at.

  7. #7
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27
    Another side note, I just checked the windows side, and the windows side is synced with the server to the exact second.

    Also, the Linux side has the right minutes, it's just 4 hours off, 4AM instead of 8 AM

  8. #8
    Just Joined!
    Join Date
    Feb 2007
    Location
    Cobleskill, NY
    Posts
    51
    Check your time zone settings on both machines. Are they the same and correct?

  9. #9
    Just Joined!
    Join Date
    Jun 2010
    Posts
    27
    Quote Originally Posted by ProfTheory View Post
    Check your time zone settings on both machines. Are they the same and correct?
    Yes, the CentOS machine is showing New_York, the server is showing Eastern Time zone.

  10. #10
    Just Joined!
    Join Date
    Feb 2007
    Location
    Cobleskill, NY
    Posts
    51
    Normally I'd say check firewall settings. I know Server 2003 has its off by default. The Ubuntu box should be blocking anything pertaining to ntp. Have you tried syncing time with say an XP VM, or physical machine? See if something can sync off the server.

    Edit: News flash - Windows doesn't always play nice with standards and protocals

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •