Find the answer to your Linux question:
Results 1 to 4 of 4
Hi there, I am trying to change permissions on a directory and it keeps telling me I dont' have permission to do it. ************************ [Student@localhost ~]$ sudo chmod ug+rwx ~/MyFiles/Ike ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    11

    Help with Permissions


    Hi there,

    I am trying to change permissions on a directory and it keeps telling me I dont' have permission to do it.

    ************************
    [Student@localhost ~]$ sudo chmod ug+rwx ~/MyFiles/Ike
    [sudo] password for Student:
    chmod: changing permissions of `/home/Student/MyFiles/Ike': Permission denied
    ************************

    Any help would be greatly appreciated.

    IKE

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello again!

    You're not giving the full path name when issuing the command.
    Code:
    $ sudo chmod ug+rwx ~/MyFiles/Ike
    Should be
    Code:
    $ sudo chmod ug+rwx ~/Student/MyFiles/Ike
    I see that because of the error message: chmod: changing permissions of `/home/Student/MyFiles/Ike': Permission denied
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Aug 2011
    Posts
    11
    Hi JAy,

    Yeah I think I figured it out, part of the issue was our teacher had given us erroneous instructions.

    I had to create the Ike directory under the Home directory and then it gave me permission to do it.

    I had tried using the whole path /home/Student/MyFiles/Ike but it still gave me the permission denied error.

    Now I need to figure out how to move my files from the erroneously created Ike directory under MyFiles to the one under Home

    Any suggestions?

    I have tried to use the mv and cp command but to no avail it said the file didn't exist
    Here is what I tried:
    Code:
     mv /home/Student/MyFiles/Myfile1.txt /home/Ike/Myfile1/txt
    and
    Code:
     cp /home/Student/MyFiles/Myfile1.txt /home/Ike/Myfile1/txt
    thanks for the help

    IKE

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2011
    Posts
    11
    OK Well it seems like I have gotten this taken care of
    It must have been something to do with the virtual server last night. I used the same commands as above and it worked this time.

    Who knows.

    Thanks for the help Jay

    IKE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •