Find the answer to your Linux question:
Results 1 to 2 of 2
Hello I run on CentOS 5.5 64 bits using Gnome. When I try to double click in Nautilus on data files containing text, I get an error like "Cannot open ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Location
    France
    Posts
    1

    Opening .dat files in CentOS


    Hello
    I run on CentOS 5.5 64 bits using Gnome. When I try to double click in Nautilus on data files containing text, I get an error like "Cannot open foo.dat", with the only button being "cancel". There's also a lecture on why this file could be dangerous, which is stupid because it's a text I just created, not even executable:
    The filename "foo.dat" indicates that this file is of type "dat document". The contents of the file indicate that the file is of type "plain text document". If you open this file, the file might present a security risk to your system.

    Do not open the file unless you created the file yourself, or received the file from a trusted source. To open the file, rename the file to the correct extension for "plain text document", then open the file normally. Alternatively, use the Open With menu to choose a specific application for the file.
    The thing is, in the file properties (right click, properties), in the tab "open with" I selected a text editor (Nedit). So I just want it to try to open the document with Nedit (it will fail if it's not text anyway) and stop bugging me! I do not want to rename every data file I have because centos is not happy with the extension!!!

    Thank you for your help.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Have you tried this?

    Open a nautilus window, then
    - go to Edit > Preferences
    - click the Behavior tab
    - under Executable Text Files, select the "View executable text files when they are clicked" option

    does that help?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •