Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I tried installing the VBOX additions in fedora 15 as guest system in VirtualBox. But after running the VBoxLinuxAdditions.run file, building of the kernel modules failed. It gave following ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    2

    fc15:VBoxAddition fails due to kernel-devel version


    Hi,

    I tried installing the VBOX additions in fedora 15 as guest system in VirtualBox. But after running the VBoxLinuxAdditions.run file, building of the kernel modules failed. It gave following message :::

    The headers of the currently running kernel were not found. If the current compilation fails then probably this could be the reason. The missing package can be probably installed with
    yum install kernel-devel-2.6.40.4-5.fc15.i686.

    But when I tried installing the above kernel headers and devel package, it says no such package were found. My kernel is 2.6.40.4-5.fc15.i686 but the kernel headers are not available for this version. They are available for previous versions i.e. 2.6.40.3-0.fc15.i686. Kindly tell me the solution, should I downgrade my kernel version or is there any way things can work out.

    Thanks for reading.

    Regards

  2. #2
    Linux User hatebreed's Avatar
    Join Date
    May 2010
    Posts
    335
    I have the same problem and am curious if anyone has the solution to this problem?

  3. #3
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Have you tried
    Code:
    yum install kernel-devel
    yum install kernel-headers
    If so, any errors?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Is the updates repo enabled? You should see it when you do a repolist, e.g.:
    Code:
    # yum repolist
    repo id    repo name                    status 
    fedora     Fedora 15 - i386             19,365
    updates    Fedora 15 - i386 - Updates   4,894
    If you don't see it, enable it in /etc/yum.repos.d/fedora-updates.repo (or use the --enablerepo=updates yum switch).

    As long as the baseurl/mirrorlist of the Updates repo is accessible, you should be able to do something like:
    Code:
    yum install kernel-devel-2.6.40.4-5.fc15.i686
    Note: you might need to change the arch (.i686) or add -PAE to the package name.

  5. #5
    Linux User hatebreed's Avatar
    Join Date
    May 2010
    Posts
    335
    i have done the updates for the headers. Then it came up with an error that the kernel didn't match so I updated the kernel so it matched but still the same error comes up. I don't think it's fedora but it's a problem with the virtual machine headers update itself. I've done some research on google and it seems that this happens on multiple distros.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •