Find the answer to your Linux question:
Results 1 to 3 of 3
I am using RHEL server 5.4.MY network adaptor card is Atheros AR8151 PCI-E Gigabit Ethernet Controller.It is worinf fine in the main kernel.But when I am using kernel-xen the network ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Location
    india
    Posts
    57

    Network card not working in Xen Kernel


    I am using RHEL server 5.4.MY network adaptor card is Atheros AR8151 PCI-E Gigabit Ethernet Controller.It is worinf fine in the main kernel.But when I am using kernel-xen the network driver is not working.
    Please suggest.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,633
    Xen will not use the card directly, but depending upon how you have configured the VM can be either bridged or NATed to your host system, and then able to piggyback on its network connection.

    Edit: OK. I see that it appears that the host has a problem with the network card. I know that some drivers are not able to deal with the Xen kernel. Are you running Xen virtual machines? If not, then install the non-xen kernel and update grub to boot from that.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Location
    india
    Posts
    57
    Actually I am using Xen-kernel to install virtual Machines.The same problem is occurring in the host having broadcom network cards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •