ARGH!!!! And it's finals week.

OK, Here, here it go . . .

downloaded http://prdownloads.sourceforge.net/...91.tgz?download

$ tar xzvf hpoj-0.91.tgz
successful
cd in dir
$configure
$make
$sudo make install
all no problem and ok

I read and follow the instructions from the hpoj Documentation
restart the cups daeman
ran the web based printer config for cups and printed out a test page.
tried checking for scanning recognition (its an HP OJ 6110) and failed
decided to restart the system

Here is where the fun began.

System starts up . . . everything ok . . . system starts . . . and I get a blue screen with my mouse as a clock waiting with no luck. I cannot even get a login prompt. X won't start.

It must have been something with the printer configuration. So I fumble my way around and discover that ctrl-alt-<function keys> will display different consoles. And I get into a prompt.

Try killing X and restart but with no luck. The only way that I was able to get X to start and use was to be in the F7 display and ctrl-alt-backspace a couple of times so I could log in as root, locate the process id for X and run the command
%kill <pid> ; xdm
#tried startx, but startx will not work

this started enlightenment but was unable to start any other graphical application like gnome-panel.

the following is my .Xclients-default:

#! /bin/bash

gnome-panel &
magicdev &
exec enlightenment

The errors which I get when I try running gnome-panel is the following:
$ gnome-panel
gnome-panel: relocation error: /usr/lib/libXft.so.2: undefined symbol: FT_Set_Hint_Flags

Actually, when I try running Firefox, Thunderbird, gnome-session, gaim . . .
$ firefox
(QFA)Talkback error: Can't initialize.
/usr/local/firefox/firefox-bin: relocation error: /usr/lib/libXft.so.2: undefined symbol: FT_Set_Hint_Flags
$ thunderbird
/usr/local/thunderbird/thunderbird-bin: relocation error: /usr/lib/libXft.so.2: undefined symbol: FT_Set_Hint_Flags
$ gaim
Gaim has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.
. . .
Aborted

I can't figure this out! Why is there a relocation error?!?

After reading more into the Documentation there was a mention of the ptal service needing to start before any spooler services or there could be hangs in subsequent boots. So on reboot I went through an interactive setup and verified that is was starting before my spooler service. In fact after running redhat-switch-printer and changing to CUPS, this is what I get from another reboot:

...
Dec 7 23:17:10 localhost network: Bringing up interface eth0: succeeded
Dec 7 23:17:20 localhost xinetd: xinetd startup succeeded
Dec 7 23:17:21 localhost ntpd: succeeded
Dec 7 23:17:21 localhost ntpd: succeeded
Dec 7 23:17:21 localhost ntpd: ntpd startup succeeded
Dec 7 23:17:24 localhost sendmail: sendmail startup succeeded
Dec 7 23:17:24 localhost sendmail: sm-client startup succeeded
Dec 7 23:17:25 localhost gpm: gpm startup succeeded
Dec 7 23:17:25 localhost crond: crond startup succeeded
Dec 7 23:17:25 localhost cups: cupsd startup succeeded
Dec 7 23:17:28 localhost xfs: xfs startup succeeded
Dec 7 23:17:28 localhost anacron: anacron startup succeeded
Dec 7 23:17:29 localhost atd: atd startup succeeded
...

I tried running a "make uninstall" to no avail, it is not supported for the hpoj driver.

After killing a running X server and attempting to restart X with "startx",
these are the error messages I get



XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc v
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Dec 8 00:38:52 2004
(==) Using config file: "/etc/X11/XF86Config"
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/9325
Loaded background '0x8095d18
/usr/bin/gnome-session: relocation error: /usr/lib/libXft.so.2: undefined symbol

waiting for X server to shut down

This is the message I get when attempting to run Eclipse:
eclipse: relocation error: /usr/lib/libXft.so.2: undefined symbol: FT_Set_Hint_Flags

I am starting to see a theme here.
$cd /usr/lib
$ls -al | grep libXft.so.2
lrwxrwxrwx 1 root root 11 Nov 26 04:04 libXft2.so -> libXft.so.2*
lrwxrwxrwx 1 root root 13 Nov 26 03:45 libXft.so.2 -> libXft.so.2.0*
-rwxr-xr-x 1 root root 80K Sep 2 2002 libXft.so.2.0*

Again, I only seem to get into to X by starting xdm, However, with severe application
restrictions. Applications such as Xine, XMMS and XChat are working fine. So is Mozilla,
but not Firefox

Please help, I know that hpoj changed some vital library which is needed by the Xserver and most other applications. I do not know where all the files were installed from the make install (yes, i tried an rpm but one was not available for RH. Besides, I am worried that deleting the files will not make a difference as deleting files manually do not undo any changes they might have made in my filesystem.