Find the answer to your Linux question:
Results 1 to 4 of 4
Ok guys I've asked a few times and havent gotten any answers so I'm re posting. I have all the drivers install in Redhat 9 for my sound card it's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    United States / West Coast
    Posts
    66

    Sound not working?


    Ok guys I've asked a few times and havent gotten any answers so I'm re posting. I have all the drivers install in Redhat 9 for my sound card it's an intel-8x0 onboard my P4P800-E Deluxe and I got it to config the driver afert 2 days of reading on the net. BUT when I load into an Xwindow I get this :

    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.

    someone told me too try modprobe snd-intel8x0 did that and got this:

    /lib/modules/2.4.20-6/kernel/sound/acore/snd.o: unresolved symbol schedule_work
    /lib/modules/2.4.20-6/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.20-6/kernel/sound/acore/snd.o failed
    /lib/modules/2.4.20-6/kernel/sound/acore/snd.o: insmod snd-intel8x0 failed

    now I read somewhere that it can be from the schedule_work tryed what I found online to fix this issue but for the past week nothing. I've screwed up linux 3 times so far so bad that it called for a re-install not that I cared hey never learn till u break it. I get the same error on boot with my NIC but it works fine as you can see. Anyway before you say just use Fedora Core heres my reasoning behind useing Redhat 9. I'm a student at ITT-Tech Portland in the computer Networking Systems program. We have to use Redhat 9 for school or else I would say screw it and go to a dif distro. I'm still a bit of a newb but catch on rather quick and find linux a heck of a lot better than winblows. I'm hopeing to become a linux specialist after I grad. I've read so much stuff the past 3 nights I'm going insane. I've been up since 5am or latter the past week and have to be up and ready for the day at 10am. I'm stuck so if someone could get me a link to something I've missed or a shove in the right direction I would be more than gratefull. I have already googled these errors in every shape and form and nothing.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    The easiest (and best) way to fix this, IMHO, is to install some 2.6 kernel sources and use ALSA. OSS is deprecated and never was very good. ALSA + 2.4 can be kinda trixie to set up. Therefore, get some current kernel sources, build your kernel (go ahead and build your soundcard module into the kernel), and boot it. That should set you straight.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    United States / West Coast
    Posts
    66
    THanks for the info 1 question though do u have a link that will explain how to build the new kernel and install the nodules I need?

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    United States / West Coast
    Posts
    66
    NM on the site I think I found a good 1 that gives me all the commands I need.
    http://www.linuxgazette.com/node/9060

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •