Find the answer to your Linux question:
Results 1 to 4 of 4
I installed samba and even disabled selinux and I'm still unable to get samba to share files. I try to access the share on my windows machine and it says ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    3

    samba config


    I installed samba and even disabled selinux and I'm still unable to get samba to share files. I try to access the share on my windows machine and it says that I don't have permission. I need help, maybe there is something I need to do with smb.conf but I thought that as long as I created an smbpasswd for my user I could see my share by using the smbclient -L localhost -U alvin, with alvin being the name of my user that I would be able to access alvin's home directory. If there's something else I need to do someone please let me know. I'm just trying to use the default [homes] share and its not working. Thank you.

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Location
    North Hollywood, CA
    Posts
    22
    I just had this same problem using Fedora 16. On the server, you also need to have nmb running. You don't need to configure it because it takes it's configuration from the smb.conf file. It is the service that allows Windows clients, or any non-local client, connections through Samba. On Fedora 15 or older just type /etc/init.d/nmb start and then make sure it starts automatcally in the services configuration screen. On Fedora 16 I had to make a dynamic link to the service file, then start it. So it went ln -s /lib/systemd/system/nmb.service /etc/systemd/multi-user.target.wants/nmb.service and then systemctl enable nmb and then systemctl start nmb. It should work then.

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    You have setup samba and have the service running, that's good. Remember, there are SAMBA permissions and there are UNIX permissions. UNIX permissions will always take precedence over SAMBA permissions.

    Also you may want to make sure there is the appropriate 'hosts allow' entry in your config.

    If you could post your config, that would be helpful as well.
    linux user # 503963

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,639
    Definitely post the contents of /etc/samba/smb.conf here. Also, the contents of /etc/samba/smbusers as well.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •