Find the answer to your Linux question:
Results 1 to 3 of 3
I am constructing a new workstation to carry out my day to day business tasks which consist of running Wine to use Microsoft Word and also to play a few ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5

    FC3 Media Support


    I am constructing a new workstation to carry out my day to day business tasks which consist of running Wine to use Microsoft Word and also to play a few games and then also using Thunderbird as my email client and just to browse the Internet and some other simmilar tasks along with listenign to music and watching movies. Right now I use five machines with FedoraCore3 but I dont use them often so i never messed around with the Mulitmedia support. But the WMA and MP3 codecs arent included with Fedora I know so the multimedia support lacks. Where are some places to download audio and video codecs for Fedora so i can listen to music and watch movies? I am aware Fedora is like the testing ground for Red Hat and have read elsewhere its reallybuggy, but whenever I used it i have had no troubles at all with anything locking up or anything along those lines. What are some of these bugs in FC3 and reasons people are turning away from Fedora? Also is gaming on Fedora any good? Using wine or using the straight Linux game? I have never tried gaming on Fedora so I dont know. Also any other comments people have about FedoraCore3 as a desktop workstation for gaming and doingwork is much appreciated. If not I think I will need to run Mandrake 10.1 for multimedia support and gaming, but I would like to remain loyal to Fedora as I have used it since FC1. I havent been able to find definitive answers to my questions, so a reply is much appreciated. The specs for the system are going to be:

    Tyan Server Grantsdale Motherboard
    2GB PC4400 Corsair XMS
    320 GB (2 x 80GB IDE with SATA convereer & 160GB native SATA drive)
    Gigabye NVIDIA 6600GT 128MB
    NetGear WAG311 802.11g going to use MadWifi
    Intel LGA775 3.0GHz

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    First, why are you using Wine to run MS Word? OpenOffice is better, especially since you can run it native on Linux, and it completely supports Mircrosoft's formats....

    As for Fedora Core 3 being buggy, it's not. It is considered a testing ground for new technologies that might get added to Redhat Enterprise Edition, but that in no way means it's buggy. In fact, FC3 is probably the most stable release of Fedora Core yet.
    If you want high-end, 3d games that use DirectX, consider using Cedega (although it's not free, it's a spin-off of Wine that focuses on DirectX, and is able to play many games). Since you have an nVidia card, you'll want to install the nVidia driver, available from nVidia's website. On Fedora Core 3 you'll also need to copy the nvidia devices from /dev/ to /etc/udev/devices before rebooting by entering "cp -a /dev/nvidia* /etc/udev/devices" after you install it.

    As for multimedia, try going to the FreshRPMs site.
    For just audio, use XMMS. For video, use MPlayer. Make sure you also download the codec package and extract the contents to "/usr/share/codecs" or "/usr/share/mplayer/codecs". That package contains the codecs for almost every non-opensource format in existance, including wma/wmv.
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    I was considering using Microsoft Word just because im accustom to using that with all of the tools and such and I feel its error correction (spelling/grammar) is better than Oo currently.

    Ok, I received numerous accounts on some different forums that Fedora was crap and everything but im glad to hear otherwise here, I personally love Fedora. I think ill just keep my windows box for gaming, so I dont have to waste any more money on Cedega.

    "On Fedora Core 3 you'll also need to copy the nvidia devices from /dev/ to /etc/udev/devices before rebooting by entering "cp -a /dev/nvidia* /etc/udev/devices" after you install it."


    So after I install the nVIDIA drivers then I type in

    cp -a /dev/nvidia* /etc/udev/devices


    Do you agree with these instructions for installing NVIDIA drivers on a FC3 box, pulled from a different forum pasting it below since im not sure of LinuxForum's policies.

    I had one heck of a time installing the NVidia drivers on my system, so I thought I would post the steps that worked for me, so ohters could be spared the pain. I got these instructions from several sources. For the record, these instructions worked on a GeForce 4 MX440 and a GeForce FX5200. They were performed on a clean install of FC 3, and all actions were performed as root. The latest NVidia driver(NVIDIA-Linux-x86-1.0-6629-pkg1.run) was used. I have an AMD Sempron 2600. These instructions will not work unless you have the development packages installed.
    Do not type the quotes around the command line commands. These are only there to seperate what is to be typed from the rest of the instructions.

    READ AND PRINT OUT THIS PAGE BEFORE STARTING

    1)Download the latest NVidia drivers to a directory of your choice

    2)Edit the /etc/inittab manually using a text editor. Change the line that reads "id:5:initdefault:" to read "id:3:initdefault:" . Certain tutorials will instruct you to use the telinit 3, init 3, or even runinit 3 command. These commands didn't work for me, though. However, they may work for other people.

    3)Reboot your system. You will end up in a command prompt environment. DO NOT PANIC. This is what it is supposed to do. Use the "cd" command to move to the directory you downloaded the driver to. For example, if you downloaded the driver to the /root/ folder, then run the command "cd /root/".

    4)Now type "sh NVIDIA-Linux-x86-1.0-6629-pkg1.run".

    5)Accept the license agreement. Now it will probably say that it could not find the kernel source. You can allow the installation program to look for the source online, but it won't work unless the servers are updated. Now it will say that it needs to compile its own kernel. Please allow it to do so. This is the part of the installation were the development tools are required.

    6)Now run the command "cd /etc/X11"

    7)Next type "vim xorg.conf". This opens the text editor. Use the arrow keys to move the cursor. Press the Insert key, and on the bottom, either "INSERT" or "REPLACE" will be shown. If INSERT is selected, then when you type the text you types will be inserted before the selected character. If replace is selected, then what you type will replace the selected character(s). Look for a line that reads "Driver "nv"", or "Driver "vega"". Change it to read "Driver "nvidia"". Now go scroll up until you get to "Section "Module"". Make sure that one of the lines between"Section "Module"" and "EndSection" says "Load "glx"". If the lines "Load "dri"" or "Load "GLcore" are present, then comment them out by placing a # at the begining of the line.

    To exit and save changes, push esc. Now type ":wq" and hit enter. If you mess up you can quit without saving by hitting esc and then typing ":q!".

    9)Now that you are back to command prompt, type "rpm -e --nodeps xorg-x11-Mesa-libGL"
    NOTE: If you update "xorg-x11" package with up2date or yum, you will have to do the abouve command again.

    10)Now run "modprobe nvidia"

    11)Now run "cp -a /dev/nvidia* /etc/udev/devices
    Allow it to overwrite what is there.

    12)Now run "chown root.root /etc/udev/devices/nvidia*"

    13) Almost there, all that's left is to edit /etc/inittab back to what it was. To do this, type "cd /etc/". Now type "vim inittab" . Change the "3" back to a "5".

    14)Reboot by hitting ctl-alt-delete

    15)You're done!!!

    I hope this helps alot of people, feedback and more information is certainly welcome.
    A special thanks to perfect_circle for helping me wih this. Also, parts of this tutorial were taken from *********************

    -Sean


    Ill try the multimedia items as soon as I get that box running, as I just woke up.

    I am also having some issues with other audio related items.Im using onboard audio from a Intel 915 Grantsdale chipset & ICH-6.. Under GStreamer preferences ALSA is selected for default sink and default source but when clicking test it says failed to construct test pipeline for 'ALSA....' I think from FedoraFAQ I can get XMMS and the media player with mp3 codecs working but no audio is working hwo do I getALSA working properkly

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •