Find the answer to your Linux question:
Results 1 to 5 of 5
Hi Linux people - I have searched and searched and I can see other with similar problems to this, but no guaranteed fix it solution! I can't risk messing this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    3

    yum update PHP dependency problems!


    Hi Linux people - I have searched and searched and I can see other with similar problems to this, but no guaranteed fix it solution! I can't risk messing this up as its in production.

    Basically we have a server with RHEL 5.4 and Plesk 9.3, running PHP 5.1.6. I need to get PHP up to 5.3 however yum upgrade is failing like this:

    --> Processing Dependency: sendmail = 8.13.8-8.1.el5_7 for package: sendmail-cf
    --> Finished Dependency Resolution
    php-soap-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-soap-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    mysql-server-5.0.77-4.el5_6.6.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: mysql = 5.0.77-4.el5_6.6 is needed by package mysql-server-5.0.77-4.el5_6.6.i386 (rhel-i386-server-5)
    sendmail-cf-8.13.8-8.1.el5_7.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: sendmail = 8.13.8-8.1.el5_7 is needed by package sendmail-cf-8.13.8-8.1.el5_7.i386 (rhel-i386-server-5)
    php-pdo-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-pdo-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    php-imap-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-imap-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    php-xml-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    php-gd-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-gd-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    php-mbstring-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mbstring-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    php-mysql-5.1.6-27.el5_5.3.i386 from rhel-i386-server-5 has depsolving problems
    --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mysql-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: mysql = 5.0.77-4.el5_6.6 is needed by package mysql-server-5.0.77-4.el5_6.6.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-imap-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mysql-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-soap-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-pdo-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-gd-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Error: Missing Dependency: sendmail = 8.13.8-8.1.el5_7 is needed by package sendmail-cf-8.13.8-8.1.el5_7.i386 (rhel-i386-server-5)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mbstring-5.1.6-27.el5_5.3.i386 (rhel-i386-server-5)
    Here is my repo info:

    repo id repo name status
    epel Extra Packages for Enterprise Linux 5 - i386 enabled: 5,552
    epel-debuginfo Extra Packages for Enterprise Linux 5 - i386 - Debug disabled
    epel-source Extra Packages for Enterprise Linux 5 - i386 - Source disabled
    epel-testing Extra Packages for Enterprise Linux 5 - Testing - i386 disabled
    epel-testing-debuginfo Extra Packages for Enterprise Linux 5 - Testing - i386 - Debug disabled
    epel-testing-source Extra Packages for Enterprise Linux 5 - Testing - i386 - Source disabled
    rhel-debuginfo Red Hat Enterprise Linux 5Server - i386 - Debug disabled
    rhel-i386-server-5 Red Hat Enterprise Linux (v. 5 for 32-bit x86) enabled: 9,408
    rhel-i386-server-supplementary-5 RHEL Supplementary (v. 5 for 32-bit x86) enabled: 784
    rhel-i386-server-vt-5 RHEL Virtualization (v. 5 for 32-bit x86) enabled: 230
    repolist: 15,974


    /etc/yum.repos.d/epel.repo /etc/yum.repos.d/epel-testing.repo /etc/yum.repos.d/rhel-debuginfo.repo


    I am no expert, but I know my way around enough to screw up our system. Can anyone advise how I should be proceed, preferably the lowest risk route?!

    Many thanks

  2. #2
    Just Joined!
    Join Date
    Dec 2011
    Posts
    3
    I forgot to say - I have done yum clean all and the usual troubleshooting stuff... to no avail!

  3. #3
    Just Joined! pradeeprajkumar's Avatar
    Join Date
    Jun 2010
    Location
    India
    Posts
    72
    I'm not sure about this,but you shall try,
    Code:
    yum groupupdate <package_name>
    .
    Here is a reference.
    15 Linux Yum Command Examples – Install, Uninstall, Update Packages

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Without looking closely at the software available at the various repos, I'd hazard a guess that EPEL is clashing with RHEL. If you really need PHP 5.3, well that is tough...especially as this is a production server. Do you not have another system that you can configure similarly and then test on?

    Also, can you show the command(s) you are using to perform the attempted PHP install?

  5. #5
    Just Joined!
    Join Date
    Feb 2011
    Posts
    21
    Dependency problems? Yum never has dependency problems!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •