Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I did a stupid thing and updated CentOS 6. This is the X log file. Code: [ 372.886] X.Org X Server 1.10.4 Release Date: 2011-08-19 [ 372.886] X Protocol Version ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie theKbStockpiler's Avatar
    Join Date
    Sep 2010
    Location
    Upstate NY
    Posts
    205

    CentOS wil not startX at boot after updates.


    I did a stupid thing and updated CentOS 6.

    This is the X log file.








    Code:
    [   372.886] 
    X.Org X Server 1.10.4
    Release Date: 2011-08-19
    [   372.886] X Protocol Version 11, Revision 0
    [   372.886] Build Operating System: c6b18n2 2.6.32-71.el6.x86_64 
    [   372.886] Current Operating System: Linux localhost.localdomain 2.6.32-71.el6.i686 #1 SMP Fri Nov 12 04:17:17 GMT 2010 i686
    [   372.887] Kernel command line: root=/dev/sda2
    [   372.887] Build Date: 17 December 2011  04:48:52PM
    [   372.887] Build ID: xorg-x11-server 1.10.4-6.el6_2.1 
    [   372.887] Current version of pixman: 0.18.4
    [   372.887] 	Before reporting problems, check https://www.redhat.com/apps/support/
    	to make sure that you have the latest version.
    [   372.887] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   372.887] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 16 18:45:46 2012
    [   372.887] (II) Loader magic: 0x822c500
    [   372.887] (II) Module ABI versions:
    [   372.887] 	X.Org ANSI C Emulation: 0.4
    [   372.887] 	X.Org Video Driver: 10.0
    [   372.887] 	X.Org XInput driver : 12.2
    [   372.887] 	X.Org Server Extension : 5.0
    [   372.888] (--) PCI:*(0:0:2:0) 8086:2e32:1043:836d rev 3, Mem @ 0xfe400000/4194304, 0xe0000000/268435456, I/O @ 0x0000cc00/8, BIOS @ 0x????????/131072
    [   372.888] (--) PCI: (0:0:2:1) 8086:2e33:1043:836d rev 3, Mem @ 0xfea00000/1048576, BIOS @ 0x????????/65536
    [   372.888] (==) Using default built-in configuration (30 lines)
    [   372.888] (==) --- Start of built-in configuration ---
    [   372.888] 	Section "Device"
    [   372.888] 		Identifier	"Builtin Default intel Device 0"
    [   372.888] 		Driver	"intel"
    [   372.888] 	EndSection
    [   372.888] 	Section "Screen"
    [   372.888] 		Identifier	"Builtin Default intel Screen 0"
    [   372.888] 		Device	"Builtin Default intel Device 0"
    [   372.888] 	EndSection
    [   372.888] 	Section "Device"
    [   372.888] 		Identifier	"Builtin Default vesa Device 0"
    [   372.888] 		Driver	"vesa"
    [   372.888] 	EndSection
    [   372.888] 	Section "Screen"
    [   372.888] 		Identifier	"Builtin Default vesa Screen 0"
    [   372.888] 		Device	"Builtin Default vesa Device 0"
    [   372.888] 	EndSection
    [   372.888] 	Section "Device"
    [   372.888] 		Identifier	"Builtin Default fbdev Device 0"
    [   372.888] 		Driver	"fbdev"
    [   372.888] 	EndSection
    [   372.888] 	Section "Screen"
    [   372.889] 		Identifier	"Builtin Default fbdev Screen 0"
    [   372.889] 		Device	"Builtin Default fbdev Device 0"
    [   372.889] 	EndSection
    [   372.889] 	Section "ServerLayout"
    [   372.889] 		Identifier	"Builtin Default Layout"
    [   372.889] 		Screen	"Builtin Default intel Screen 0"
    [   372.889] 		Screen	"Builtin Default vesa Screen 0"
    [   372.889] 		Screen	"Builtin Default fbdev Screen 0"
    [   372.889] 	EndSection
    [   372.889] (==) --- End of built-in configuration ---
    [   372.889] (==) ServerLayout "Builtin Default Layout"
    [   372.889] (**) |-->Screen "Builtin Default intel Screen 0" (0)
    [   372.889] (**) |   |-->Monitor "<default monitor>"
    [   372.889] (**) |   |-->Device "Builtin Default intel Device 0"
    [   372.889] (==) No monitor specified for screen "Builtin Default intel Screen 0".
    	Using a default monitor configuration.
    [   372.889] (**) |-->Screen "Builtin Default vesa Screen 0" (1)
    [   372.889] (**) |   |-->Monitor "<default monitor>"
    [   372.889] (**) |   |-->Device "Builtin Default vesa Device 0"
    [   372.889] (==) No monitor specified for screen "Builtin Default vesa Screen 0".
    	Using a default monitor configuration.
    [   372.889] (**) |-->Screen "Builtin Default fbdev Screen 0" (2)
    [   372.889] (**) |   |-->Monitor "<default monitor>"
    [   372.889] (**) |   |-->Device "Builtin Default fbdev Device 0"
    [   372.889] (==) No monitor specified for screen "Builtin Default fbdev Screen 0".
    	Using a default monitor configuration.
    [   372.889] (==) Automatically adding devices
    [   372.889] (==) Automatically enabling devices
    [   372.889] (==) FontPath set to:
    	catalogue:/etc/X11/fontpath.d,
    	built-ins
    [   372.889] (==) ModulePath set to "/usr/lib/xorg/modules"
    [   372.889] (II) The server relies on HAL to provide the list of input devices.
    	If no devices become available, reconfigure HAL or disable AutoAddDevices.
    [   372.889] (II) LoadModule: "extmod"
    [   372.890] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [   372.890] (II) Module extmod: vendor="X.Org Foundation"
    [   372.890] 	compiled for 1.10.4, module version = 1.0.0
    [   372.890] 	Module class: X.Org Server Extension
    [   372.890] 	ABI class: X.Org Server Extension, version 5.0
    [   372.890] (II) Loading extension SELinux
    [   372.890] (II) Loading extension MIT-SCREEN-SAVER
    [   372.890] (II) Loading extension XFree86-VidModeExtension
    [   372.890] (II) Loading extension XFree86-DGA
    [   372.890] (II) Loading extension DPMS
    [   372.890] (II) Loading extension XVideo
    [   372.890] (II) Loading extension XVideo-MotionCompensation
    [   372.890] (II) Loading extension X-Resource
    [   372.890] (II) LoadModule: "dbe"
    [   372.890] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [   372.890] (II) Module dbe: vendor="X.Org Foundation"
    [   372.890] 	compiled for 1.10.4, module version = 1.0.0
    [   372.890] 	Module class: X.Org Server Extension
    [   372.890] 	ABI class: X.Org Server Extension, version 5.0
    [   372.890] (II) Loading extension DOUBLE-BUFFER
    [   372.890] (II) LoadModule: "glx"
    [   372.891] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   372.891] (II) Module glx: vendor="X.Org Foundation"
    [   372.891] 	compiled for 1.10.4, module version = 1.0.0
    [   372.891] 	ABI class: X.Org Server Extension, version 5.0
    [   372.891] (==) AIGLX enabled
    [   372.891] (II) Loading extension GLX
    [   372.891] (II) LoadModule: "record"
    [   372.891] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [   372.891] (II) Module record: vendor="X.Org Foundation"
    [   372.891] 	compiled for 1.10.4, module version = 1.13.0
    [   372.891] 	Module class: X.Org Server Extension
    [   372.891] 	ABI class: X.Org Server Extension, version 5.0
    [   372.891] (II) Loading extension RECORD
    [   372.891] (II) LoadModule: "dri"
    [   372.891] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [   372.891] (II) Module dri: vendor="X.Org Foundation"
    [   372.891] 	compiled for 1.10.4, module version = 1.0.0
    [   372.891] 	ABI class: X.Org Server Extension, version 5.0
    [   372.891] (II) Loading extension XFree86-DRI
    [   372.891] (II) LoadModule: "dri2"
    [   372.892] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [   372.892] (II) Module dri2: vendor="X.Org Foundation"
    [   372.892] 	compiled for 1.10.4, module version = 1.2.0
    [   372.892] 	ABI class: X.Org Server Extension, version 5.0
    [   372.892] (II) Loading extension DRI2
    [   372.892] (II) LoadModule: "intel"
    [   372.892] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [   372.892] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: PictureScreenPrivateKey
    [   372.892] (EE) LoadModule: Module intel does not have a intelModuleData data object.
    [   372.892] (II) UnloadModule: "intel"
    [   372.892] (II) Unloading intel
    [   372.892] (EE) Failed to load module "intel" (invalid module, 0)
    [   372.892] (II) LoadModule: "vesa"
    [   372.893] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [   372.893] (II) Module vesa: vendor="X.Org Foundation"
    [   372.893] 	compiled for 1.7.7, module version = 2.3.0
    [   372.893] 	Module class: X.Org Video Driver
    [   372.893] 	ABI class: X.Org Video Driver, version 6.0
    [   372.893] (EE) module ABI major version (6) doesn't match the server's version (10)
    [   372.893] (II) UnloadModule: "vesa"
    [   372.893] (II) Unloading vesa
    [   372.893] (EE) Failed to load module "vesa" (module requirement mismatch, 0)
    [   372.893] (II) LoadModule: "fbdev"
    [   372.893] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [   372.893] (II) Module fbdev: vendor="X.Org Foundation"
    [   372.893] 	compiled for 1.7.7, module version = 0.4.2
    [   372.893] 	ABI class: X.Org Video Driver, version 6.0
    [   372.893] (EE) module ABI major version (6) doesn't match the server's version (10)
    [   372.893] (II) UnloadModule: "fbdev"
    [   372.893] (II) Unloading fbdev
    [   372.893] (EE) Failed to load module "fbdev" (module requirement mismatch, 0)
    [   372.893] (EE) No drivers available.
    [   372.893] 
    Fatal server error:
    [   372.893] no screens found
    [   372.893] 
    Please consult the Red Hat, Inc. support 
    	 at https://www.redhat.com/apps/support/
     for help. 
    [   372.893] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [   372.893]
    Thanks in advance!
    Last edited by jayd512; 01-20-2012 at 12:38 AM. Reason: added code tags

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    What video hardware are you using? Was it using a proprietary driver or one that was installed after the original OS and kernel? If so, then boot into runlevel 3, reinstall the video driver, and reset or reboot to runlevel 5.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Newbie theKbStockpiler's Avatar
    Join Date
    Sep 2010
    Location
    Upstate NY
    Posts
    205

    X Server does not work at all even in console with command 'xstart'

    I'm only using what ever came with the Installation Disk and a mainboard that has a VGA jack right on it. Bare minimum. I heard what a pain Video cards can be with Linux and they don't last long so I have never delved in that area. No X capabilities with either the original Kernel or the Updated One.

    Thanks for the Reply!

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hey,

    Assuming you have an internet connection and the yum configured, have you done a full system update yet? Perhaps one of the packages related to X has been updated, which might fix your problem.

    It is as simple as:

    Code:
    yum update
    although you may need to enable the updates repo first. you can permanently enable it by find the correct stanza (starts with [updates]) in the correct repo file in /etc/yum.repos.d/*.repo, or you can temporarily enable it with:

    Code:
    yum update --enablerepo=updates
    provided that this repo is already configured, but just disabled.

  5. #5
    Linux Newbie theKbStockpiler's Avatar
    Join Date
    Sep 2010
    Location
    Upstate NY
    Posts
    205

    Thanks for the Replies!

    I have multiple repos on CentOS which is a bad thing but nothing catches my eye as being destructive on these updates. Does anyone else?



    Code:
     Aug 25 23:47:46 Installed: meld-1.3.1-2.el6.noarch
    Aug 26 00:02:51 Installed: libgnomecups-0.2.3-9.el6.i686
    Aug 26 00:02:54 Installed: libgnomeprint22-2.18.6-4.el6.i686
    Aug 26 00:02:57 Installed: libgnomeprintui22-2.18.4-3.el6.i686
    Aug 26 00:03:00 Installed: ghex-2.24.0-4.el6.i686
    Aug 26 00:15:37 Installed: gnome-ppp-0.3.23-4mdv2011.0.i586
    Aug 26 18:20:06 2:opera-11.50-1074.i386: 100
    Aug 26 20:21:39 Installed: gparted-0.6.0-1.el6.i686
    Aug 26 20:51:58 Installed: rpmforge-release-0.5.2-2.el6.rf.i686
    Aug 26 21:00:30 Installed: soundconverter-1.5.4-1.el6.rf.noarch
    Aug 26 21:05:28 2:opera-11.50-1074.i386: 100
    Aug 26 21:14:50 Installed: alacarte-0.12.4-1.el6.noarch
    Aug 27 03:12:43 Installed: 2:opera-11.50-1074.i386
    Aug 30 12:55:34 Installed: 1:mc-4.7.0.2-3.el6.i686
    Aug 30 13:00:49 Updated: meld-1.4.0-1.el6.rf.noarch
    Aug 30 13:36:54 Installed: lde-2.6.1-4.el6.i686
    Aug 31 13:23:21 Installed: fuse-ntfs-3g-2010.10.2-1.el6.rf.i686
    Aug 31 15:15:57 Installed: kchmviewer-common-5.2-5.el6.2.noarch
    Aug 31 15:15:59 Installed: chmlib-0.40-3.el6.i686
    Aug 31 15:16:02 Installed: kio_msits-5.2-5.el6.2.i686
    Aug 31 15:16:05 Installed: kchmviewer-5.2-5.el6.2.i686
    
    
    Sep 23 19:15:13 Installed: opencore-amr-0.1.2-1.el6.rf.i686
    Sep 23 19:15:14 Installed: libid3tag-0.15.1b-11.el6.i686
    Sep 23 19:15:15 Installed: a52dec-0.7.4-15.el6.i386
    Sep 23 19:15:16 Installed: x264-0.0.0-0.4.20101111.el6.rf.i686
    Sep 23 19:15:17 Installed: libsidplay-1.36.60-1.el6.rf.i686
    Sep 23 19:15:18 Installed: twolame-0.3.13-1.el6.rf.i686
    Sep 23 19:15:19 Installed: libmpeg2-0.5.1-8.el6.i386
    Sep 23 19:15:20 Installed: libmad-0.15.1b-13.el6.i386
    Sep 23 19:15:21 Installed: lame-3.98.4-1.el6.rf.i686
    Sep 23 19:15:22 Installed: orc-0.4.11-1.el6.rf.i686
    Sep 23 19:15:25 Installed: gstreamer-plugins-ugly-0.10.16-2.el6.rf.i686
    Sep 23 19:15:28 Installed: gstreamer-ffmpeg-0.10.11-1.el6.rf.i686
    Sep 23 19:58:52 Updated: 2:vim-common-7.2.411-1.6.el6.i686
    Sep 23 19:58:56 Installed: 2:vim-X11-7.2.411-1.6.el6.i686
    Sep 23 19:58:58 Updated: 2:vim-enhanced-7.2.411-1.6.el6.i686
    Sep 23 22:34:46 Installed: mdic-0.8.1-1.i386
    Sep 23 23:41:47 Installed: cppunit-1.12.1-3.1.el6.i686
    Sep 23 23:41:48 Installed: dirac-1.0.2-1.el6.rf.i686
    Sep 23 23:42:34 Installed: schroedinger-1.0.10-1.el6.rf.i686
    Sep 23 23:42:35 Installed: libebml-1.0.0-1.el6.rf.i686
    Sep 23 23:42:36 Installed: libmatroska-1.0.0-1.el6.rf.i686
    Sep 23 23:42:38 Installed: libkate-0.3.8-1.el6.i686
    Sep 23 23:42:39 Installed: live555-0-0.30.2011.01.24.el6.i386
    Sep 23 23:42:40 Installed: libcddb-1.3.2-2.el6.i686
    Sep 23 23:42:42 Installed: zvbi-0.2.33-2.el6.rf.i686
    Sep 23 23:42:43 Installed: libdca-0.0.5-5.el6.i386
    Sep 23 23:42:44 Installed: libdvbpsi-0.1.7-1.el6.rf.i686
    Sep 23 23:42:46 Installed: svgalib-1.9.25-8.el6.i686
    Sep 23 23:42:47 Installed: libmodplug-0.8.7-1.el6.rf.i686
    Sep 23 23:42:48 Installed: faac-1.26-1.el6.rf.i686
    Sep 23 23:42:49 Installed: freeglut-2.6.0-1.el6.i686
    Sep 23 23:42:50 Installed: libcaca-0.99-0.9.beta16.el6.i686
    Sep 23 23:42:52 Installed: jack-audio-connection-kit-0.118.0-1.el6.i686
    Sep 23 23:42:53 Installed: portaudio-19-9.el6.i686
    Sep 23 23:42:54 Installed: libdvdnav-4.1.4-0.1.svn1184.el6.i686
    Sep 23 23:42:55 Installed: aalib-1.4.0-5.el6.rf.i686
    Sep 23 23:42:55 Installed: 1:faad2-libs-2.7-2.el6.i386
    Sep 23 23:42:56 Installed: SDL_image-1.2.10-1.el6.rf.i686
    Sep 23 23:42:57 Installed: enca-1.13-1.el6.i686
    Sep 23 23:42:58 Installed: libass-0.9.11-1.el6.rf.i686
    Sep 23 23:42:59 Installed: libupnp-1.6.6-1.el6.rf.i686
    Sep 23 23:43:01 Installed: libva-1.0.6-1.el6.rf.i686
    Sep 23 23:43:02 Installed: fribidi-0.19.2-2.el6.i686
    Sep 23 23:43:03 Installed: librtmp-2.3-2.el6.i386
    Sep 23 23:43:04 Installed: ffmpeg-libpostproc-0.6.1-1.el6.rf.i686
    Sep 23 23:43:06 Installed: ffmpeg-0.6.1-1.el6.rf.i686
    Sep 23 23:43:17 Installed: vlc-1.1.11-1.el6.rf.i686
    Sep 24 00:53:47 Installed: lyx-fonts-2.0.0-1.puias6.noarch
    Sep 25 08:17:21 Updated: glibc-2.12-1.7.el6_0.5.i686
    Sep 25 08:17:36 Updated: glibc-common-2.12-1.7.el6_0.5.i686
    Sep 25 08:17:39 Updated: freetype-2.3.11-6.el6_0.2.i686
    Sep 25 08:17:40 Updated: pango-1.28.1-3.el6_0.5.i686
    Sep 25 08:17:44 Installed: wv-1.2.7-2.el6.i686
    Sep 25 08:17:46 Updated: freetype-devel-2.3.11-6.el6_0.2.i686
    Sep 25 08:17:49 Updated: glibc-headers-2.12-1.7.el6_0.5.i686
    Sep 25 08:17:51 Updated: glibc-devel-2.12-1.7.el6_0.5.i686
    Sep 25 08:17:52 Updated: pango-devel-1.28.1-3.el6_0.5.i686
    Sep 25 08:48:50 Installed: 1:aiksaurus-1.2.1-21.puias6.i686
    Sep 25 08:49:04 Installed: 1:aiksaurus-gtk-1.2.1-21.puias6.i686
    Sep 25 08:50:46 Installed: t1lib-5.1.2-6.el6.i686
    Sep 25 08:50:48 Installed: gtkmathview-0.8.0-6.puias6.i686
    Sep 25 08:51:02 Installed: link-grammar-4.6.7-3.puias6.i686
    Sep 25 08:51:15 Installed: ots-libs-0.5.0-3.puias6.i686
    Sep 25 08:52:45 Installed: loudmouth-1.4.3-6.el6.i686
    Sep 25 08:52:46 Installed: libwpg-0.1.3-4.1.el6.i686
    Sep 25 08:52:49 Installed: 1:libabiword-2.8.6-3.puias6.i686
    Sep 25 08:53:22 Installed: 1:abiword-2.8.6-3.puias6.i686
    Sep 25 12:04:10 Installed: xorg-x11-fonts-ISO8859-1-75dpi-7.2-9.1.el6.noarch
    Sep 25 12:04:11 Installed: libXp-1.0.0-15.1.el6.i686
    Sep 25 12:04:13 Installed: lesstif-0.95.2-1.el6.i686
    Sep 25 12:04:18 Installed: ddd-3.3.12-5.el6.i686
    Sep 26 13:58:00 Installed: perl-Crypt-PasswdMD5-1.3-6.el6.noarch
    Sep 26 13:58:02 Installed: syslinux-4.04-1.el6.rfx.i686
    Sep 26 13:58:04 Installed: p7zip-plugins-9.20.1-2.el6.i686
    Sep 26 13:58:05 Installed: unetbootin-0-8.485bzr.el6.i686
    
    
    Oct 05 04:54:32 Installed: pyparted-3.4-2.el6.i686
    Oct 05 04:54:34 Installed: 1:isomd5sum-1.0.6-1.el6.i686
    Oct 05 04:54:37 Installed: sip-4.9.3-1.el6.i686
    Oct 05 04:54:44 Installed: PyQt4-4.6.2-8.el6.i686
    Oct 05 04:54:51 Installed: liveusb-creator-3.11.1-1.el6.noarch
    Oct 12 05:05:26 Updated: openssh-5.3p1-20.el6_0.3.i686
    Oct 12 05:05:27 Updated: openssh-askpass-5.3p1-20.el6_0.3.i686
    Oct 12 05:05:28 Updated: openssh-clients-5.3p1-20.el6_0.3.i686
    Oct 12 05:05:30 Updated: openssh-server-5.3p1-20.el6_0.3.i686
    Oct 12 05:15:52 Installed: 1:gnome-system-log-2.28.1-10.el6.i686
    Nov 15 11:47:34 Installed: dissy-8-5.el6.noarch
    Nov 15 22:58:40 Installed: vnstat-1.11-1.el6.i686
    Nov 21 14:00:39 Installed: gnuchess-5.07-14.1.el6.i686
    
    
    Dec 11 15:16:01 Updated: audit-libs-2.1-5.el6.i686
    Dec 11 15:16:02 Installed: setools-libs-3.3.7-4.el6.i686
    Dec 11 15:16:04 Installed: setools-libs-python-3.3.7-4.el6.i686
    Dec 11 15:16:05 Installed: setools-console-3.3.7-4.el6.i686
    Dec 11 15:16:10 Updated: policycoreutils-2.0.83-19.8.el6_0.i686
    Dec 11 15:16:10 Installed: audit-libs-python-2.1-5.el6.i686
    Dec 11 15:16:11 Installed: libsemanage-python-2.0.43-4.el6.i686
    Dec 11 15:16:13 Updated: audit-libs-devel-2.1-5.el6.i686
    Dec 11 15:16:49 Installed: policycoreutils-python-2.0.83-19.8.el6_0.i686
    Dec 11 15:16:50 Updated: audit-2.1-5.el6.i686
    Dec 11 15:16:52 Installed: policycoreutils-gui-2.0.83-19.8.el6_0.i686
    Dec 18 14:05:41 Installed: wxGTK-2.8.12-1.el6.rf.i686
    Dec 18 14:05:47 Installed: xchm-1.20-1.el6.i686
    Dec 18 17:05:04 Installed: unrar-4.0.7-1.el6.rf.i686
    Dec 20 13:09:40 Updated: elfutils-libelf-0.152-1.el6.i686
    Dec 20 13:09:41 Updated: rpm-libs-4.8.0-19.el6.i686
    Dec 20 13:09:43 Updated: rpm-4.8.0-19.el6.i686
    Dec 20 13:09:44 Updated: elfutils-libs-0.152-1.el6.i686
    Dec 20 13:09:45 Updated: elfutils-0.152-1.el6.i686
    Dec 20 13:09:46 Updated: rpm-python-4.8.0-19.el6.i686
    Dec 20 13:09:48 Updated: gdb-7.2-50.el6.i686
    Dec 20 13:09:49 Updated: yum-metadata-parser-1.1.2-16.el6.i686
    Dec 20 13:09:50 Updated: yum-plugin-fastestmirror-1.1.30-10.el6.noarch
    Dec 20 13:09:52 Updated: yum-3.2.29-22.el6.centos.noarch
    Dec 20 13:09:53 Updated: PackageKit-gtk-module-0.5.8-19.el6.centos.i686
    Dec 20 13:09:54 Updated: PackageKit-glib-0.5.8-19.el6.centos.i686
    Dec 20 13:09:55 Updated: PackageKit-yum-0.5.8-19.el6.centos.i686
    Dec 20 13:09:58 Updated: PackageKit-0.5.8-19.el6.centos.i686
    Dec 20 13:10:00 Updated: PackageKit-yum-plugin-0.5.8-19.el6.centos.i686
    Dec 20 13:10:00 Updated: elfutils-libelf-devel-0.152-1.el6.i686
    Dec 20 13:10:01 Updated: PackageKit-device-rebind-0.5.8-19.el6.centos.i686
    Dec 20 13:10:02 Updated: PackageKit-gstreamer-plugin-0.5.8-19.el6.centos.i686
    Dec 20 13:10:03 Updated: rpm-build-4.8.0-19.el6.i686
    Dec 20 13:10:04 Updated: elfutils-devel-0.152-1.el6.i686
    Dec 20 13:10:05 Updated: yum-utils-1.1.30-10.el6.noarch
    Dec 21 12:29:13 Updated: libwnck-2.28.0-3.el6.i686
    Dec 21 12:29:14 Updated: gnome-panel-libs-2.30.2-14.el6.i686
    Dec 21 12:29:20 Updated: gnome-session-2.28.0-18.el6.i686
    Dec 21 12:29:20 Updated: gnome-session-xsession-2.28.0-18.el6.i686
    Dec 21 12:29:35 Updated: gnome-panel-2.30.2-14.el6.i686
    Dec 21 12:29:52 Updated: 1:gnome-applets-2.28.0-7.el6.centos.i686
    Dec 21 12:30:00 Updated: gnome-power-manager-2.28.3-5.el6.i686
    Dec 21 12:30:07 Updated: gnome-system-monitor-2.28.0-9.el6.i686
    Dec 21 12:30:16 Updated: gnome-terminal-2.31.3-7.el6.i686
    Dec 21 12:30:24 Updated: gnome-screensaver-2.28.3-18.el6.i686
    Dec 22 00:04:53 Updated: libacl-2.2.49-6.el6.i686
    Dec 22 00:04:54 Updated: libacl-devel-2.2.49-6.el6.i686
    Dec 22 00:04:55 Updated: coreutils-libs-8.4-16.el6.i686
    Dec 22 00:05:01 Updated: coreutils-8.4-16.el6.i686
    Dec 22 00:05:02 Updated: acl-2.2.49-6.el6.i686
    Dec 22 00:41:31 Updated: webkitgtk-1.2.6-2.el6_0.i686
    Dec 22 04:17:34 Updated: pixman-0.18.4-1.el6_0.1.i686
    Dec 22 04:17:36 Updated: xorg-x11-server-common-1.10.4-6.el6_2.1.i686
    Dec 22 04:17:38 Updated: pixman-devel-0.18.4-1.el6_0.1.i686
    Dec 22 04:17:42 Updated: xorg-x11-server-Xorg-1.10.4-6.el6_2.1.i686
    Dec 22 04:38:15 Updated: binutils-2.20.51.0.2-5.28.el6.i686
    Dec 22 04:53:12 Updated: 1:cups-libs-1.4.2-44.el6.i686
    Dec 22 04:53:18 Updated: 1:cups-1.4.2-44.el6.i686
    Dec 22 06:04:20 Updated: evince-libs-2.28.2-14.el6_0.1.i686
    Dec 22 06:04:30 Updated: evince-2.28.2-14.el6_0.1.i686
    Dec 22 06:04:31 Updated: evince-dvi-2.28.2-14.el6_0.1.i686
    Dec 22 06:29:32 Updated: selinux-policy-3.7.19-126.el6_2.4.noarch
    Dec 22 06:30:06 Updated: selinux-policy-targeted-3.7.19-126.el6_2.4.noarch
    Dec 22 10:51:08 Updated: nspr-4.8.8-3.el6.i686
    Dec 22 10:51:10 Updated: nspr-devel-4.8.8-3.el6.i686
    Dec 22 10:51:11 Updated: nss-util-3.12.10-2.el6.i686
    Dec 22 10:51:12 Updated: nss-util-devel-3.12.10-2.el6.i686
    Dec 22 10:51:13 Updated: nss-softokn-freebl-3.12.9-11.el6.i686
    Dec 22 10:51:13 Updated: nss-softokn-3.12.9-11.el6.i686
    Dec 22 10:51:14 Installed: nss-softokn-freebl-devel-3.12.9-11.el6.i686
    Dec 22 10:51:15 Updated: nss-3.12.10-17.el6_2.i686
    Dec 22 10:51:16 Updated: nss-sysinit-3.12.10-17.el6_2.i686
    Dec 22 10:51:17 Updated: nss-softokn-devel-3.12.9-11.el6.i686
    Dec 22 10:51:17 Updated: libcurl-7.19.7-26.el6_1.2.i686
    Dec 22 10:51:23 Updated: xulrunner-1.9.2.24-2.el6.centos.1.i686
    Dec 22 10:51:29 Updated: firefox-3.6.24-3.el6.centos.i686
    Dec 22 10:51:30 Updated: libcurl-devel-7.19.7-26.el6_1.2.i686
    Dec 22 10:51:32 Updated: nss-devel-3.12.10-17.el6_2.i686
    Dec 22 10:51:32 Updated: curl-7.19.7-26.el6_1.2.i686
    Dec 22 10:51:34 Updated: nss-tools-3.12.10-17.el6_2.i686
    Dec 22 11:47:57 Updated: kdm-4.3.4-22.el6.i686
    Dec 22 12:00:20 Updated: libxml2-2.7.6-4.el6.i686
    Dec 22 12:00:23 Updated: libxml2-devel-2.7.6-4.el6.i686
    Dec 22 12:00:24 Updated: libxml2-python-2.7.6-4.el6.i686
    Dec 22 12:30:29 Installed: celt051-0.5.1.3-0.el6.i686
    Dec 22 12:30:30 Installed: spice-glib-0.6-2.el6.i686
    Dec 22 12:30:31 Installed: spice-gtk-0.6-2.el6.i686
    Dec 22 12:30:32 Installed: spice-gtk-python-0.6-2.el6.i686
    Dec 22 12:30:34 Updated: python-virtinst-0.600.0-5.el6.noarch
    Dec 22 12:30:40 Updated: virt-manager-0.9.0-7.el6.i686
    Dec 23 04:53:35 Updated: qt3-3.3.8b-30.el6.i686
    Dec 23 04:53:45 Updated: qt3-devel-3.3.8b-30.el6.i686
    Dec 23 05:24:27 Updated: system-config-date-1.9.60-1.el6.centos.noarch
    Dec 23 05:30:39 Updated: xkeyboard-config-2.3-1.el6.noarch
    Dec 23 05:38:25 Updated: openldap-2.4.23-20.el6.i686
    Dec 23 05:38:27 Updated: openldap-devel-2.4.23-20.el6.i686
    Dec 23 05:38:28 Updated: 1:compat-openldap-2.3.43-2.el6.i686
    Dec 23 05:45:56 Updated: alsa-lib-1.0.22-3.el6.i686
    Dec 23 05:45:59 Updated: alsa-lib-devel-1.0.22-3.el6.i686
    Dec 23 07:18:56 Updated: libuuid-2.17.2-12.4.el6.i686
    Dec 23 07:18:57 Updated: libblkid-2.17.2-12.4.el6.i686
    Dec 23 07:19:00 Updated: util-linux-ng-2.17.2-12.4.el6.i686
    Dec 23 08:30:24 Updated: postgresql-libs-8.4.9-1.el6_1.1.i686
    Dec 23 08:30:30 Updated: postgresql-8.4.9-1.el6_1.1.i686
    Dec 23 08:30:34 Updated: postgresql-server-8.4.9-1.el6_1.1.i686
    Dec 23 08:30:37 Updated: postgresql-devel-8.4.9-1.el6_1.1.i686
    Dec 23 08:30:39 Updated: postgresql-docs-8.4.9-1.el6_1.1.i686
    Dec 26 18:34:59 Updated: 1:java-1.6.0-openjdk-1.6.0.0-1.42.1.10.4.el6_2.i686
    Dec 26 18:35:05 Updated: 1:java-1.6.0-openjdk-devel-1.6.0.0-1.42.1.10.4.el6_2.i686
    Dec 27 03:43:03 Updated: 1:perl-Pod-Escapes-1.04-119.el6_1.1.i686
    Dec 27 03:43:04 Updated: 3:perl-version-0.77-119.el6_1.1.i686
    Dec 27 03:43:04 Updated: 1:perl-Module-Pluggable-3.90-119.el6_1.1.i686
    Dec 27 03:43:06 Updated: 1:perl-Pod-Simple-3.13-119.el6_1.1.i686
    Dec 27 03:43:11 Updated: 4:perl-libs-5.10.1-119.el6_1.1.i686
    Dec 27 03:43:26 Updated: 4:perl-5.10.1-119.el6_1.1.i686
    Dec 27 03:43:27 Updated: 1:perl-Locale-Maketext-Simple-0.18-119.el6_1.1.i686
    Dec 27 03:43:28 Updated: 1:perl-Params-Check-0.26-119.el6_1.1.i686
    Dec 27 03:43:28 Updated: 1:perl-Module-Load-0.16-119.el6_1.1.i686
    Dec 27 03:43:29 Updated: perl-Module-Load-Conditional-0.30-119.el6_1.1.i686
    Dec 27 03:43:30 Updated: 1:perl-IPC-Cmd-0.56-119.el6_1.1.i686
    Dec 27 03:43:32 Updated: perl-Test-Harness-3.23-1.el6.rfx.noarch
    Dec 27 03:43:33 Updated: perl-ExtUtils-MakeMaker-6.55-119.el6_1.1.i686
    Dec 27 03:43:34 Updated: 1:perl-ExtUtils-ParseXS-2.2003.0-119.el6_1.1.i686
    Dec 27 03:43:35 Updated: 4:perl-devel-5.10.1-119.el6_1.1.i686
    Dec 27 03:43:36 Updated: perl-Test-Simple-0.98-1.el6.rfx.noarch
    Dec 27 03:43:37 Updated: 1:perl-Log-Message-0.02-119.el6_1.1.i686
    Dec 27 03:43:38 Updated: perl-IO-Compress-Base-2.020-119.el6_1.1.i686
    Dec 27 03:43:39 Updated: 1:perl-Package-Constants-0.02-119.el6_1.1.i686
    Dec 27 03:43:40 Updated: perl-Log-Message-Simple-0.06-1.el6.rfx.noarch
    Dec 27 03:43:40 Updated: perl-Term-UI-0.26-1.el6.rfx.i686
    Dec 27 03:43:41 Updated: perl-Module-CoreList-2.25-1.el6.rfx.noarch
    Dec 27 03:43:42 Updated: 1:perl-ExtUtils-CBuilder-0.27-119.el6_1.1.i686
    Dec 27 03:43:43 Updated: 1:perl-Archive-Extract-0.38-119.el6_1.1.i686
    Dec 27 03:43:43 Updated: perl-File-Fetch-0.26-119.el6_1.1.i686
    Dec 27 03:43:44 Updated: 1:perl-Object-Accessor-0.34-119.el6_1.1.i686
    Dec 27 03:43:44 Updated: 1:perl-Module-Loaded-0.02-119.el6_1.1.i686
    Dec 27 03:43:45 Updated: 1:perl-Parse-CPAN-Meta-1.40-119.el6_1.1.i686
    Dec 27 03:43:47 Updated: perl-CPANPLUS-0.88-119.el6_1.1.i686
    Dec 27 03:43:48 Updated: 1:perl-Module-Build-0.3607-1.el6.rfx.noarch
    Dec 27 03:43:49 Updated: perl-ExtUtils-Embed-1.28-119.el6_1.1.i686
    Dec 27 03:43:50 Installed: perl-CGI-3.51-119.el6_1.1.i686
    Dec 27 03:43:51 Updated: 1:perl-parent-0.221-119.el6_1.1.i686
    Dec 27 03:43:52 Updated: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.i686
    Dec 27 03:43:53 Updated: perl-IO-Compress-Zlib-2.020-119.el6_1.1.i686
    Dec 27 03:43:54 Updated: perl-Compress-Zlib-2.020-119.el6_1.1.i686
    Dec 27 03:43:55 Updated: 1:perl-IO-Zlib-1.09-119.el6_1.1.i686
    Dec 27 03:43:57 Updated: 1:perl-Digest-SHA-5.47-119.el6_1.1.i686
    Dec 27 03:43:58 Updated: perl-CPAN-1.9402-119.el6_1.1.i686
    Dec 27 03:43:59 Updated: perl-Archive-Tar-1.58-119.el6_1.1.i686
    Dec 27 03:44:08 Updated: subversion-1.6.15-0.1.el6.rfx.i686
    Dec 27 03:44:09 Updated: 1:perl-Time-Piece-1.20-1.el6.rfx.i686
    Dec 27 03:44:10 Updated: 4:perl-Time-HiRes-1.9721-119.el6_1.1.i686
    Dec 27 03:44:11 Updated: perl-core-5.10.1-119.el6_1.1.i686
    Dec 27 03:44:12 Updated: subversion-javahl-1.6.15-0.1.el6.rfx.i686
    Dec 27 11:04:34 Updated: samba-winbind-clients-3.5.10-114.el6.i686
    Dec 27 11:04:40 Updated: samba-common-3.5.10-114.el6.i686
    Dec 27 11:04:45 Updated: samba-client-3.5.10-114.el6.i686
    Dec 27 11:04:47 Updated: libsmbclient-3.5.10-114.el6.i686
    Dec 29 12:51:34 Updated: kernel-firmware-2.6.32-220.2.1.el6.centos.plus.noarch
    Dec 29 12:51:52 Installed: kernel-2.6.32-220.2.1.el6.centos.plus.i686
    Dec 29 13:22:35 Updated: 1:NetworkManager-glib-0.8.1-15.el6.i686
    Dec 29 13:22:40 Updated: 1:NetworkManager-0.8.1-15.el6.i686
    Dec 29 13:22:52 Updated: 1:NetworkManager-gnome-0.8.1-15.el6.i686
    Dec 29 13:56:44 Updated: krb5-libs-1.9-22.el6_2.1.i686
    Dec 29 13:56:46 Updated: krb5-workstation-1.9-22.el6_2.1.i686
    Dec 29 13:56:48 Updated: krb5-devel-1.9-22.el6_2.1.i686
    Dec 29 14:20:43 Updated: qpid-cpp-client-0.12-6.el6.i686
    Dec 29 14:20:46 Updated: qpid-cpp-server-0.12-6.el6.i686
    Dec 29 14:20:47 Installed: qpid-qmf-0.12-6.el6.i686
    Dec 29 14:20:47 Erased: qmf
    Dec 29 14:28:16 Updated: fuse-2.8.3-4.el6.i686
    Dec 29 14:37:03 Updated: 7:kdeadmin-4.3.4-5.el6.i686
    Dec 29 18:27:05 Updated: crash-5.1.8-1.el6.i686
    Dec 29 18:37:37 Updated: 1:dovecot-2.0.9-2.el6_1.1.i686
    Dec 29 18:55:12 Updated: xerces-j2-2.7.1-12.6.el6_0.i686
    Dec 30 00:20:07 Updated: filesystem-2.4.30-3.el6.i686
    Dec 30 04:49:04 Updated: php-common-5.3.3-3.el6_1.3.i686
    Dec 30 04:49:06 Updated: php-cli-5.3.3-3.el6_1.3.i686
    Dec 30 04:49:08 Updated: php-5.3.3-3.el6_1.3.i686
    Dec 30 04:49:09 Updated: php-pdo-5.3.3-3.el6_1.3.i686
    Dec 30 04:49:10 Updated: php-gd-5.3.3-3.el6_1.3.i686
    Dec 30 04:49:10 Updated: php-xml-5.3.3-3.el6_1.3.i686
    Dec 30 09:28:40 Updated: oprofile-0.9.6-21.el6.i686
    Dec 31 11:15:28 Updated: oxygen-cursor-themes-4.3.4-22.el6.noarch
    Dec 31 11:15:36 Updated: kdebase-workspace-wallpapers-4.3.4-22.el6.noarch
    Dec 31 11:15:37 Updated: ksysguardd-4.3.4-22.el6.i686
    Dec 31 11:15:39 Updated: kdebase-workspace-libs-4.3.4-22.el6.i686
    Dec 31 11:15:54 Updated: kdebase-workspace-4.3.4-22.el6.i686
    Jan 01 03:00:57 Updated: 6:kdelibs-4.3.4-11.el6_1.4.i686
    Jan 01 08:14:54 Updated: 1:valgrind-3.6.0-4.el6.i686



    Thanks for viewing this thread!

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    It's hard to tell from that list...but at least I see xorg-x11-server-xorg in there. Btw, are your dates screwy or something? Those dates look old.

    As to your repos, you're right - mixing them can be bad. what repos do you have enabled?

    Code:
    yum repolist

  7. #7
    Linux Newbie theKbStockpiler's Avatar
    Join Date
    Sep 2010
    Location
    Upstate NY
    Posts
    205

    Unhappy Thanks for the Reply!

    I usually suspend my computer so it boots faster. So unless there is a power outage I warm boot for months consecutively. I do a few updates at a time and not all at once so and that was the entire yum log from when it was originally installed. I have the original CentOS repos and along with CentOS plus. There is puias in there but those where just individual RPM files.

    X was updated by CentOS and the kernel was updated by CentOS plus. X won't start from the original kernel so I don't understand what happened. It looks like CentOS's own updates broke it.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    If you had the proprietary nVidia drivers installed, changing the kernel requires that you also reinstall the video driver. The CentOS plus kernel is different from the normal kernel, so this would also be the case. Switching back to the original kernel should work, but maybe not if the plus kernel has the nouveau driver installed by default.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Linux Newbie theKbStockpiler's Avatar
    Join Date
    Sep 2010
    Location
    Upstate NY
    Posts
    205

    Thanks for the Replies!

    My mainboard has a Integrated Intel gmax 4500 gpu. I'm thinking something happened that caused a faulty update.

  10. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    This line from your Xorg log looks suspicious:

    Code:
    [ 372.892] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol:
    I have a possible suggestion, though it is not pretty. It would save you from doing a complete reinstall though (if it works).

    You can manually remove that driver, along with the Xorg server, and revert to the older ones. Get the version of the currently installed one:
    Code:
    rpm -qf /usr/lib/xorg/modules/drivers/intel_drv.so
    Get the version of Xorg, too:
    Code:
    rpm -qf /usr/bin/Xorg
    Compare them to what is the latest available in CentOS 6.x:
    xorg-x11-server-Xorg-1.10.4-6.el6_2.1
    xorg-x11-drv-intel-2.16.0-1.el6

    and what comes with stock CentOS 6.0:
    xorg-x11-server-Xorg-1.7.7-26.el6
    xorg-x11-drv-intel-2.11.0-7.el6

    You can then remove them like this:
    Code:
    rpm -e xorg-x11-server-Xorg xorg-x11-drv-intel
    The command will probably fail b/c of the package dependencies. For example, I would see (on my RHEL 4 box):
    Code:
    [root@localhost ~]# rpm -e xorg-x11-server-Xorg xorg-x11-server-intel
    error: Failed dependencies:
            xorg-x11-server-Xorg >= 1.4.99.1 is needed by (installed) xorg-x11-drv-vesa-2.3.0-1.el6.x86_64
            xorg-x11-server-Xorg >= 1.5.99.1 is needed by (installed) xorg-x11-drv-evdev-2.3.2-8.el6.x86_64
            xorg-x11-server-Xorg >= 1.4.99.1 is needed by (installed) xorg-x11-drv-void-1.3.0-4.el6.x86_64
            xorg-x11-server-Xorg >= 1.5.99.1 is needed by (installed) xorg-x11-drv-mouse-1.5.0-4.el6.x86_64
            xorg-x11-server-Xorg >= 1.5.99.1 is needed by (installed) xorg-x11-drv-keyboard-1.4.0-3.el6.x86_64
            xorg-x11-server-Xorg >= 1.6.0-2 is needed by (installed) xorg-x11-drv-synaptics-1.2.1-5.el6.x86_64
    So I would run the rpm erase command again, this time appending all those packages to the list, e.g.:
    Code:
    rpm -e xorg-x11-server-Xorg \
      xorg-x11-server-intel \
      xorg-x11-drv-vesa \
      xorg-x11-drv-evdev \
      xorg-x11-drv-void \
      xorg-x11-drv-mouse \
      xorg-x11-drv-keyboard \
      xorg-x11-drv-synaptics
    You can then go to the original CentOS 6.0 repo and download the packages manually:

    http://vault.centos.org/6.0/os/i386/Packages/

    Specifically, you should see these two RPMS in that dir:

    xorg-x11-server-Xorg-1.7.7-26.el6.i686.rpm

    xorg-x11-drv-intel-2.11.0-7.el6.i686.rpm

    but you may also need to download some of those other dependency packages, too (the ones that might have caused a failure to remove the xorg-x11-server-Xorg package initially).

    Once you have all of your newly downloaded RPMS together in one directory, you can attempt an install of them:

    Code:
    rpm -ivh xorg-*.rpm
    When all the dust settles, you can also try regenerating your Xorg config file:

    Code:
    X -configure
    If that does work, you'll want to tell yum to NOT update those xorg packages in the future (man yum.conf and look for exclude).

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •