Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, i have setup linux 6 httpd server for network installation: distribution: 2.6.32-19.el6.i686 here are my httpd.conf <VirtualHost 192.168.10.1:80> ServerAdmin rootatlocalhost DocumentRoot /data/ </VirtualHost> <Directory /data/network-install> Options +Indexes AllowOverride ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    19

    Thumbs up unable to start kickstart installation


    Hi all,

    i have setup linux 6 httpd server for network installation:
    distribution: 2.6.32-19.el6.i686

    here are my httpd.conf

    <VirtualHost 192.168.10.1:80>
    ServerAdmin rootatlocalhost
    DocumentRoot /data/
    </VirtualHost>

    <Directory /data/network-install>
    Options +Indexes
    AllowOverride AuthConfig
    order allow,deny
    allow from all
    </Directory>


    i have setup /data/network-install/ directory for network installation.
    i have created ks.cfg in /data/network-install/kickstart/ks.cfg

    in ks.cfg the first line is

    install
    url --url=...://192.168.10.1/network-install/

    which seems correct.

    i have modified boot.iso to include ks path in isolinux.cfg as
    append initrd=initrd.img ks=...://192.168.10.1/network-install/kickstart/ks.cfg

    note: i have ... to denote http
    since this post did not allow me to post http url.
    now when i am opening client machine ..it is booting in kickstart mode but i am getting errors:

    Error in <h1>Forbidden</h1> on line 6 of kickstart file /tmp/ks.cfg

    click ok and another error is:

    Error in <hr> on line 9 of kickstart file /tmp/ks.cfg
    (loader:54): Glib-CRITICAL **: unquote_string_inplace: assertion 'err == NULL || *err == NULL' failed



    is it wrong configuration?
    shall i place ks.cfg in /data/ which is root of web server?

    also if you have goog step by step guide to do kickstart installation please?

    Regards,

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,318
    Hey,

    Instead of putting your URL in your kickstart file, try passing it on the command line, when you execute the kernel. You can do it in isolinux, syslinux, grub, whatever. Here's an example of how I might specify a RHEL 6 installation over PXE. The notable portions are the ks= and the repo= lines. You can figure out what to put there.

    Code:
    # RHEL 6.0
    label rhel6
      kernel vmlinuz
      append initrd=initrd.img ks=http://192.168.1.1/RHEL-minimal.ks repo=http://192.168.1.1/redhat/enterprise/6/en/os/x86_64/ ramdisk_size=8192
    The quick way to test whether your ks and repo lines are working is by simply trying to load their respective URLS in a browser from another machine on the same network: if you can't load them in that page, then they won't work in the install.

    BTW, you can keep your kickstart file dead simple, at first. Here's an example of a simple one:
    Code:
    #System language
    lang en_US
    
    #System keyboard
    keyboard us
    
    #Installation Type
    install
    
    #System timezone
    timezone --utc Europe/London
    
    #System authorization information
    auth --useshadow --enablemd5
    
    #SELinux
    selinux --disabled
    
    #Firewall configuration
    firewall --disabled
    
    #Do not configure the X Window System
    #skipx
    
    #Bootloader
    bootloader --location=mbr --append="selinux=0 vga=0x318"
    
    #Root password
    rootpw --iscrypted $1$abcdefghijklmnopqrstuvwzyz
    
    # Prevent the Setup Agent from launching, the first time the system is booted
    firstboot --disabled
    
    # services to disable
    --disabled=kudzu,NetworkManager,NetworkManagerDispatcher,avahi-daemon,cups,netconsole,netfs,ntpd,rdisc,wpa_supplicant --enabled=network
    
    #Package install information, for 'install' only
    %packages --nobase
    @Core
    openssh-clients
    openssh-server
    Here's a good list of Anaconda options that you can put in your kickstart file:
    Anaconda/Kickstart - FedoraProject

    And here's Anacona boot options that you can pass to the kernel (installer) at boot time:
    Anaconda Boot Options - FedoraProject

    They are Fedora-specific, but in reality should mostly apply to RHEL.

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    19
    Hi thanks for reply,

    i have found the solution for above problem. i found that that permission for file was incorrect. it was set to rw-------
    i modified to 755. and it worked.
    but there is another problem now. when i boot to kickstart. after selecting eth0 and on next wizard it showed to choose partition to for network image for installation . it gave me two options to choose that from /dev/sda1 and /dev/sda2. when i pressed back and typed the http url manually it worked. rest of the installation of even partitions were created automatically as set in ks file.

    i think i need to modify something. to skip this /dev/sda1 and dev/sda2 prompt

    Regards,
    parkar
    UAE

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,318
    that sounds like a typo in the URL in your kickstart file, or in your kernel boot parameters, whichever you chose. How and where are you specifying it? Check the apache error log for helpful hints, too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •