Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
hello I am facing problem in changing default boot option in grub loader in fc16 . Sometimes I would like the default OS as windows ,but iam not getting the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8

    how to change default boot option from grub loader in fedora 16


    hello
    I am facing problem in changing default boot option in grub loader in fc16 .
    Sometimes I would like the default OS as windows ,but iam not getting the desktop switching tool in FC16.

    Please help me out.
    DB

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    Posts
    8
    If i remember right, open /etc/grub.conf

    and change "default=0" to "default=1" or whatever your windows is listed as

  3. #3
    Just Joined! pradeeprajkumar's Avatar
    Join Date
    Jun 2010
    Location
    India
    Posts
    72
    Quote Originally Posted by dineshbij75 View Post
    iam not getting the desktop switching tool in FC16.
    You might have set a very low timeout value in the
    Code:
    /etc/grub.conf
    file
    Timeout is given input in seconds.So, give as much seconds as you need there!
    for example:
    Code:
    timeout=10
    While booting, press UP or DOWN arrow keys to switch between the booting options of os's.

  4. #4
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8
    I want to change the default booting option from linux to windows but specifically in FC16.
    In FC16 no such options are available.Is there any desktop switching tools are available or not.

  5. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Since Fedora 16 uses GRUB 2, edit your /etc/default/grub file.
    Look for GRUB_DEFAULT=x. Change it to the entry number for your Windows install. Then run:
    Code:
    sudo update-grub
    GRUB starts counting at 0. So the first entry would be 0. Second entry is 1. And so on...
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  6. #6
    Just Joined! pradeeprajkumar's Avatar
    Join Date
    Jun 2010
    Location
    India
    Posts
    72
    Quote Originally Posted by dineshbij75 View Post
    Is there any desktop switching tools are available or not.
    In fedora 15, Bootloader application allows us to configure the default booting and default timeout options through GUI mode.(I guess it might be available in fedora 16 too)
    Bootloader can be found in,
    Applications->others->bootloader

  7. #7
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8
    Quote Originally Posted by pradeeprajkumar View Post
    In fedora 15, Bootloader application allows us to configure the default booting and default timeout options through GUI mode.(I guess it might be available in fedora 16 too)
    Bootloader can be found in,
    Applications->others->bootloader
    I am facing in running the command sudo update-grub, It is giving error saying command not found.
    Please help me out.

  8. #8
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Fedora doesn't enable sudo by default.
    Have you tried:
    Code:
    su -
    <enter root password>
    update-grub
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  9. #9
    Just Joined!
    Join Date
    Feb 2011
    Posts
    21
    modify /etc/grub.conf. Find the WIndows "paragraph" and put it at the top of the list

  10. #10
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8
    Quote Originally Posted by jayd512 View Post
    Fedora doesn't enable sudo by default.
    Have you tried:
    Code:
    su -
    <enter root password>
    update-grub
    My grub entries are like this, now suggest what to do as my windows entry is on fourth line of grub loader during boot process.
    [root@localhost dinesh]# cat /etc/default/grub
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR="Fedora"
    GRUB_DEFAULT=3
    GRUB_CMDLINE_LINUX="rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks=0 LANG=en_US.UTF-8"

    I update grub but giving following error

    [dinesh@localhost ~]$ su
    Password:
    [root@localhost dinesh]# vi /etc/default.grub
    [root@localhost dinesh]# update-grub
    bash: update-grub: command not found...

    Please check it and suggest

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •