Find the answer to your Linux question:
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By Jonathan183
So, i basically use my computer to browsing the web, downloading files, and some light use or photoshop and dreamweaver. And all tose things can be done on Linux (Photoshop ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    4

    Unhappy Decided to move from Windows to Fedora.... But my printer wont let me


    So, i basically use my computer to browsing the web, downloading files, and some light use or photoshop and dreamweaver. And all tose things can be done on Linux (Photoshop and dreamweaver with wine or virtualization).

    Im decided to move to fedora, but there is one little thing that wont let me... My printer!

    I have an HP Laserjet Pro P1102w. I have tryed with the hplip's and the foo2zjs drivers, and allways happens the same:
    After installing the driver, i can print normally, but as soon as i poweroff the computer, or i reboot it, i wont be Able to print anymore.
    I can see the printer listed on the lsusb output, but when i send a Job to print, it doesnt happen anything, it just get in the printer spool and the printer appears as being disconnected or turned off.


    The only solution that I found was to reset the printer (by long pressing the power button) but tris is really annoying!


    So, if someone has a p1102w and has solved thing problem, or someone is Willing to help, I will really appreciate it, because, as o said, tenis problem is the only thing that is stopping me from permanently move from Windows to Linux.

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    assuming you are using cups as a print server ... have you tried pause and resume of the printer? cups web interface should be available from Open Source and Linux Forums with online info here

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    4
    Yes, i did, and i receive this message:

    Code:
    Pause Printer HP-LaserJet-Professional-P1102w Error
    
    Unable to do maintenance command:
    
        Forbidden


    However, i can stop/cancel jobs, so i think that its not a permissions issue.

  4. #4
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    you can probably stop/cancel your own print jobs ... check admin information. Check contents of /etc/cups/cupsd.conf SystemGroup and check you are in the relevant group. Last time I setup printing I used info from here ... but then again I use Arch

  5. #5
    Just Joined!
    Join Date
    Jan 2012
    Posts
    4
    You were right, i wasnt on the SystemGroup and that is why I couldnt pause the printer.
    However, this didnt solved my problem.



    Also, i was experimenting with the hp-setup, and I installed the printer as a WIFI printer, and now its working perfect! (as wifi).


    However, i would like to know WHY it doesnt work when connected via USB.

    The only difference i found in CUPS is this:

    Code:
    HP LaserJet Professional P1102w	localhost.localdomain hpcups 3.11.10, requires proprietary plugin	Idle
    HP LaserJet Professional p1102w hpijs, 3.11.10, requires proprietary plugin	Idle - "ready to print"
    The usb connected printer is using the hpcups driver, and when its connected via wifi, its using the hpijs driver...


    any idea?

  6. #6
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    You should be able to select the driver and use the hpijs driver for a wired connection as well ...
    Lilbighorn likes this.

  7. #7
    Just Joined!
    Join Date
    Jan 2012
    Posts
    4
    I updated the HPLIP package, and selected hpijs, and now everything is working awesomely!


    Thanks for your help, Jonathan!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •