Find the answer to your Linux question:
Results 1 to 2 of 2
Dear all, I am new on mdadm software RAID. I tested on CentOS 5 and 6 successfully that install /boot on RAID1 drives. I tried to unplug hard disk A ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    2

    mdadm software RAID works fine in CentOS 5/6 but got problem in RHEL 6


    Dear all,

    I am new on mdadm software RAID. I tested on CentOS 5 and 6 successfully that install /boot on RAID1 drives. I tried to unplug hard disk A and it can boot up with the hard disk B. Also, I tried to unplug hard disk B and it can boot up with the hard disk A too.

    However, I am using RHEL 6.1 now without luck. I installed /boot on RAID 1 drives as usual, but after unplug hard disk A (or B) and remain another hard disk, the server can't boot up. I disabled "quiet" in boot parameters, so I got error below:

    md: bind<sda1>
    md: bind<sda2>
    dracut Warning: No root device "block:/dev/disk/by-uuid/b8e83903-7096-4abd-ac90-689ca2a37f2c" found



    after adding "rdshell" in boot parameters then I can check directory "/dev/disk", I found that there are "by-id" and "by-path" directories, but no "by-uuid" .


    I was thinking whether it is GRUB problem, so i ran "/sbin/grub-install /dev/sda" and "/sbin/grub-install /dev/sda" (while I boot with 2 hard disks normally), but it does not help.

    Below are some information of the RAID, please can someone teach me how can I boot single hard disk while the RAID 1 degraded?

    # cat /etc/mdadm.conf
    # mdadm.conf written out by anaconda
    MAILADDR root
    AUTO +imsm +1.x -all
    ARRAY /dev/md0 level=raid1 num-devices=2 UUID=d4a9986b:fe4e587c:b5a91460:da5fd050
    ARRAY /dev/md1 level=raid1 num-devices=2 UUID=4e18987c:ff846e24:7b6a8935:34d7d230


    # mdadm --detail --scan
    ARRAY /dev/md1 metadata=1.0 name=localhost.localdomain:1 UUID=4e18987c:ff846e24:7b6a8935:34d7d230
    ARRAY /dev/md0 metadata=1.1 name=localhost.localdomain:0 UUID=d4a9986b:fe4e587c:b5a91460:da5fd050


    # cat /etc/grub.conf
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You do not have a /boot partition. This means that
    # all kernel and initrd paths are relative to /, eg.
    # root (hd0,1)
    # kernel /boot/vmlinuz-version ro root=/dev/md1
    # initrd /boot/initrd-[generic-]version.img
    #boot=/dev/sda
    default=0
    timeout=5
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    hiddenmenu
    title Red Hat Enterprise Linux (2.6.32-220.el6.x86_64)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.32-220.el6.x86_64 ro root=UUID=b8e83903-7096-4abd-ac90-689ca2a37f2c rd_NO_LUKS KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_MD_UUID=d4a9986b:fe4e587c:b5a91460:da5fd050 rd_MD_UUID=4e18987c:ff846e24:7b6a8935:34d7d230 SYSFONT=latarcyrheb-sun16 rhgb crashkernel=auto quiet rd_NO_LVM rd_NO_DM
    initrd /boot/initramfs-2.6.32-220.el6.x86_64.img


    # cat /etc/fstab

    #
    # /etc/fstab
    # Created by anaconda on Tue Feb 7 11:08:14 2012
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    UUID=b8e83903-7096-4abd-ac90-689ca2a37f2c / ext4 defaults 1 1
    UUID=e60fd9cd-b4a3-4cfd-8c20-8e68ab89401f swap swap defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0

  2. #2
    Just Joined!
    Join Date
    Feb 2012
    Posts
    2
    I think that my problem is exactly same as this one: bugzilla.redhat.com/show_bug.cgi?id=772926, does anyone know how to solve it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •