Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all! I'm configuring a PC for a university project using Linux RedHat 6. The problem is as follows: after installing the repositi RPMFusion me a great mistake "Error: Can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    6

    RedHat Problem


    Hi all!

    I'm configuring a PC for a university project using Linux RedHat 6.

    The problem is as follows: after installing the repositi RPMFusion me a great mistake
    "Error: Can not retrieve repository metadata (repomd.xml) for repository: rpmfusion-free. ITS Please verify path and try again." I searched on google and there are "MANY" that have the same problem but none of their solutions has fixed my problem.

    I've also tried uninstalling and reinstalling both repositi that the entire OS with a clean install but the problem remains.

    Maybe someone with more linux experience can give me a hand.

    thanks
    Last edited by Lorius; 02-08-2012 at 10:21 AM.

  2. #2
    Just Joined!
    Join Date
    Feb 2012
    Posts
    6
    I solved the problem alone!
    now the big problem is VLC.

    it's give me this errors
    Loaded plugins: product-id, refresh-packagekit, subscription-manager
    Updating certificate-based repositories.
    Setting up Local Package Process
    Examining ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386.rpm: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    Marking ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386.rpm to be installed
    rhel-6-desktop-beta-debug-rpms | 1.3 kB 00:00
    rhel-6-desktop-beta-rpms | 4.0 kB 00:00
    rhel-6-desktop-beta-source-rpms | 1.3 kB 00:00
    rhel-6-desktop-debug-rpms | 2.9 kB 00:00
    rhel-6-desktop-optional-beta-debug-rpms | 1.3 kB 00:00
    rhel-6-desktop-optional-beta-rpms | 3.8 kB 00:00
    rhel-6-desktop-optional-beta-source-rpms | 1.3 kB 00:00
    rhel-6-desktop-optional-debug-rpms | 2.9 kB 00:00
    rhel-6-desktop-optional-rpms | 3.5 kB 00:00
    rhel-6-desktop-optional-source-rpms | 2.6 kB 00:00
    rhel-6-desktop-rpms | 3.7 kB 00:00
    rhel-6-desktop-source-rpms | 2.6 kB 00:00
    rhel-6-desktop-supplementary | 3.7 kB 00:00
    rhel-6-desktop-supplementary-beta | 4.0 kB 00:00
    rhel-6-desktop-supplementary-beta-debuginfo | 951 B 00:00
    rhel-6-desktop-supplementary-beta-src | 951 B 00:00
    rhel-6-desktop-supplementary-debuginfo | 2.5 kB 00:00
    rhel-6-desktop-supplementary-src | 2.6 kB 00:00
    Resolving Dependencies
    --> Running transaction check
    ---> Package ffmpeg.i386 0:0.4.9-0.20041110.3.0.rh7.rf will be installed
    --> Processing Dependency: libSDL-1.2.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libfaad.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libmp3lame.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libogg.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libpostproc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libvorbis.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libvorbisenc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libxvidcore.so.4 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libImlib2.so.1 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libttf.so.2 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Running transaction check
    ---> Package SDL.i686 0:1.2.14-2.el6 will be installed
    ---> Package ffmpeg.i386 0:0.4.9-0.20041110.3.0.rh7.rf will be installed
    --> Processing Dependency: libfaad.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libpostproc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libvorbisenc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libttf.so.2 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    ---> Package imlib2.i686 0:1.4.2-5.el6 will be installed
    --> Processing Dependency: libbz2.so.1 for package: imlib2-1.4.2-5.el6.i686
    --> Processing Dependency: libgif.so.4 for package: imlib2-1.4.2-5.el6.i686
    ---> Package lame-libs.i686 0:3.98.4-1.fc14 will be installed
    ---> Package libogg.i686 2:1.1.4-2.1.el6 will be installed
    ---> Package libvorbis.i686 1:1.2.3-4.el6 will be installed
    ---> Package xvidcore.i686 0:1.3.2-2.fc15 will be installed
    --> Running transaction check
    ---> Package bzip2-libs.i686 0:1.0.5-7.el6_0 will be installed
    ---> Package ffmpeg.i386 0:0.4.9-0.20041110.3.0.rh7.rf will be installed
    --> Processing Dependency: libfaad.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libpostproc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libvorbisenc.so.0 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    --> Processing Dependency: libttf.so.2 for package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386
    ---> Package giflib.i686 0:4.1.6-3.1.el6 will be installed
    --> Finished Dependency Resolution
    Error: Package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386 (/ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386)
    Requires: libpostproc.so.0
    Error: Package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386 (/ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386)
    Requires: libttf.so.2
    Error: Package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386 (/ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386)
    Requires: libvorbisenc.so.0
    Error: Package: ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386 (/ffmpeg-0.4.9-0.20041110.3.0.rh7.rf.i386)
    Requires: libfaad.so.0

    ffmpeg is installed. i downloaded the source code,compiled and installed.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    Get the atrpms repository, disable the rpmforge temporarily (you can do this on the yum command line when you install vlc and/or ffmpeg), and then install vlc and ffmpeg. FWIW, the atrpms repository's version of ffmpeg is up to 0.9-52. Anyway, your problem seems to be with ffmpeg, not VLC. If you want to disable an installed repository permanently, just go to /etc/yum.repos.d and edit the appropriate .repo file, such as rpmforge.repo, and set the line "enabled=1" to "enabled=0". That will take it out of the equation entirely, yet still be available if you want, by specifying on the yum command line "--enablerepo=rpmforge". Anyway, you should read the yum man page carefully. It will tell you just about anything you need to know about dealing with repositories from the command line.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Quote Originally Posted by Lorius View Post
    I solved the problem alone!
    now the big problem is VLC.
    I would like to add that it is great that you fixed this on your own, but it would have been best if you would have posted what you did to fix this so that the next person with this problem would know what you did. This would help the next person looking for an answer.

    It would also be nice if you started a new topic for your problems as if a thread gets too long it really doesn't help anyone as the information someone is looking for could be deep into the thread.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  5. #5
    Just Joined!
    Join Date
    Feb 2012
    Posts
    6
    Thank's! I had tried to write the solution to the problem but first I do 6 thread or does not put the link in this thread.
    soon as possible i post my solution.

    Get the atrpms repository, disable the rpmforge temporarily (you can do this on the yum command line when you install vlc and/or ffmpeg), and then install vlc and ffmpeg. FWIW, the atrpms repository's version of ffmpeg is up to 0.9-52. Anyway, your problem seems to be with ffmpeg, not VLC. If you want to disable an installed repository permanently, just go to /etc/yum.repos.d and edit the appropriate .repo file, such as rpmforge.repo, and set the line "enabled=1" to "enabled=0". That will take it out of the equation entirely, yet still be available if you want, by specifying on the yum command line "--enablerepo=rpmforge". Anyway, you should read the yum man page carefully. It will tell you just about anything you need to know about dealing with repositories from the command line.
    Thank's this has resolved my problem with vlc and other program

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •