Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I installed the beta version of Linux AS 4.0 Update 2. (Though when I do a cat /etc/issue i see.. [root@veas4th1 ~]# cat /etc/issue Red Hat Enterprise Linux AS ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15

    AS4 update two libraries issue..


    Hi,

    I installed the beta version of Linux AS 4.0 Update 2.

    (Though when I do a cat /etc/issue i see..

    [root@veas4th1 ~]# cat /etc/issue
    Red Hat Enterprise Linux AS release 3.90 (Nahant)
    Kernel \r on an \m

    Is that an issue? anyways..

    So I installed all cd's.. installed everything.. installed the compat layer cd forcing all packages.. and still, when I try to install a package of my own.. I get this..


    error: Failed dependencies:
    ld-linux.so.2 is needed by VRTSob-3.2.533-0.i686
    libc.so.6 is needed by VRTSob-3.2.533-0.i686
    libcrypt.so.1 is needed by VRTSob-3.2.533-0.i686
    libdl.so.2 is needed by VRTSob-3.2.533-0.i686
    libm.so.6 is needed by VRTSob-3.2.533-0.i686
    libnsl.so.1 is needed by VRTSob-3.2.533-0.i686
    libpthread.so.0 is needed by VRTSob-3.2.533-0.i686
    libc.so.6(GLIBC_2.0) is needed by VRTSob-3.2.533-0.i686
    libc.so.6(GLIBC_2.1) is needed by VRTSob-3.2.533-0.i686
    libcrypt.so.1(GLIBC_2.0) is needed by VRTSob-3.2.533-0.i686
    libdl.so.2(GLIBC_2.0) is needed by VRTSob-3.2.533-0.i686
    libdl.so.2(GLIBC_2.1) is needed by VRTSob-3.2.533-0.i686
    libm.so.6(GLIBC_2.0) is needed by VRTSob-3.2.533-0.i686
    libpthread.so.0(GLIBC_2.0) is needed by VRTSob-3.2.533-0.i686
    libpthread.so.0(GLIBC_2.1) is needed by VRTSob-3.2.533-0.i686
    [root@veas4th1 ~]# rpm -qa | grep ld-lin

    Ideas?

    Thanks
    -Nikhil.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try first running 'ldconfig' as root. If that doesn't fix it, try (re)installing glibc.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •