Find the answer to your Linux question:
Results 1 to 3 of 3
I have searched the forum posts but cannot find any help on the wake on LAN function in RHEL 5. My bios is set up to do WOL but I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    13

    RHEL 5 Wake on LAN Solution


    I have searched the forum posts but cannot find any help on the wake on LAN function in RHEL 5.

    My bios is set up to do WOL but I do not know how to make the ether-wake function work.

    I tried
    # ether-wake -p 00:22:19:0D:5B 00:11:22:33:44:55
    Unable to read Wake-On-Lan password

    Don't know how to do this right. Any help would be appreciated.

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Mar 2012
    Posts
    13
    OK, went to the site and did everything listed there (with tweeks for my config). But still unsuccessful. I ran the ethtool on eth0 on my server and on my test client machine and got this readout:

    [root@My-srvr-1 ~]# ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Current message level: 0x000000ff (255)
    Link detected: yes

    So is my Wake-on-LAN turned on? I think so with the "Supports Wake-on: g" and "Wake-on: g" line readouts.
    My client machine gives the same readouts. I have it's MAC address and used it below with ether-wake.

    Don't know what this is telling me:

    [root@My-srvr-1 ~]# ether-wake -vb 00:11:22:33:44:55 00:22:19:0B:5D
    ether-wake.c: v1.09 11/12/2003 Donald Becker,
    The hardware address (SIOCGIFHWADDR) of eth0 is type 1 00:1f:29:00:1f:03.


    I also ran this. I think this is an error telling me I didn't do something right.

    [root@My-srvr-1 ~]# ether-wake -i 00:22:19:0B:5D
    Specify the Ethernet address as 00:11:22:33:44:55.


    So how should I be writing this?
    My wol script is this: Is it messed up? Where should I put it? I have it in /etc/init.d right now. How do I activate it? Or is it already activated simply because it is a shell script? Should it not be executable? AHHHHHHH! Somebody help me please.

    #Got this script from edvoncken net/2011/02/configure-wake-on-lan-on-red-hat-enterprise-linux/
    #!/bin/bash
    # Source function library.
    . /etc/rc.d/init.d/functions
    NIC="eth0"
    if [ "$1" != "start" ]; then
    exit 0
    fi
    echo -n "Enabling Wake-on-LAN for:"
    for nic in ${NIC};
    do
    echo -n " ${nic}"
    [ -x /sbin/ethtool ] && /sbin/ethtool -s ${nic} wol g >/dev/null 2>&1
    done
    # Note: no error checking - ethtool does not return a useful exit code
    success
    echo
    # EOF

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •