Find the answer to your Linux question:
Results 1 to 2 of 2
installed mysql-5.5.21-1.fc16.i686, mysql-server-5.5.21-1.fc16.i68 from rpmfusion repo trying to run Code: sudo systemctl start mysqld.service error Code: Job failed. See system logs and 'systemctl status' for details. then ran Code: sudo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    95

    mysql Not starting on Fedora 16


    installed mysql-5.5.21-1.fc16.i686, mysql-server-5.5.21-1.fc16.i68 from rpmfusion repo
    trying to run
    Code:
    sudo systemctl start mysqld.service
    error
    Code:
    Job failed. See system logs and 'systemctl status' for details.
    then ran
    Code:
    sudo systemctl status mysqld.service
    result
    Code:
    mysqld.service - MySQL database server
    	  Loaded: loaded (/lib/systemd/system/mysqld.service; disabled)
    	  Active: failed since Wed, 28 Mar 2012 13:38:27 +0530; 1min 53s ago
    	 Process: 5100 ExecStartPost=/usr/libexec/mysqld-wait-ready $MAINPID (code=exited, status=1/FAILURE)
    	 Process: 4961 ExecStart=/usr/bin/mysqld_safe --nowatch --basedir=/usr (code=exited, status=0/SUCCESS)
    	 Process: 4945 ExecStartPre=/usr/libexec/mysqld-prepare-db-dir (code=exited, status=0/SUCCESS)
    	Main PID: 5098 (code=exited, status=1/FAILURE)
    	  CGroup: name=systemd:/system/mysqld.service
    How do I start the server??

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    check the output of the MySQL log, usually /var/log/mysqld.log, and also look in /var/log/messages. maybe there is additional info in one of them. it is possible that a required directory does not exist, or has the wrong permissions. also it may be a problem if it is an botched mysql-server upgrade. speaking of which, you can try updating the package, too, in case a fix was implemented:

    Code:
    yum update mysql-server
    also, is SELinux enabled? This can cause problems, too. Check if on with:
    Code:
    getenforce
    and temporarily (until a reboot) disable SELinux with:
    Code:
    setenforce 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •