Find the answer to your Linux question:
Results 1 to 9 of 9
Just installed FC3 and trying to get up2date to download important security updates. I run behind a proxy server, in the configuration of up2date i set the proxy port and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29

    up2date


    Just installed FC3 and trying to get up2date to download important security updates.

    I run behind a proxy server, in the configuration of up2date i set the proxy port and ip. When i try to run up2date the progress bar doesn't move on Fetching http://fedora.redhat.com/download/up...rs/header.info

    When i cancel the update and check the configuration the "Enable http proxy" tickbox is unticked.

    Is this why my updates don't proceed?

    Any help would be appreciated. Thanks in advance.

  2. #2
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Up2date is just very slow.
    Since you did a new install it has to get a lot of updates.
    (So even if it seems to crash it's atually still working)

    Better start with either Yum or Apt(recommended).

    As for Apt install this RPM (rpm -Uvh file.rpm):
    http://dag.wieers.com/packages/apt/a...c3.rf.i386.rpm
    Next do:
    #apt-get update
    #apt-get upgrade (this will do most of the updates)

    If you want a nice graphical tool for it:
    #apt-get install synaptic

    Synaptic can do the same as the command line.
    Start it from your GNOME menu or just type synaptic in a terminal.


    You also have yum(something I don't like myself).
    Since it's already installed all you have to do is:
    #yum update

    I don't recommend using Yum, but hey, that's all your choice.

    After updating with Apt(this also gives you a lot of new stuff you can install using synaptic), your up2date will work faster for the few remaining updates like your kernel(you can use Apt for this as well).

    Have fun.

  3. #3
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    OK thanks for the swift reply .. the update is now running smoothly.

    I can now get back to business surfing the web in (moderate) safety.

  4. #4
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    Just reinstalled fedora and tried to run yum as i did before. However, this time no packages are being detected, i assume this is because of my proxy settings. Could someone give me the commands that I entered (and forgot about just as quickly) to get yum, apt or up2date to detect my proxy settings and install these updates.

    Thanks again.

  5. #5
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    As for Apt, add the following in /etc/apt/apt.conf :
    Code:
    ACQUIRE
    {
      http
      {
        Proxy "http://proxy.somewhere.com:xxxx/";
      };
    };
    (don't forget to replace "http://proxy.somewhere.comxxx" with you own URL)

  6. #6
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada Eh!
    Posts
    21
    Since this is regarding updates..can I get an update without being connected to the net directly? My ISP doesn't support linux (also I'm using internal modem). Can I just download the update and install it on my FC3 via RPM/TAR?

    Thanks in advance.

  7. #7
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    Yep, just download the rpms and edit your /etc/sysconfig/rhn/sources file. There is a directive where you can just point a channel at a local directory. Then run up2date on that channel only.

    Best,

    Samuel
    I respectfully decline the invitation to join your delusion.

  8. #8
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    I still have the same problems with up2date that i had in my first post. I left it running overnight and the progress bar didn't move once (I did input my proxy settings).

    I have downloaded a new apt.conf file on the advice of a website and whenever i run #apt-get update i get the error message "Syntax error /etc/apt/apt.conf:76: Extra junk after value" Line 76 is at the point where I inserted the ACQUIRE code to set my proxy server. If i leave out the code i get the same error message only at the end of apt.conf.

    When trying to run yum I get the error "Cannot find a valid baseurl for repo: base." I'm assuming that this is because it hasn't detected my proxy settings, so i set a shell variable:
    #set "http://myproxy:8080/"
    #export http_proxy= "http://myproxy:8080/"
    and still have the same problem.

    Any help would be appreciated. I don't understand how it worked so smoothly first time.

  9. #9
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    yum has started working now. I suspect that this is because i left off the trailing forward--slash from my proxy set and export commands.

    Thanks anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •