Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I have 4 Ethernet interfaces on my node. I created two separate bonds, and set up two interfaces per bond using MASTER/SLAVE parameters. My issue is, when I reboot, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5

    RH6.2 Networking Question


    Hello,

    I have 4 Ethernet interfaces on my node.
    I created two separate bonds, and set up two interfaces per bond using MASTER/SLAVE parameters.

    My issue is, when I reboot, or run "Service network restart" The correct interfaces do not map back to the correct bonds, and all of them do not start.

    I have mapped the interface to the correct bonds, and have checked my config. Below is my config. How do I ensure the correct interfaces are binded to the correct bonds so when the system reboots, the network interfaces start as intended?

    eth0 configuration (eth1 is identicle other than device name. eth2/3 are pointed to an different bond for their master)

    DEVICE="eth0"
    USERCTL="no"
    ONBOOT="yes"
    MASTER="bond0"
    SLAVE="yes"
    BOOTPROTO="none"
    HWADDR="<MAC>"
    NM_CONTROLLED="yes"

    Here is my bond configuration. Each one is the same other than the bond name and addresses

    DEVICE=bond0
    NAME="<name>"
    IPADDR=x.x.x.x
    NETWORK=x.x.x.x
    NETMASK-x.x.x.x
    DNS1=x.x.x.x
    DNS2=x.x.x.x
    NM_CONTROLLED="yes"
    USERCTL=no
    BOOTPROTO=none
    ONBOOT=yes
    TYPE=Ethernet
    PREFIX=24
    GATEWAY=x.x.x.x
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=yes
    IPV6INIT=no
    UUID=<uuid>

    modprobe.conf Configuration
    alias bond# bonding
    options mode=802.3ad miimon=100

    any suggestions or help to get this guys to become static and correctly map when I reboot would be very helpful. As it stands, every time I reboot now, I need to specify which interface gets what bond (in the GUI) before any networking works.

    Thanks.
    Last edited by Askeptic; 04-12-2012 at 04:07 PM.

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    To be more specific, my bonding is not persistent at all. If I reboot or run a service network restart, it assigns 1 bond (usually bond1) to eth0 every time, and does nothing else.

    I have even put the option "primary=eth#" in my modprobe.conf file, and it basically ignores it and still maps bond1 to eth0 no matter what.

    It should be doing the following per the config

    bond0 - eth0, eth1
    bond1 - eth2, eth3

  3. #3
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    You will never hear me say anything good about the NetworkManager and I don't support using it.

    Try the following:

    eth# config

    Code:
    DEVICE=eth#
    USERCTL=no
    ONBOOT=yes
    MASTER=bond0
    SLAVE=yes
    BOOTPROTO=none
    HWADDR=<MAC>
    NM_CONTROLLED=no
    Bond config

    Code:
    DEVICE=bond0
    IPADDR=x.x.x.x
    NETWORK=x.x.x.x
    NETMASK-x.x.x.x
    GATEWAY=x.x.x.x
    USERCTL=no
    BOOTPROTO=none
    ONBOOT=yes
    TYPE=Ethernet
    NM_CONTROLLED=no
    IPV6INIT=no
    If this doesn't work please post the output from ifconfig so we can see what is going on wiht the interfaces.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! slapandtickle69's Avatar
    Join Date
    Nov 2011
    Location
    Australia
    Posts
    12
    Hay Askeptic, I hope you are well.

    I Completely agree with Lazydog, on this one you can only be sure of configs when you do them manually.

  6. #5
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    Lazydog,

    Thank you very much. That did the trick. As soon as I removed the GUI from the picture it started working and saving my settings flawlessly. Much appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •