Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy SKYPE not launching and endsup with "failed to execute child process"


    Dear Friends

    I would like to install skype in my fedora 16 and startd the process by downloading skype rpm from website and installed successfully, but not launching

    I googled and find that I need to install some lib files
    These are the files
    "libXv.i686
    libXScrnSaver.i686
    qt.i686 qt-x11.i686
    pulseaudio-libs.i686
    pulseaudio-libs-glib2.i686
    alsa-plugins-pulseaudio.i686"

    While installing the files the yum process end with following error.

    Loaded plugins: langpacks, presto, refresh-packagekit
    Resolving Dependencies
    --> Running transaction check
    ---> Package alsa-plugins-pulseaudio.i686 0:1.0.25-3.fc16 will be installed
    --> Processing Dependency: libc.so.6(GLIBC_2.4) for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libc.so.6(GLIBC_2.0) for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libc.so.6 for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libasound.so.2(ALSA_0.9) for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    --> Processing Dependency: libasound.so.2 for package: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
    ---> Package libXScrnSaver.i686 0:1.2.1-2.fc15 will be installed
    --> Processing Dependency: libXext.so.6 for package: libXScrnSaver-1.2.1-2.fc15.i686
    --> Processing Dependency: libX11.so.6 for package: libXScrnSaver-1.2.1-2.fc15.i686
    ---> Package libXv.i686 0:1.0.6-2.fc15 will be installed
    ---> Package pulseaudio-libs.i686 0:0.9.23-1.fc16 will be installed
    --> Processing Dependency: libsndfile.so.1 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libxcb.so.1 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libdbus-1.so.3 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libwrap.so.0 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libSM.so.6 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libasyncns.so.0 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libICE.so.6 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libXtst.so.6 for package: pulseaudio-libs-0.9.23-1.fc16.i686
    --> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: pulseaudio-libs-0.9.23-1.fc16.i686
    ---> Package pulseaudio-libs-glib2.i686 0:0.9.23-1.fc16 will be installed
    --> Processing Dependency: libglib-2.0.so.0 for package: pulseaudio-libs-glib2-0.9.23-1.fc16.i686
    ---> Package qt.i686 1:4.8.0-7.fc16 will be installed
    --> Processing Dependency: libz.so.1 for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libstdc++.so.6 for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libssl.so.10 for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libsqlite3.so.0 for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libgcc_s.so.1 for package: 1:qt-4.8.0-7.fc16.i686
    --> Processing Dependency: libcrypto.so.10 for package: 1:qt-4.8.0-7.fc16.i686
    ---> Package qt-x11.i686 1:4.8.0-7.fc16 will be installed
    --> Processing Dependency: libtiff.so.3 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libpng12.so.0(PNG12_0) for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libpng12.so.0 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libmng.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libjpeg.so.62 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libfreetype.so.6 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libfontconfig.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXrender.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXrandr.so.2 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXinerama.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXi.so.6 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXfixes.so.3 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libXcursor.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Processing Dependency: libGL.so.1 for package: 1:qt-x11-4.8.0-7.fc16.i686
    --> Running transaction check
    ---> Package alsa-lib.i686 0:1.0.25-1.fc16 will be installed
    ---> Package dbus-libs.i686 1:1.4.10-3.fc16 will be installed
    ---> Package fontconfig.i686 0:2.8.0-4.fc16 will be installed
    --> Processing Dependency: libexpat.so.1 for package: fontconfig-2.8.0-4.fc16.i686
    ---> Package freetype.i686 0:2.4.6-4.fc16 will be installed
    ---> Package glib2.i686 0:2.30.2-1.fc16 will be installed
    --> Processing Dependency: libselinux.so.1 for package: glib2-2.30.2-1.fc16.i686
    --> Processing Dependency: libffi.so.5 for package: glib2-2.30.2-1.fc16.i686
    --> Processing Dependency: libfam.so.0 for package: glib2-2.30.2-1.fc16.i686
    ---> Package glibc.i686 0:2.14.90-24.fc16.6 will be installed
    --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14.90-24.fc16.6.i686
    --> Processing Dependency: libfreebl3.so for package: glibc-2.14.90-24.fc16.6.i686
    ---> Package libICE.i686 0:1.0.7-1.fc16 will be installed
    ---> Package libSM.i686 0:1.2.0-2.fc15 will be installed
    --> Processing Dependency: libuuid.so.1(UUID_1.0) for package: libSM-1.2.0-2.fc15.i686
    --> Processing Dependency: libuuid.so.1 for package: libSM-1.2.0-2.fc15.i686
    ---> Package libX11.i686 0:1.4.3-1.fc16 will be installed
    ---> Package libXcursor.i686 0:1.1.11-3.fc15 will be installed
    ---> Package libXext.i686 0:1.3.0-1.fc16 will be installed
    ---> Package libXfixes.i686 0:5.0-1.fc16 will be installed
    ---> Package libXi.i686 0:1.4.5-1.fc16 will be installed
    ---> Package libXinerama.i686 0:1.1.1-2.fc15 will be installed
    ---> Package libXrandr.i686 0:1.3.1-2.fc15 will be installed
    ---> Package libXrender.i686 0:0.9.6-2.fc15 will be installed
    ---> Package libXtst.i686 0:1.2.0-2.fc15 will be installed
    ---> Package libasyncns.i686 0:0.8-2.fc15 will be installed
    ---> Package libgcc.i686 0:4.6.3-2.fc16 will be installed
    ---> Package libjpeg-turbo.i686 0:1.2.0-1.fc16 will be installed
    ---> Package libmng.i686 0:1.0.10-5.fc15 will be installed
    --> Processing Dependency: liblcms.so.1 for package: libmng-1.0.10-5.fc15.i686
    ---> Package libpng.i686 2:1.2.48-1.fc16 will be installed
    ---> Package libsndfile.i686 0:1.0.25-1.fc16 will be installed
    --> Processing Dependency: libvorbis.so.0 for package: libsndfile-1.0.25-1.fc16.i686
    --> Processing Dependency: libogg.so.0 for package: libsndfile-1.0.25-1.fc16.i686
    --> Processing Dependency: libFLAC.so.8 for package: libsndfile-1.0.25-1.fc16.i686
    --> Processing Dependency: libvorbisenc.so.2 for package: libsndfile-1.0.25-1.fc16.i686
    ---> Package libstdc++.i686 0:4.6.3-2.fc16 will be installed
    ---> Package libtiff.i686 0:3.9.5-1.fc16 will be installed
    ---> Package libxcb.i686 0:1.7-3.fc16 will be installed
    --> Processing Dependency: libXau.so.6 for package: libxcb-1.7-3.fc16.i686
    ---> Package mesa-libGL.i686 0:7.11.2-3.fc16 will be installed
    --> Processing Dependency: mesa-dri-drivers(x86-32) = 7.11.2-3.fc16 for package: mesa-libGL-7.11.2-3.fc16.i686
    --> Processing Dependency: libdrm.so.2 for package: mesa-libGL-7.11.2-3.fc16.i686
    --> Processing Dependency: libXxf86vm.so.1 for package: mesa-libGL-7.11.2-3.fc16.i686
    --> Processing Dependency: libXdamage.so.1 for package: mesa-libGL-7.11.2-3.fc16.i686
    ---> Package openssl.i686 0:1.0.0g-1.fc16 will be installed
    --> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.0g-1.fc16.i686
    --> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.0g-1.fc16.i686
    --> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.0g-1.fc16.i686
    --> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.0g-1.fc16.i686
    --> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.0g-1.fc16.i686
    --> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.0g-1.fc16.i686
    ---> Package sqlite.i686 0:3.7.7.1-1.fc16 will be installed
    --> Processing Dependency: libtinfo.so.5 for package: sqlite-3.7.7.1-1.fc16.i686
    --> Processing Dependency: libreadline.so.6 for package: sqlite-3.7.7.1-1.fc16.i686
    --> Processing Dependency: libncurses.so.5 for package: sqlite-3.7.7.1-1.fc16.i686
    ---> Package tcp_wrappers-libs.i686 0:7.6-64.fc16 will be installed
    ---> Package zlib.i686 0:1.2.5-6.fc16 will be installed
    --> Running transaction check
    ---> Package expat.i686 0:2.0.1-11.fc15 will be installed
    ---> Package flac.i686 0:1.2.1-6.fc12 will be installed
    ---> Package gamin.i686 0:0.1.10-10.fc16 will be installed
    ---> Package krb5-libs.i686 0:1.9.3-1.fc16 will be installed
    --> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.9.3-1.fc16.i686
    --> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.9.3-1.fc16.i686
    ---> Package lcms-libs.i686 0:1.19-4.fc16 will be installed
    ---> Package libXau.i686 0:1.0.6-2.fc15 will be installed
    ---> Package libXdamage.i686 0:1.1.3-2.fc15 will be installed
    ---> Package libXxf86vm.i686 0:1.1.1-2.fc15 will be installed
    ---> Package libcom_err.i686 0:1.41.14-2.fc15 will be installed
    ---> Package libdrm.i686 0:2.4.30-1.fc16 will be installed
    --> Processing Dependency: libpciaccess.so.0 for package: libdrm-2.4.30-1.fc16.i686
    ---> Package libffi.i686 0:3.0.10-1.fc16 will be installed
    ---> Package libogg.i686 2:1.2.2-3.fc15 will be installed
    ---> Package libselinux.i686 0:2.1.6-6.fc16 will be installed
    ---> Package libuuid.i686 0:2.20.1-2.2.fc16 will be installed
    ---> Package libvorbis.i686 1:1.3.3-1.fc16 will be installed
    ---> Package mesa-dri-drivers.i686 0:7.11.2-3.fc16 will be installed
    --> Processing Dependency: mesa-dri-filesystem(x86-32) for package: mesa-dri-drivers-7.11.2-3.fc16.i686
    --> Processing Dependency: libLLVM-2.9.so for package: mesa-dri-drivers-7.11.2-3.fc16.i686
    ---> Package ncurses-libs.i686 0:5.9-2.20110716.fc16 will be installed
    ---> Package nss-softokn-freebl.i686 0:3.13.3-1.fc16 will be installed
    ---> Package readline.i686 0:6.2-2.fc16 will be installed
    --> Running transaction check
    ---> Package keyutils-libs.i686 0:1.5.2-1.fc16 will be installed
    ---> Package libpciaccess.i686 0:0.12.1-1.fc15 will be installed
    ---> Package llvm-libs.i686 0:2.9-9.fc16 will be installed
    ---> Package mesa-dri-filesystem.i686 0:7.11.2-3.fc16 will be installed
    --> Finished Dependency Resolution
    Error: Protected multilib versions: libselinux-2.1.6-6.fc16.i686 != libselinux-2.1.5-5.1.fc16.x86_64
    Error: Protected multilib versions: alsa-lib-1.0.25-1.fc16.i686 != alsa-lib-1.0.24-2.fc15.x86_64
    Error: Protected multilib versions: glibc-2.14.90-24.fc16.6.i686 != glibc-2.14.90-14.x86_64
    Error: Protected multilib versions: freetype-2.4.6-4.fc16.i686 != freetype-2.4.6-3.fc16.x86_64
    Error: Protected multilib versions: libXi-1.4.5-1.fc16.i686 != libXi-1.4.3-3.fc16.x86_64
    Error: Protected multilib versions: libXext-1.3.0-1.fc16.i686 != libXext-1.2.0-2.fc15.x86_64
    Error: Protected multilib versions: libuuid-2.20.1-2.2.fc16.i686 != libuuid-2.20.1-2.fc16.x86_64
    Error: Protected multilib versions: openssl-1.0.0g-1.fc16.i686 != openssl-1.0.0e-1.fc16.x86_64
    Error: Protected multilib versions: glib2-2.30.2-1.fc16.i686 != glib2-2.30.1-1.fc16.x86_64


    So please help me out of this friends, waiting for replay......

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    12,596
    You need the 32bit versions of the libraries installed for Skype to work on Linux - it is only available as a 32bit image. That means if you install the application directly with rpm, ignoring dependencies, when you run it it will tell you what shared libraries it cannot find/load. You will then need to install the 32bit packages that contain them. It took me a few tries before I got them all installed on my 64-bit Scientific Linux (RHEL) 6 system before it would run properly, but I did get it to work, and it handles my webcam and bluetooth headset just fine.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Dear Rubberman

    Thankz for replay

    I tried to install 32 version but I failed, (Depencies Failed) Can u please explain the process in brief,

    Thanks in Advance..

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    12,596
    1. Download and install the generic Linux binary.
    2. Run binary from a command-line. If it runs, and you get the GUI, you are done. If not, go to #3.
    3. See what shared library can't be loaded. This will be in the error messages you get in the command-line window.
    4. Install the 32-bit package that contains that library (some Googling may be required).
    5. Go to #2 and try again.

    It took me about 4 or 5 tries and some google searches to get all the dependencies loaded. After that, it just works. Not as pretty as the Windows version, but I can do both voice and video calls.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Dear Rabberman

    I googled a lot for generic Linux binary. but I reached nowhere.
    and I downloaded fedoora 16 i386(32-bit) version, will it be of any use.

    Thanks in advance...

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    12,596
    I used the FC10 rpm from skype. It's running on my RHEL 6.2 system now.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •