Find the answer to your Linux question:
Results 1 to 4 of 4
Hello all, I am new here but am your average Linux user. I have built and configured my system numerous times with various ATI FGLRX iterations of drivers, however FC3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Location
    Central Florida, Polk County, AKA Hurricane Alley
    Posts
    2

    FGLRX & Xorg 6.8


    Hello all, I am new here but am your average Linux user. I have built and configured my system numerous times with various ATI FGLRX iterations of drivers, however FC3 and Xorg 6.8 have kicked my butt. I found the statement that ATI/Xorg 6.8 have issues and that ATI will fix in the next driver however I cannot wait as I am an avid Americas Army player and ver 2.2.1 for linux has just come out. So I need to downgrade FC3 Xorg 6.8 to FC3 Xorg 6.7. That is the gist of my question, is there an easy way to do this as I don't want to have to pull all of those files individually, nor do I want to install every file individually? What I am hoping is that I can use Synaptic, Yum, or a simple RPM to downgrade Xorg 6.8 -> Xorg 6.7. Any and all help is greatly appreciated.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    dload the 6.7 xorg version and run this
    Code:
    rpm -Uvh --oldpackage <package_name>
    this will install an older package over a newer one...


    Hope it helps
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Newbie
    Join Date
    Oct 2004
    Posts
    133
    I have tried several times to do this, and I always have trouble with package conflicts and dependencies.
    Does anyone know specifically which xorg packages need to be downgraded and which ones should be left alone?

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Location
    Central Florida, Polk County, AKA Hurricane Alley
    Posts
    2

    Xorg 6.7

    I ended up downloading all of Xorg 6.7 RPM's and installing them 1 at a time except for the Mesa-libGL rpm which conflicts with fglrx. I then used synaptic to remove all of the Xorg 6.8 packages. But I still have a problem with the fglrx module compile. I am getting that infamous error about:
    ATI module generator V 2.0
    ==========================
    initializing...
    Error:
    XFree86 drm includes at /lib/modules/2.6.9-1.681_FC3/build/include/../drivers/char/drm do not fit this driver.
    This driver is designed to only work with X4.1.0 or higher.
    You can match this by getting Linux kernel 2.4.8 or higher.

    I have patched my make file but still didn't resolve, can anyone help me here? I am running FC3 w/2.6.9 kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •