Find the answer to your Linux question:
Results 1 to 7 of 7
Hello Dear Friends. Wow to the world of newbies, and unfortunately I am one. I am trying to install "Packetix vpn" on my Fedora Core 16, and it seems to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Location
    Talesh
    Posts
    13

    OH...Holy Whatever!!!


    Hello Dear Friends.

    Wow to the world of newbies, and unfortunately I am one.

    I am trying to install "Packetix vpn" on my Fedora Core 16, and it seems to say that I haven't got "pthread Library".

    I searched alot and couldn't find a way to install it. I used The idea of
    Code:
    yum whatprovides pthread
    and guess what. nothing. then I check the web. diffrent ideas of yum install devel or glibc or any asterisk lib asterisk, but they all failed. I also tried different rpms from many sources, and they also didn't answered...

    I'm gonna paste the return of the make precedure I've done for packetix vpn.

    Please help me if anyone has an idea.

    Code:
    [rootAtheist Downloads]# tar xzvf vpnserver-5280-rtm-linux-x86.tar.gz
    vpnserver/
    vpnserver/libcrypto.a
    vpnserver/License_ReadMeFirstUtf.txt
    vpnserver/License_ReadMeFirst.txt
    vpnserver/vpnserver.a
    vpnserver/libssl.a
    vpnserver/License_ReadMeFirstSjis.txt
    vpnserver/Makefile
    vpnserver/vpncmd.a
    vpnserver/.install.sh
    vpnserver/hamcore.se2
    this is the extract which is done with no errors....


    and this is the error....

    Code:
    Did you read and understand the License Agreement ?
    (If you couldn't read above text, Please read License_ReadMeFirst.txt
     file with any text editor.)
    
     1. Yes
     2. No
    
    Please choose one of above number: 
    1
    
    
    Did you agree the License Agreement ?
    
    1. Agree
    2. Do Not Agree
    
    Please choose one of above number: 
    1
    
    make[1]: Entering directory `/home/mojsh2020/Downloads/vpnserver'
    ranlib libssl.a
    1ranlib libcrypto.a
    ranlib vpnserver.a
    gcc vpnserver.a -pthread -lrt -lm -lz libssl.a libcrypto.a -lpthread -ldl -lreadline -lcurses  -o vpnserver
    
    /usr/bin/ld: cannot find -lreadline
    /usr/bin/ld: cannot find -lcurses
    collect2: ld returned 1 exit status
    make[1]: *** [vpnserver] Error 1
    make[1]: Leaving directory `/home/mojsh2020/Downloads/vpnserver'
    [rootAtheist vpnserver]#
    Last edited by oz; 05-20-2012 at 12:41 PM. Reason: removed foreign language entry

  2. #2
    Just Joined!
    Join Date
    Mar 2012
    Location
    Talesh
    Posts
    13
    and this is the content of makefile:

    Code:
    # PacketiX VPN Makefile
    # 
    # Copyright (C) 2004-2006 SoftEther Corporation.
    # All Rights Reserved.
    
    default:
    			./.install.sh
    
    i_read_and_agree_the_license_agreement:	vpnserver vpncmd
    
    
    vpnserver:	vpnserver.a
    			-ranlib libssl.a
    			-ranlib libcrypto.a
    			-ranlib vpnserver.a
    			gcc vpnserver.a -pthread -lrt -lm -lz libssl.a libcrypto.a -lpthread -ldl -lreadline -lcurses  -o vpnserver
    
    vpncmd:		vpncmd.a
    			-ranlib vpncmd.a
    			gcc vpncmd.a -pthread -lrt -lm -lz libssl.a libcrypto.a -lpthread -ldl -lreadline -lcurses  -o vpncmd
    
    clean:
    			rm -f vpnserver
    			rm -f vpncmd
    as you see it has a -lpthread if you may suggest that.

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    try installing these additional packages. they have the libraries and header files that you seem to be missing:
    Code:
    yum install glibc-headers glibc-devel readline ncurses-devel

  4. #4
    Just Joined!
    Join Date
    Mar 2012
    Location
    Talesh
    Posts
    13
    I did what you said and this was the result:

    Code:
    [root.Atheist vpnserver]# yum install glibc-headers glibc-devel readline ncurses-devel
    Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, security
    Loading mirror speeds from cached hostfile
     * fedora: ftp.cs.pu.edu.tw
     * livna: ftp-stud.fht-esslingen.de
     * rpmfusion-free: download1.rpmfusion.org
     * rpmfusion-free-updates: fedora-mirror02.rbc.ru
     * rpmfusion-nonfree: fedora-mirror02.rbc.ru
     * rpmfusion-nonfree-updates: fedora-mirror02.rbc.ru
     * updates: mirror.neu.edu.cn
    ://linuxdownload.adobe.com/linux/i386/repodata/repomd.xml: [Errno 12] Timeout on ://linuxdownload.adobe.com/linux/i386/repodata/repomd.xml: (28, '')
    Trying other mirror.
    Package glibc-headers-2.14.90-24.fc16.6.i686 already installed and latest version
    Package glibc-devel-2.14.90-24.fc16.6.i686 already installed and latest version
    Package readline-6.2-2.fc16.i686 already installed and latest version
    Package ncurses-devel-5.9-2.20110716.fc16.i686 already installed and latest version
    Nothing to do
    and I couldn't install packetix too.

  5. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i guess it is looking for readline header files, too, not just library files. try this:
    Code:
     yum install readline-devel

  6. #6
    Just Joined!
    Join Date
    Mar 2012
    Location
    Talesh
    Posts
    13
    oh man....it worked.......

    thnk you very very much........

  7. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    np, glad its sorted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •