Find the answer to your Linux question:
Results 1 to 3 of 3
Hey all, I am having difficulty installing cobbler on my centos5.8 i386 machine. I keep reading that i need to update the yum repos or run this command: Code: rpm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    45

    Installing Cobbler on Centos-5.8


    Hey all,
    I am having difficulty installing cobbler on my centos5.8 i386 machine.
    I keep reading that i need to update the yum repos or run this command:
    Code:
    rpm -Uvh hxxp://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
    Unfortunately when I run that command, I get the following output:

    Code:
    Retrieving hxxp://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
    error: skipping hxxp://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm - transfer failed - Unknown or unexpected error
    I have tried adding to the repo:
    Code:
    vi /etc/yum.repos.d/extras.repo
    which has the following:
    Code:
    [EXTRAS]
    name = extra repository for enterprise linux
    baseurl = hxxp://download.fedora.redhat.com/pub/epel/5/i386/
    enabled = 1
    gpgcheck = 0
    Please let me know what I need to change. Btw I have deliberately replaced 'http' with 'hxxp' to work around this forums rules.

    Stu

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    RH recently switch domain names, try this instead:

    http://dl.fedoraproject.org/pub/epel/5/i386/

    basically, switch the download.fedora.redhat.com for dl.fedoraproject.org in your extras.repo file.

    or i guess you could download the rpm from the new url, too, e.g.:
    Code:
    wget http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
    note that the new version is 5.4.

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    45
    Thanks that worked a treat! This thead is now solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •