Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    sshd doesn't properly load on startup


    Problem - sshd does not startup correctly
    uname -r
    3.3.5-2.fc16.x86_64
    I am starting up the sshd service using
    "systemctl enable sshd.service"

    I've verified that the service loads on startup using:
    systemctl status sshd.service

    the problem is that after startup i can only ssh into:
    user -at- localhost
    and cannot ssh into
    user -at- 192.168.10.183
    if i execute:
    systemctl restart sshd.service

    it loads my /etc/ssh/sshd_config config file properly and I am able to ssh as normal.

    Iptables is disable
    selinux is set to permissive.

    I even went into /etc/systemd/system/multi-user.targets.wants and altered the symlink to specify the config file to use, and that did not work.

    Why is sshd not starting up listening on the specified interface?

  2. #2
    additional information:
    sshd -t
    does not find an error in the config file.

    Interesting:
    if change the config file to:
    ListenAddress 192.168.10.183
    #ListenAddress localhost
    (plus all the other crap)
    from
    ListenAddress 192.168.10.183
    ListenAddress localhost

    the sshd service fails to load entirely (once again sshd -t does not yeild any errors in teh config)
    the symlink for sshd.service has the following in the "After" key:
    After=syslog.target network.target auditd.service

    is it possible that I'm missing a critical service?

  3. #3
    have you tried commenting out the ListenAddress lines entirely (let it bind to all interfaces)?

  4. $spacer_open
    $spacer_close
  5. #4
    Just did -- it does work, thanks for the suggestion.

    Someone blamed NetworkManager for behavior similar to this.
    I tried to disable NetworkManager, but then the NIC never gets configured, and then it really wont work. (i'll have to check what the heck network manager does.)

    I also tried to force sshd to wait for NetworkManager.service, but that didn't work either.

    At any rate, I'm just gonna call it a night since binding and listening to all ports is good enough for me.

    thanks again,

  6. #5
    Quote Originally Posted by jmkokott View Post
    Just did -- it does work, thanks for the suggestion.

    Someone blamed NetworkManager for behavior similar to this.
    I tried to disable NetworkManager, but then the NIC never gets configured, and then it really wont work. (i'll have to check what the heck network manager does.)

    I also tried to force sshd to wait for NetworkManager.service, but that didn't work either.

    At any rate, I'm just gonna call it a night since binding and listening to all ports is good enough for me.

    thanks again,
    np. and FWIW, i really hate NetworkManager myself. one of the first things i do is remove it entirely. Then I make sure /etc/init.d/network (the legacy network init stuff which works just fine) is enabled.

    1. remove NetworkManager
    Code:
    yum erase NetworkManager
    2. enable network initscript
    Code:
    chkconfig network on
    3. start network
    Code:
    service network restart
    also, just make sure your networking is all configured in the usual /etc/sysconfig/network-scripts/ifcfg-* files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •