Find the answer to your Linux question:
Results 1 to 2 of 2
Running Dual Boot Win 7 Ultimate and Fedora 16, Kernel Linux 3.2.7-1.fc16.i686, GNOME 3.2.1 Using Fedora 16 with a Opera browser open I couldn't open my 'Files' or anything, a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9

    [SOLVED]Fedora 16: yum-complete-transaction fails...


    Running Dual Boot Win 7 Ultimate and Fedora 16, Kernel Linux 3.2.7-1.fc16.i686, GNOME 3.2.1

    Using Fedora 16 with a Opera browser open I couldn't open my 'Files' or anything, a message popped up at bottom of screen that said something along the lines that there wasn't enough memory to open.

    So I went to SOFTWARE UPDATES to run it and get this:

    FAILED TO INITIALIZE
    Failed to initialize packaging backend.
    There are unfinished transactions remaining. Please run yum-complete-transaction as root.

    Here are all of the commands I have found to try to resolve this issue, in order.
    -yum-complete-transaction
    -yum-complete-transaction –cleanup-only
    -package-cleanup –cleandupes
    -yum clean all
    -yum update

    I am now at a loss as to what to do next, short of saving all my files and wiping that partition and starting from scratch. (Which I really don't want to.)

    Sorry for the book but I am hoping I have given enough info and that someone will see where the problem is and give me a solution to fix this.

    Thank you all for any any help or input as to what is going on...

    I tried to post all the command logs but the web site says:
    You are only allowed to post URLs to other sites after you have made 15 posts or more.

    So not real sure how to post those but in short when I run the 'yum-complete-transaction' the log says:

    fedorautilsDOTsourceforgeDOTnet/repo/repodata/repomdDOTxml: [Errno 14] HTTP Error 404 - Not Found :
    Last edited by geminimoon66; 06-05-2012 at 10:54 PM. Reason: Problem solved!

  2. #2
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9
    This problem was solved by running the following as root:

    yum-complete-transaction --disablerepo=fedorautils

    Thanks AndrewSerk at fedoraforum.org!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •