Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
Sorry but I can't access to the VM for now, I will reboot ir. Still this is the output from the machine # iptables -L: Chain INPUT (policy ACCEPT) target ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    May 2012
    Posts
    14

    Sorry but I can't access to the VM for now, I will reboot ir.
    Still this is the output from the machine

    # iptables -L:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
    ACCEPT icmp -- anywhere anywhere
    ACCEPT all -- anywhere anywhere
    ACCEPT all -- anywhere anywhere
    ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ftp
    ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
    REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere PHYSDEV match --physdev-is-bridged
    ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
    ACCEPT icmp -- anywhere anywhere
    ACCEPT all -- anywhere anywhere
    ACCEPT all -- anywhere anywhere
    ACCEPT all -- anywhere anywhere
    REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    # cat /etc/sysconfig/network-scripts/ifcfg-eth0

    DEVICE="eth0"
    HWADDR="00:15:17:B2:F4:F3"
    NM_CONTROLLED="yes"
    ONBOOT="no"

  2. #12
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Quote Originally Posted by larry54 View Post
    In the first case, ensure that in the /etc/sh/sshd_config configuration file the PermitrootLogin is set to YES.
    First, this is just BAD Sysadmin advice! Best practice is to never allow ROOT access.

    Quote Originally Posted by Yarok View Post
    DEVICE="eth0"
    HWADDR="00:15:17:B2:F4:F3"
    NM_CONTROLLED="yes"
    ONBOOT="no"
    So I understand that you have 1 host that also hosts a VM but you are unable to get to the VM from the VM host. My question is as follows:

    1. Did you setup the Host's interface to work as a bridge?
    2. What are the ip addresses for both the host and the VM?
    3. Are you running a firewall on both the host and the VM?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #13
    Just Joined!
    Join Date
    May 2012
    Posts
    14
    Thanks for the tip.
    First, I am new to Linux. Now I will answer your questions.
    1. No I didn't. How can I set the host's interface to work as a bridge? and what is for?
    2. Host IP address: 8.12.4.197; VM IP address: 8.12.4.111
    3. I don't know. What files should I check for that? I noticed that in System->Firewall Configuration the FTP and SSH are make as "trusted" ("v" mark).

    Yaron

  4. #14
    Just Joined!
    Join Date
    Jun 2012
    Posts
    3
    Hello,
    I assume you are running 2 machine, one is host PC, one is in virtual PC right?

    First, you need to make sure are they in the same network & gateway,
    run command #ifconfig on both PC. check the IP and gateway, try ping each other machine.

    Then, check the firewall setting, just to make sure its not firewall issue, try shutdown the iptables for temporary. and try ssh again, if success, then you need setup the firewall properly. (dont forget to start the f/w again, its not secure leave the iptables stoped)
    run command #/sbin/service iptables stop, then try ssh again.

    Regards,
    Droo

  5. #15
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2
    HI . Please check that the port number might be change from 22 to some other number

    vi /etc/ssh/sshd_config file

    If it's change then use the following syntax

    ssh -p portnumber hostname or IPaddress

  6. #16
    Just Joined!
    Join Date
    May 2012
    Posts
    14
    Hi,

    I am running 2 machines on the same PC:
    1. RHL-6 (IP: 8.12.4.197 Netmask: 255.255.255.0)
    2. Virtual machine (QEMU) (IP: 8.12.4.111 Netmask: 255.255.255.0)

    I can ping from the RHL-6 but NOT from the VM to the other way. (also I can't "kill" the ping process with CNTL C and all other shortcuts don't work...)

    First let's fix the ping issue.
    Any Idea?

    Yaron

  7. #17
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2
    Hello Yarok,

    1 ) To stop ping request automatically use the following command

    ===================================

    ping -c (no of counts) IP or Hostname

    eg ping -c 10 google.com

    ===================================

    So it will stop automatically after 10 Echo request.


    2. From Virtual Machine can you able to browse site ?

  8. #18
    Just Joined!
    Join Date
    May 2012
    Posts
    14
    Thanks for the reply.

    1. It's a way to solve the ping problem. But way all other keyboards' shortcut are not functioning?

    2. Regarding the internet the answer is no. But now I try to establish connection between the HOST and the VM with a net that cannot open to the internet.

    Yaron.

  9. #19
    Just Joined!
    Join Date
    May 2012
    Posts
    14
    Now I changed the VM's IP and I can't ping at all...
    Please advice.

  10. #20
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Post the following from the VM;

    Code:
    route -n
    ifconfig

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •