Find the answer to your Linux question:
Results 1 to 10 of 10
NTP is not synchronizing on Fedora 14 64 bit. When I set the clock a few seconds ahead it will not synchronize after a few minutes. This works on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    jlh
    jlh is offline
    Just Joined!
    Join Date
    Jun 2012
    Posts
    5

    NTP not synchronizing on Fedora 14 64 bit


    NTP is not synchronizing on Fedora 14 64 bit.

    When I set the clock a few seconds ahead it will not synchronize after a few minutes. This works on the redhat 9, after a few minutes the time is synchronized.

    ntpdate -d server_ip it shows I'm off by 5.xx seconds but will not synchronize unless ntpdate is run or a reboot.

    Does anyone know how to fix this problem?

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Is the daemon running?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    jlh
    jlh is offline
    Just Joined!
    Join Date
    Jun 2012
    Posts
    5
    Quote Originally Posted by Lazydog View Post
    Is the daemon running?
    Sorry, should have mentioned that in the post. The daemon is running. I can't get it to work on Fedora 8 or Fedora 14. It does work on RedHat 9 (which is old). We are in the process of updating.

    Everything looks like it should work. The command ntpdc -c loopinfo output is good, same as ntpdc sysinfo. Yet the time will not slowly catch up.

    Thanks for the help, really appreciate it.

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    You running a firewall? Are the ports open on the firewall?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  5. #5
    jlh
    jlh is offline
    Just Joined!
    Join Date
    Jun 2012
    Posts
    5
    No firewalls at this time, port 123 is open. I have downloaded the 4.2.6p3 and it is working on the Fedora 14 64 bit.

    There is a difference between the redhat 9 and the fedora14. I can change the time to be off by an hour and redhat 9 will synch in a matter of minutes while fedora 14 will take days. Not sure why this is since it should gradually synch the time. I'm using the step-tickers file to do a synch on boot so I don't believe this to be a problem. I was changing time to troubleshoot.

    The version of ntp for Fedora 8, 4.2.4p2, the offset actually gets bigger. I might try to use the version of ntp that we are using on the redhat to see if this will correct the problem.

    Definitely not sure why the 2 behave so differently synching the time between redhat 9 and Fedora 14.

    Thanks for the replies, maybe you'll have an insight on the behavior I'm seeing.

  6. #6
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    can you post the output from the following command;

    Code:
    ntpq -p

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  7. #7
    jlh
    jlh is offline
    Just Joined!
    Join Date
    Jun 2012
    Posts
    5
    Code:
    remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
     slc1            .INIT.          16 u    - 1024    0    0.000    0.000   0.000
     100.100.6.1     .INIT.          16 u    - 1024    0    0.000    0.000   0.000
    I spoke a liitle too soon, from the above it isn't working.

    Code:
    ntp.conf file
    
    # --- GENERAL CONFIGURATION ---
    #
    # Only a simple configuration is required for this application.
    # The NTP servers are located on the SLC boards.
    # Set 2 server parameters, one for each SLC.
    #
    # Important notes:
    # 1) The server IPs will need to be updated for the deployment IPs
    # 2) Be sure to use the ethernet IP vs. backplane IP.
    #
    # SLC 1
    server 138.125.192.46 iburst
    # SLC 2
    server 100.100.6.1 iburst
    
    #
    # Drift file.  Put this in a directory which the daemon can write to.
    # No symbolic links allowed, either, since the daemon updates the file
    # by creating a temporary in the same directory and then rename()'ing
    # it to the file.
    #
    driftfile /etc/ntp/drift
    logfile /var/log/ntp.log
    Code:
    Output from ntp.log
    
    11 Jun 12:50:37 ntpd[1450]: ntpd exiting on signal 15
    11 Jun 12:52:25 ntpd[1462]: 0.0.0.0 c016 06 restart
    11 Jun 12:52:25 ntpd[1462]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
    11 Jun 12:52:25 ntpd[1462]: 0.0.0.0 c011 01 freq_not_set
    11 Jun 12:52:28 ntpd[1462]: 0.0.0.0 c514 04 freq_mode
    11 Jun 12:55:00 ntpd[1462]: ntpd exiting on signal 15
    11 Jun 12:57:53 ntpd[2575]: ntpd exiting on signal 2
    11 Jun 12:58:26 ntpd[2894]: 0.0.0.0 c016 06 restart
    11 Jun 12:58:26 ntpd[2894]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
    11 Jun 12:58:26 ntpd[2894]: 0.0.0.0 c011 01 freq_not_set
    11 Jun 12:58:29 ntpd[2894]: 0.0.0.0 c514 04 freq_mode
    11 Jun 13:14:29 ntpd[2894]: 0.0.0.0 0512 02 freq_set kernel 0.000 PPM
    11 Jun 13:14:29 ntpd[2894]: 0.0.0.0 0515 05 clock_sync
    11 Jun 13:17:30 ntpd[2894]: ntpd exiting on signal 15
    11 Jun 13:19:58 ntpd[5037]: 0.0.0.0 c016 06 restart
    11 Jun 13:19:58 ntpd[5037]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
    11 Jun 13:19:58 ntpd[5037]: 0.0.0.0 c011 01 freq_not_set
    11 Jun 13:19:59 ntpd[5037]: ntpd exiting on signal 15
    11 Jun 13:20:01 ntpd[5072]: 0.0.0.0 c016 06 restart
    11 Jun 13:20:01 ntpd[5072]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
    11 Jun 13:20:01 ntpd[5072]: 0.0.0.0 c011 01 freq_not_set
    11 Jun 13:21:20 ntpd[5072]: ntpd exiting on signal 15
    11 Jun 13:22:56 ntpd[5190]: ntpd exiting on signal 2
    11 Jun 13:27:56 ntpd[9031]: 0.0.0.0 c016 06 restart
    11 Jun 13:27:56 ntpd[9031]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
    11 Jun 13:27:56 ntpd[9031]: 0.0.0.0 c011 01 freq_not_set
    There is no firewall, SELinux is disabled, ntptrace hostname doesn't return anything. I am at a loss as to what is wrong. This same configuration is used in the redhat 9 and all is well. Any ideas? I will be out of office June 13 - June 20.

    Thanks,
    Jeff

  8. #8
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Can you post the output from the following:
    Code:
    service ntpd status
    Ping me when you get back.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  9. #9
    jlh
    jlh is offline
    Just Joined!
    Join Date
    Jun 2012
    Posts
    5
    Problem Solved, sort of...

    The NTP server we use, for some reason, is not compatible with the newer versions of NTP. Version 4.1.2@1.892 (output from ntpdc version) works fine and exactly the same as the RedHat 9.

    If you have an idea for the above, please post a reply. If not, thanks again for your help.

    Thanks,
    Jeff

  10. #10
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    If the service is not working then the problem is still now solved.
    would it be possible to get the ntp.conf via PM? Would like to see what you have as settings.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •