Find the answer to your Linux question:
Results 1 to 3 of 3
I'm running a cron job that runs 3 scripts, all using the same shared libraries. for sake of discussion lets called them 1.sh 2.sh 3.sh 1 & 2 run fine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    16

    Cron job problem


    I'm running a cron job that runs 3 scripts, all using the same shared libraries.
    for sake of discussion lets called them

    1.sh
    2.sh
    3.sh

    1 & 2 run fine but 3 produces an error "error while loading shared libraries: libpsAF:so: cannt open shared object file: No such file or directory.

    the file IS there and when I run the script manually, it runs fine.


    why is the cron job failing to run that one script properly?
    Last edited by jlew24asu; 06-13-2012 at 05:12 PM.

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    16
    I figured it out. turns out the other 2 scripts didnt use the shared libs so it didnt matter. I set the wrong lib path in the cron job.


    (sorry guys, I'm kinda new to linux)

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    6
    Hi,

    Try to export the LD_LIBRARY_PATH in the script 3.sh

    Code:
    LD_LIBRARY_PATH=/usr/sfw/lib
    export LD_LIBRARY_PATH

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •