Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Untitled.jpg Please let me know how to bring back eth0...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2012
    Posts
    11

    No eth0-redhat linux 6.0


    Untitled.jpg


    Please let me know how to bring back eth0
    Attached Images Attached Images

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Do you have the file

    /etc/sysconfig/network-scripts/ifcfg-eth0

    and if so please post the contents.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    11
    Yes, I got it
    contents are

    DEVICE=eth0
    BOOTPROTO=dhcp
    DEFROUTE= yes
    TYPE= ethernet
    ONBOOT= yes

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jan 2012
    Location
    Ohio
    Posts
    175
    Did it disappear after an update?

  6. #5
    Just Joined!
    Join Date
    Jun 2012
    Posts
    11
    after editing the ifcfg-eth0 file I got eth0 icon...but when I tried ifup eth0, i am getting the error as 1.jpg


    thanks

  7. #6
    Linux Newbie
    Join Date
    Jan 2012
    Location
    Ohio
    Posts
    175
    The system does not recognize that the device is installed. What I had asked was did the device exist and function at one point and then did you get this error message after processing some updates? The reason why I ask is on my fedora box when the kernel updates prior to my wireless module I lose wireless function. It may be the case with this particular ethernet card. Also, what kind of card is it.

  8. #7
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Are you sure this is 6.0? RHEL6.1 implemented biosdevname, which names ethernet interfaces differently, e.g. em1, em2, etc, for embedded motherboard nics. I think you can turn off the behavior with biosdevname=0 on the kernel command line (at install and in grub.conf).

  9. #8
    Just Joined!
    Join Date
    Jun 2012
    Posts
    11
    yes I am using 6.0.
    I got these controllers
    ethernet controller : Atheros communication device 1083 (rev c0)
    network controller : Atheros communication Inc. AR9300 wireless LAN adapter (rev 01)

    I didn't install any updates, actually I installed linux for the first time on to my laptop.

    thanks

  10. #9
    Linux Newbie
    Join Date
    Jan 2012
    Location
    Ohio
    Posts
    175
    Does you wirelss work? (I want to know in case you need to install a package). If you do lsmod | grep atl1c do you get a result? How about modprobe atl1c? If you get anything stating it can't find the module, you may need to install it.

  11. #10
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    You should be able to see your interface device names with "cat /proc/net/dev". Run "ethtool" on each. The one that shows actual settings should be the wired device. You can also see the link status. The one that returns "No data available" should be the wireless device.

    E.G:

    Code:
    [root@mudgen ~]# cat /proc/net/dev
    Inter-|   Receive                                                |  Transmit
     face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
        lo:   44942     420    0    0    0     0          0         0    44942     420    0    0    0     0       0          0
      eth1: 209406284  245896    0    0    0 69940          0         0 36461584  228456    5    0    0     0       0          0
      eth0:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    [root@mudgen ~]# ethtool eth0
    Settings for eth0:
    	Supported ports: [ TP MII ]
    	Supported link modes:   10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	Supported pause frame use: No
    	Supports auto-negotiation: Yes
    	Advertised link modes:  10baseT/Half 10baseT/Full 
    	                        100baseT/Half 100baseT/Full 
    	Advertised pause frame use: Symmetric Receive-only
    	Advertised auto-negotiation: Yes
    	Speed: 10Mb/s
    	Duplex: Half
    	Port: MII
    	PHYAD: 0
    	Transceiver: internal
    	Auto-negotiation: on
    	Supports Wake-on: pumbg
    	Wake-on: g
    	Current message level: 0x00000033 (51)
    			       drv probe ifdown ifup
    	Link detected: no
    [root@mudgen ~]# ethtool eth1
    Settings for eth1:
    No data available
    This one has no wire attached, has wireless connected on eth1.
    Last edited by Mudgen; 06-15-2012 at 02:58 PM. Reason: example added

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •