Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
create the .bash_profile and the .bashrc file under your home directory. Contents of the .bash_profile follow # .bash_profile # Get the aliases and functions if [ -f ~/.bashrc ]; then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jan 2011
    Posts
    4

    create the .bash_profile and the .bashrc file under your home directory. Contents of the .bash_profile follow

    # .bash_profile

    # Get the aliases and functions
    if [ -f ~/.bashrc ]; then
    . ~/.bashrc
    fi

    # User specific environment and startup programs

    PATH=$PATH:$HOME/bin

    export PATH



    Contents of .bashrc

    # .bashrc

    # Source global definitions
    if [ -f /etc/bashrc ]; then
    . /etc/bashrc
    fi

    # User specific aliases and functions

  2. #12
    Just Joined!
    Join Date
    Jun 2012
    Posts
    20
    Quote Originally Posted by pelf View Post
    What do you mean? How do I replace my username with the one for grep?
    Why is it that everything I do gives me permission denied and I have to use sudo?

  3. #13
    Just Joined!
    Join Date
    Jan 2011
    Posts
    4
    can you ls -la the files under home directory and the parent folder. Could be ownership issu
    e.g
    ls -la /home

    ls -la /home/newuser

    Do you have selinux enabled?

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jun 2012
    Posts
    20
    I have drwxr-xr-x. on new.user directory in home.

    which selinux returns: no selinux in ...

  6. #15
    Just Joined!
    Join Date
    Jan 2011
    Posts
    4
    I meant the user and group ownership of the home directory and the files and folders under it.

    To check selinux use the command getenforce

  7. #16
    Just Joined!
    Join Date
    Jun 2012
    Posts
    20
    same permissions. Enforcing!
    Still no permissions to write without using sudo.

  8. #17
    Just Joined!
    Join Date
    Jan 2011
    Posts
    4
    If you are not using selinux then I would suggest you can disable it for now.

    To disable the selinux, edit the file /etc/sysconfig/selinux

    modify the line, SELINUX=enforcing
    to
    SELINUX=disabled

    reboot the system. In case you cannot reboot the system then as root run the command "setenforce disable"

    This could resolve your issue.

  9. #18
    Just Joined!
    Join Date
    Jun 2012
    Posts
    20
    Didn't help... same issue... everything needs permission!

  10. #19
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I've never had to do this, so it's a shot in the dark here...
    Do this with sudo:
    Code:
    mv /home/old.name /home/new.name
    chown -r /home/old.name new.name
    Logout and log back in.
    It might work.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •