Find the answer to your Linux question:
Results 1 to 7 of 7
I do not know what the service name of the firewall demon is in fc 17 (is it sssd)? Why can't sssd be loaded with either the services config tool ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    14

    Question how start firewallD in fedora 17 - System Security Services sssd fails


    I do not know what the service name of the firewall demon is in fc 17 (is it sssd)? Why can't sssd be loaded with either the services config tool or chkconfig?
    Trying to add a printer results in:
    FirewallD is not running. Network printer detection needs services
    mdns
    ipp
    ipp-client
    samba-client
    Now, these services can be easily turned ON with:
    sudo system-config-firewall
    But, how does one start the firewall demon?
    Firstboot after an installation should give the first login an opportunity to have the firewall demon start on startup but it doesn't.

    Floyd,

  2. #2
    Just Joined!
    Join Date
    Apr 2011
    Posts
    5
    SSSD has nothing to do with the firewall. It's an authentication and authorization client (for logging in with centrally-managed LDAP and/or Kerberos users).

    system-config-firewall has been deprecated for a long time.

    You want to do 'service firewalld start'

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    system-config-firewall is not deprecated. its purpose is to provide a graphical tool for configuring the firewall (iptables). basically, it writes a /etc/sysconfig/iptables config file for you.

    The firewall initscript is controlled via the systemd script, /usr/lib/systemd/system/firewalld.service. you control it like this:
    Code:
    # start it
    systemctl start firewalld.service
    
    # stop it 
    systemctl stop firewalld.service
    
    # status
    systemctl status firewalld.service
    
    # enable it
    systemctl enable firewalld.service
    
    # see if enabled
    systemctl is-enabled firewalld.service
    for now, the legacy service method (service firewalld status) will work: the script name and command are simply passed to systemctl (well, its more complicated than that, but you get the idea).

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    14
    This does not work - output is:
    Failed to issue method call: Unit firewalld.service failed to load: No such file or directory. See system logs and 'systemctl status firewalld.service' for details.
    This is because systemctl -a shows there is NO service called firewall (or ANYTHING similar) in fc 17.
    This why I am asking what its name in fc 17 is. It probally is loaded by default. But what is its name. Probablly the printer config also thinks its name is firewalld which I can log a bug against it if that is the case.

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Code:
    yum install firewalld

  7. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    14
    Thanks - that worked - and now my HP printer works.
    The reason I didn't initially try this is because I can not imagine ANY OS NOT INTALLING A FIREWALL PACKAGE BY DEFAULT!

  8. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by floydsmith View Post
    Thanks - that worked - and now my HP printer works.
    The reason I didn't initially try this is because I can not imagine ANY OS NOT INTALLING A FIREWALL PACKAGE BY DEFAULT!
    you know, you're right about that: i use Fedora / RHEL regularly and I've never had to install it, even with a minimal/base install. i wonder if this is a F17 newness...i just checked one of my F17 boxes that was a base install - no firewalld. This is not a good idea.

    Edit: According to this Fedora wiki, firewalld is not enabled or installed by default, as of Fedora 15. But iptables IS installed (and I think enabled) in F15 and F16. Perhaps firewalld is not installed/enabled on F17 b/c it is still a work in progress, but that seems a bit dodgy to me, even for bleeding-edge Fedora.
    Last edited by atreyu; 07-13-2012 at 01:37 PM. Reason: link

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •