Find the answer to your Linux question:
Results 1 to 3 of 3
I just installed a fresh copy of CentOS 6.3 followed by MySQL and phpMyAdmin ver 3.5.2. I can start MySql fine, but I've run into an issue starting phpMyAdmin. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Posts
    27

    Error starting phpMySql on CentOS 6.3


    I just installed a fresh copy of CentOS 6.3 followed by MySQL and phpMyAdmin ver 3.5.2. I can start MySql fine, but I've run into an issue starting phpMyAdmin.

    I tried launching localhost/phpMyAdmin/ from Firefox and receive the error "You don't have permission to access /phpmyadmin/ on this server."

    I looked at the error_log in /etc/httpd/logs and found the following message: "[Sat Aug 04 14:49:34 2012] [error] [client ::1] Directory index forbidden by Options directive: /usr/share/phpMyAdmin/".

    I researched this in several websites and found recommendations for changing the /etc/httpd/conf.d/phpMyAdmin.conf file, which I have, but still cannot use phpMyAdmin.

    Here's the current settings in phpMyAdmin.conf file

    Alias /phpMyAdmin /usr/share/phpMyAdmin
    Alias /phpmyadmin /usr/share/phpMyAdmin

    <Directory /usr/share/phpMyAdmin/>
    <IfModule mod_authz_core.c>
    # Apache 2.4
    Require local
    </IfModule>
    <IfModule !mod_authz_core.c>
    # Apache 2.2
    Order Deny,Allow
    Deny from All
    Allow from 127.0.0.1
    Allow from ::1
    </IfModule>
    </Directory>

    I tried chaning it to this, but receive the same "You do not have permission..." error from Firefox and the same "[Sat Aug 04 14:49:34 2012] [error] [client ::1] Directory index forbidden by Options directive: /usr/share/phpMyAdmin/" error in the httpd erro_log file.

    <Directory /usr/share/phpMyAdmin/>
    <IfModule mod_authz_core.c>
    # Apache 2.4
    Require local
    </IfModule>
    <IfModule !mod_authz_core.c>
    # Apache 2.2
    Order Deny,Allow
    Allow from All
    </IfModule>
    </Directory>

    If I specify my local ipaddress "Allow from x.x.x.x" and use x.x.x.x/phpmyadmin/ in Firefox, I get the same results.

    One website suggested adding 8080 as the port "x.x.x.x:8080/phpmyadmin/", but Firefox replys that it can't establish a connection.

    Can some please help me with this. I'm pulling my hair out!

    Thanks
    Last edited by jjscott; 08-04-2012 at 07:33 PM.

  2. #2
    Just Joined!
    Join Date
    Apr 2011
    Posts
    27
    Update...
    If I comment out the "DenyAll" line in the phpMyAdmin.conf file, I get some sort of php script displayed by FireFox when launching localhost/phpMyAdmin/.

    Alias /phpMyAdmin /usr/share/phpMyAdmin
    Alias /phpmyadmin /usr/share/phpMyAdmin

    <Directory /usr/share/phpMyAdmin/>
    <IfModule mod_authz_core.c>
    # Apache 2.4
    Require local
    </IfModule>
    <IfModule !mod_authz_core.c>
    # Apache 2.2
    Order Deny,Allow
    # Deny from All
    Allow from 127.0.0.1
    Allow from ::1
    </IfModule>
    </Directory>

    Here the resulting page that is displayed by Firefox...

    <?php
    /* vim: set expandtab sw=4 ts=4 sts=4: */
    /**
    * forms frameset
    *
    * or common.inc.php
    * @package PhpMyAdmin
    */

    /**
    * Gets core libraries and defines some variables
    */
    require_once './libraries/common.inc.php';

    // free the session file, for the other frames to be loaded
    session_write_close();

    // Gets the host name
    if (empty($HTTP_HOST)) {
    if (PMA_getenv('HTTP_HOST')) {
    $HTTP_HOST = PMA_getenv('HTTP_HOST');
    } else {
    $HTTP_HOST = '';
    }
    ...

  3. #3
    Just Joined!
    Join Date
    Apr 2011
    Posts
    27
    Issue resolved. Found that CentOS doesn't have the require PHP components. Installed PHP & all is well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •