Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all, Fedora 17 64 bit System Settings -> Sound -> Output Choose a device for sound output: Code: RS780 Azalia controller Digitaol Stereo (HDMI) But Code: analog output built-in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    No sound on external speaker


    Hi all,

    Fedora 17 64 bit

    System Settings -> Sound -> Output
    Choose a device for sound output:
    Code:
    RS780 Azalia controller Digitaol Stereo (HDMI)

    But
    Code:
    analog output built-in audio
    not found

    The built-in speaks on LCD display works. But I can't select sound on external speakers

    Please advise how to fix it? TIA

    satimis

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,849
    I wonder if the hardware you have is hiding the analogue sound when you use the HDMI? Is that sound option there if you boot up using HDMI? What about if you boot up using the laptop display and plug in the HDMI afterwards?

    Does Alsamixer give you an option to turn the analogue device on and off in either of these scenarios?

    I know the HDMI is supposedly DRM locked, so if you're using it it's supposed to prevent you diverting part of the audio/video output stream down another channel. Perhaps if the HDMI socket is built-in you'll have a BIOS option for that? It might prevent you from playing DRM stuff over the HDMI display if that's the case, but it might be an interesting test if it a setting exists.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by Roxoff View Post
    I wonder if the hardware you have is hiding the analogue sound when you use the HDMI? Is that sound option there if you boot up using HDMI? What about if you boot up using the laptop display and plug in the HDMI afterwards?
    Please explain in more detail. How to boot up using
    the laptop display and plug in the HDMI afterwards?

    Does Alsamixer give you an option to turn the analogue device on and off in either of these scenarios?
    $ alsamixer
    Code:
     Card: PulseAudio                                     F1:  Help               │
    │ Chip: PulseAudio                                     F2:  System information │
    │ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
    │ Item: Master                                         Esc: Exit               │
    Only "Master" is there

  4. #4
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by satimis View Post
    Please explain in more detail. How to boot up using
    the laptop display and plug in the HDMI afterwards?


    $ alsamixer
    Code:
     Card: PulseAudio                                     F1:  Help               │
    │ Chip: PulseAudio                                     F2:  System information │
    │ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
    │ Item: Master                                         Esc: Exit               │
    Only "Master" is there
    Edit:

    Ubuntu 12.04 LTS is running on this PC but on another HD. Both HDs are NOT connected at the same time. There is no sound problem on Ubuntu. Both built-in speakers and external speakers are working without problem.

    System Settings -> Sound -> Output
    Choose a device for sound output:

    both
    Code:
    RS780 Azalia controller Digitaol Stereo (HDMI)
    
    analog output built-in audio
    are there.

  5. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,849
    Quote Originally Posted by satimis View Post
    Please explain in more detail. How to boot up using
    the laptop display and plug in the HDMI afterwards?
    I made the assumption that you had an HDMI socket on your machine and you were either booting up with and without it connected. The test was about booting up with the HDMI lead unplugged from your laptop and then plugging it in after bootup was complete. If you don't have an HDMI lead running from your laptop, then you probably can't do this.

    From your later posts you clearly have a difference between Fedora and Ubuntu. I use Fedora 17 on my desktop and, while I don't use the same sound chip as you, I don't experience this problem. For me the analogue sound device is available.

    There could be a bug in the Fedora sound system, however, that is not present in the Ubuntu system. It may help to compare which versions of Alsa and/or PulseAudio you have installed.

    There may also be an issue with your Video drivers, as, it would seem, the HDMI output is generated by the video card. Do you run proprietary drivers on either system? Perhaps your Fedora is running with Nouveau drivers while in Ubuntu you've got the closed-source nVidia drivers?
    Linux user #126863 - see http://linuxcounter.net/

  6. #6
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by Roxoff View Post
    - snip -

    It may help to compare which versions of Alsa and/or PulseAudio you have installed.
    Fedora 17
    =======

    $ rpm -qa | grep alsa
    Code:
    alsa-tools-firmware-1.0.25-2.fc17.x86_64
    alsa-lib-1.0.25-3.fc17.x86_64
    alsa-firmware-1.0.25-1.fc17.noarch
    alsa-plugins-pulseaudio-1.0.25-3.fc17.x86_64
    alsa-utils-1.0.25-8.fc17.x86_64
    $ rpm -qa | grep pulseaudio
    Code:
    pulseaudio-module-zeroconf-1.1-9.fc17.x86_64
    wine-pulseaudio-1.5.11-1.fc17.x86_64
    pulseaudio-gdm-hooks-1.1-9.fc17.x86_64
    pulseaudio-module-gconf-1.1-9.fc17.x86_64
    pulseaudio-1.1-9.fc17.x86_64
    pulseaudio-module-bluetooth-1.1-9.fc17.x86_64
    pulseaudio-esound-compat-1.1-9.fc17.x86_64
    pulseaudio-module-x11-1.1-9.fc17.x86_64
    pulseaudio-libs-1.1-9.fc17.x86_64
    pulseaudio-utils-1.1-9.fc17.x86_64
    alsa-plugins-pulseaudio-1.0.25-3.fc17.x86_64
    pulseaudio-libs-glib2-1.1-9.fc17.x86_64
    - snip -
    Do you run proprietary drivers on either system?
    No.


    Ubuntu 12.04
    ==========


    $ apt-cache policy alsa-*
    Code:
    bluez-alsa:
      Installed: 4.98-2ubuntu7
      Candidate: 4.98-2ubuntu7
      Version table:
     *** 4.98-2ubuntu7 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
            100 /var/lib/dpkg/status
    
    gstreamer0.10-alsa:
      Installed: 0.10.36-1ubuntu0.1
      Candidate: 0.10.36-1ubuntu0.1
      Version table:
     *** 0.10.36-1ubuntu0.1 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Pack
    
    alsa-utils:
      Installed: 1.0.25-1ubuntu5
      Candidate: 1.0.25-1ubuntu5
      Version table:
     *** 1.0.25-1ubuntu5 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
            100 /var/lib/dpkg/status
    
    alsa-base:
      Installed: 1.0.25+dfsg-0ubuntu1
      Candidate: 1.0.25+dfsg-0ubuntu1
      Version table:
     *** 1.0.25+dfsg-0ubuntu1 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
            100 /var/lib/dpkg/status
    $ apt-cache policy pulseaudio
    Code:
    pulseaudio:
      Installed: 1:1.1-0ubuntu15.1
      Candidate: 1:1.1-0ubuntu15.1
      Version table:
     *** 1:1.1-0ubuntu15.1 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
            100 /var/lib/dpkg/status
         1:1.1-0ubuntu15 0
            500 http://hk.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

    satimis
    Last edited by satimis; 09-24-2012 at 02:47 PM.

  7. #7
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,849
    It looks like the biggest difference is with PulseAudio (1.1.0 with Ubuntu and 1.1.9 with Fedora). There is a change log here: pulseaudio-1.1-9.fc17 | Build Info | Koji. The interesting bit is this:

    Code:
    * Sat Apr 21 2012 Matthias Clasen <mclasen@redhat.com> - 1.1-9 - Update default.pa to not load the CK module 
    * Tue Feb 28 2012 Bruno Wolff III <bruno@wolff.to< - 1.1-8 - Fix for building with gcc 4.7 
    * Mon Feb 20 2012 Lennart Poettering <lpoetter@redhat.com> - 1.1-7 - Temporary fix for CK/systemd move (#794690)
    * Mon Jan 23 2012 Dan Horák <dan@danny.cz> - 1.1-6 - rebuilt for json-c-0.9-4.fc17 
    * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-5 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild 
    * Tue Dec 13 2011 Adam Jackson <ajax@redhat.com> 1.1-4 - Fix RHEL build 
    * Tue Nov 22 2011 Rex Dieter <rdieter@fedoraproject.org> 1.1-3 - Obsoletes: padevchooser < 1.0 
    * Thu Nov 10 2011 Rex Dieter <rdieter@fedoraproject.org> 1.1-2 - -libs: Obsoletes: pulseaudio-libs-zeroconf - use versioned Obsoletes/Provides - tighten subpkg deps via %_isa - remove autoconf/libtool hackery 
    * Thu Nov 03 2011 Lennart Poettering <lpoetter@redhat.com> - 1.1-1 - New upstream release
    Most of these are fixes to make it build on different platforms. Perhaps that last update in the list includes something that has changed HDMI output - it's all a bit unspecific.

    I suspect you have no way to roll back to a version of PulseAudio on Fedora to 1.1-0 or earlier. The assumption I'd make is that this no longer works, either by design or by some unexpected change. Perhaps it would be useful to raise a bug with Fedora about it? At least then you'd get an official response.

    It might also help to look at the check-in log for PulseAudio - the change that made this happen might be clearly marked. I suspect that when Ubuntu comes to include 1.1.1 or later, that it might bring in the change too.

    Other suggestions:
    - I saw bug reports against Fedora that showed that selinux had caused problems for the audio system -especially with the bluez package. It might be interfering - so you could try temporarily disabling selinux and see if that causes the problem to stop.
    - If you've an nVidia or ATI video chipset, you could try using the proprietary video drivers - it might contain better support for the audio output via HDMI.
    Linux user #126863 - see http://linuxcounter.net/

  8. #8
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi Roxoff,

    Problem solved as follows;

    System Settings -> Sound

    Sound window starts:
    Select "Hardware" tag
    On "Profile" droplist
    -> select "Analog Surround 7.1 Output + Analog Stereo Input"

    Select "Output" tag
    "Internal Audio Analog Surround 7.1" device appears
    -> Select above device for sound output

    Now external speakers work.

    Thanks.

    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •