Find the answer to your Linux question:
Results 1 to 2 of 2
I recently tried to update my sound card as some applications were having providing horrible sound quality. While attempting to install said drivers I messed up my audio card drivers ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    1

    No Sound Card in Fedora 17


    I recently tried to update my sound card as some applications were having providing horrible sound quality. While attempting to install said drivers I messed up my audio card drivers all together. I was hoping that someone might be able to help me get them back to the way they were when they were "working."

    lspci provided me with the following audio device:

    Code:
     ~]$ lspci 
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
    when I run aplay -l i get the following
    Code:
     ~]$ aplay -l
    aplay: device_list:256: no soundcards found...
    I tried to install alsa and realtek drivers in that order. I think this was a mistake because i believe also drivers were already installed and wouldn't make any difference.

    When I look at the sound settings in the system settings menu from the GUI there is no device in the hardware tab.

    I can help provide whatever will be helpful in troubleshooting this issue. Please help i've gone to the crazy side!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    i'd try removing the realtek drivers, if that is possible.

    then reinstall the alsa packages and the kernel, as the audio drivers are part of the kernel. preferably get updated packages, too.

    Code:
    rpm -e --nodeps alsa-utils alsa-lib
    Code:
    yum update alsa-util alsa-lib kernel
    then reboot. make sure you pick the new kernel at the grub prompt (assuming a new one was installed).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •