Find the answer to your Linux question:
Results 1 to 8 of 8
Fedora 17 64bit Problem in running: # yum update Code: Loaded plugins: langpacks, presto, refresh-packagekit, versionlock Repository 'freshrpms' is missing name in configuration, using id adobe-linux-x86_64 | 951 B 00:00 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Problem re running Yum update


    Fedora 17 64bit

    Problem in running:

    # yum update
    Code:
    Loaded plugins: langpacks, presto, refresh-packagekit, versionlock
    Repository 'freshrpms' is missing name in configuration, using id
    adobe-linux-x86_64                                       |  951 B     00:00     
    fedora/metalink                                          | 8.7 kB     00:00     
    Error: Cannot find a valid baseurl for repo: freshrpms
    $ cat /etc/yum.repos.d/fedora-updates.repo
    Code:
    [updates]
    name=Fedora $releasever - $basearch - Updates
    failovermethod=priority
    #baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    
    [updates-debuginfo]
    name=Fedora $releasever - $basearch - Updates - Debug
    failovermethod=priority
    #baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    
    [updates-source]
    name=Fedora $releasever - Updates Source
    failovermethod=priority
    #baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    Pls help. TIA

    B.R.
    satimis

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Remove # sign before baseurl lines in fedoro-updates.repo file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by devils casper View Post
    Remove # sign before baseurl lines in fedoro-updates.repo file.
    $ sudo gedit /etc/yum.repos.d/fedora-updates.repo
    [sudo] password for satimis:

    Remove all # sign before baseurl lines

    $ sudo yum update
    Code:
    Loaded plugins: langpacks, presto, refresh-packagekit, versionlock
    Repository 'freshrpms' is missing name in configuration, using id
    Error: Cannot find a valid baseurl for repo: freshrpms
    Still failed

    # cat /etc/yum.repos.d/fedora-updates.repo
    Code:
    [updates]
    name=Fedora $releasever - $basearch - Updates
    failovermethod=priority
    baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    
    [updates-debuginfo]
    name=Fedora $releasever - $basearch - Updates - Debug
    failovermethod=priority
    baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    
    [updates-source]
    name=Fedora $releasever - Updates Source
    failovermethod=priority
    baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
    I found following strange thing;
    # gedit /etc/yum.repos.d/fedora-updates.repo
    Code:
    (gedit:3485): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported
    
    
    ** (gedit:3485): WARNING **: Could not connect to session bus

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,931
    Freshrpms is now part of RPM Fusion.

    I recommend you uninstall the repo before you start (you may need to use 'rpm -e ...' rather than 'yum remove ...' as yum cannot function with the broken repo), then follow the instructions on RPM Fusion's wiki page to add that repo. It should allow you to update any packages you installed from Freshrpms.
    Linux user #126863 - see http://linuxcounter.net/

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Freshrpms have been gone for last 3 years or so. Not a Fedora user anymore and forgot that...
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    $ sudo yum --disablerepo=freshrpms update

    works for me here.

    How to disable it permanently? Thanks

  8. #7
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,931
    Normally there will have been an rpm installed for the repository. Not all of them have one, but a lot of them do. Find out if you have one for freshrpms try

    Code:
    rpm -qa|grep -i fresh
    To remove it, delete it from your system with rpm:

    Code:
    rpm -e <name of rpm>
    If it doesn't have one then you should delete (or disable by setting the disabled= line in) the repository's config in your yum.repos.d directory.
    Linux user #126863 - see http://linuxcounter.net/

  9. #8
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    $ rpm -qa|grep -i fresh
    no output

    also tried;
    $ sudo rpm -qa|grep -i fresh

    no output as well. Strange!

    B.R.
    satimis


    Edit:
    ===

    # find / -name fresh*
    Code:
    find: `/run/user/satimis/gvfs': Permission denied
    /usr/share/man/man8/freshclam_selinux.8.gz
    /var/cache/yum/x86_64/17/freshrpms
    /var/lib/yum/repos/x86_64/17/freshrpms
    # ls /var/lib/yum/repos/x86_64/17/freshrpms/
    no output

    # ls -al /var/cache/yum/x86_64/17/freshrpms/
    Code:
    total 12
    drwxr-xr-x.  3 root root 4096 Oct 15 13:44 .
    drwxr-xr-x. 11 root root 4096 Oct 16 00:56 ..
    drwxr-xr-x.  2 root root 4096 Sep 24 20:09 packages
    Last edited by satimis; 10-16-2012 at 03:05 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •