Find the answer to your Linux question:
Results 1 to 3 of 3
I have a system with P-III processor which works on 850 MHz with "siliconmotion" graphics adapter.My BIOS supports APM not ACPI. I installed a customized version of fedora-8 (only some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Location
    New Delhi, India.
    Posts
    2

    Display screen going blank


    I have a system with P-III processor which works on 850 MHz with "siliconmotion" graphics adapter.My BIOS supports APM not ACPI. I installed a customized version of fedora-8 (only some application packages and services are removed, and all the driver packages are there).

    The problem is the screen goes blank after half an hour or so, even if I have set the Power Management option to "NEVER" for AC power and Battery, and a gnome screen saver is also there.
    After this also the screen goes black/blank and never comes up on mouse movement or keypress, only option is to reboot the system. Also the vertual terminals are blank(Can't switch Alt+Ctrl+F1 etc.).

    Please Help.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,851
    The screen blanking here is being done by your X server not by the secreen saver, so the solution is to change your /etc/X11/xorg.conf file. Edit it as the root user (use 'sudo' or 'su') and add these to the 'ServerLayout' section:

    Code:
        Option      "OffTime"       "0"
        Option      "BlankTime"     "0"
        Option      "StandbyTime"   "0"
        Option      "SuspendTime"   "0"
    And if your 'Monitor' section has a 'Option "DPMS"', change it to "NODPMS". That should do it.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •