Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 23
at first It said Code: error: "qt-x11" specifies multiple packages: qt-x11-4.8.2-4.fc17.x86_64 qt-x11-4.8.2-4.fc17.i686 qt-x11-4.8.2-7.fc17.x86_64 So I tried Code: sudo rpm -e qt-x11-4.8.2-7.fc17.x86_64 [sudo] password for mburghard: /sbin/ldconfig: file /lib/libQtDesigner.so.4.8.2;507b0eb8 is truncated...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25

    at first It said

    Code:
    error: "qt-x11" specifies multiple packages:
      qt-x11-4.8.2-4.fc17.x86_64
      qt-x11-4.8.2-4.fc17.i686
      qt-x11-4.8.2-7.fc17.x86_64

    So I tried
    Code:
    sudo rpm -e qt-x11-4.8.2-7.fc17.x86_64
    [sudo] password for mburghard: 
    /sbin/ldconfig: file /lib/libQtDesigner.so.4.8.2;507b0eb8 is truncated

  2. #12
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by Mark25 View Post
    at first It said

    Code:
    error: "qt-x11" specifies multiple packages:
      qt-x11-4.8.2-4.fc17.x86_64
      qt-x11-4.8.2-4.fc17.i686
      qt-x11-4.8.2-7.fc17.x86_64
    you are on x86_64, not i686, right? if so, then try:
    Code:
    rpm -e --nodeps qt-x11-4.8.2-4.fc17.i686
    that truncated error is new to me. it does not sound good. anything in your /var/log/messages that looks suspicious/interesting?

    for completeness, post your arch, distro, and version.

  3. #13
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25
    the console returned
    Code:
    qt-x11-4.8.2-4.fc17.i686 is truncated
    I can't seem to get the /var command to work. Maybe I'm typing it wrong. Could you give me the specific command to open up the /var stuff? Also, after it said the code above, I typed the same command you gave again, and it said that qt-x11-4.8.2-4fc17.i686 was erased.

  4. $spacer_open
    $spacer_close
  5. #14
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by Mark25 View Post
    the console returned
    Code:
    qt-x11-4.8.2-4.fc17.i686 is truncated
    i guess it is complaining about a corrupt file in the package, but you hopefully should still be able to remove the package with the rpm command.

    I can't seem to get the /var command to work. Maybe I'm typing it wrong. Could you give me the specific command to open up the /var stuff?
    Sorry, I should have been more clear. What I meant was to check your syslog, which is typically saved to this file:
    Code:
    /var/log/messages
    you can open the file with an editor, but it is constantly being written to, so you're better off using cat or tail, e.g.:

    Code:
    tailf /var/log/messages
    that command will send the entire contents of the file to STDOUT (your screen), and keep it open, so that any new stuff will appear at the bottom of the screen. So it is handy, when trouble-shooting, to open a terminal, su to root and run a tail of this log. Then in another terminal, do your actual trouble-shooting commands.

    another handy thing to do is search the file for something particular, using grep, e.g.:

    Code:
    grep -i rpm /var/log/messages
    so have you tried to yum update again?

  6. #15
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25
    the grep command returned

    Code:
    yum[5110]: Updated: rpmfusion-free-release-17.0.3-1.noarch
    The tailf command returned an insanely long list which I can't copy paste. I then updated, which surprisingly actually worked, but I rebooted and it still booted in fallback mode. So close... I just reinstalled the gnome-panel, hoping it might help. What should I do now?

  7. #16
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25
    I also just figured out my graphics driver. It's Gallium 0.4 on NV86.

  8. #17
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    is the Fedora nvidia xorg driver installed? check with:

    Code:
    rpm -qv xorg-x11-drv-nouveau
    if not, install it with:
    Code:
    yum update xorg-x11-drv-nouveau
    also, show your kernel boot args with this command:

    Code:
    cat /proc/cmdline
    there is also the option of installing NVidia's closed binary driver (if you're okay w/that). I usually have no problems with it, but I have run of the mill nvidia hardware.

  9. #18
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25
    Console returned
    Code:
    xorg-x11-drv-nouveau-0.0.16-37.20120306gitf5d1cd2.fc17.x86_64
    after entering cat command I got

    Code:
    BOOT_IMAGE=/vmlinuz-3.6.1-1.fc17.x86_64 root=/dev/mapper/vg_trogdor-lv_root ro rd.lvm.lv=vg_trogdor/lv_swap rd.md=0 rd.dm=0 SYSFONT=True rd.lvm.lv=vg_trogdor/lv_root KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet

  10. #19
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Try adding modesetting and dri drivers:

    Code:
    yum update mesa-dri-drivers  xorg-x11-drv-modesetting
    then reboot.

    also, post your xorg.conf file, if you have one. it would be here:

    Code:
    /etc/X11/xorg.conf
    also, post your xorg log. it is big, but we may need it. it should be here:

    Code:
    /var/log/Xorg.0.log

  11. #20
    Just Joined!
    Join Date
    Oct 2012
    Posts
    25
    Code:
    sudo yum update mesa-dri-drivers xorg-xll-drv-modsetting
    [sudo] password for mburghard: 
    Loaded plugins: langpacks, presto, refresh-packagekit
    No Match for argument: xorg-xll-drv-modsetting
    No package xorg-xll-drv-modsetting available.
    No Packages marked for Update
    returned for yum update command. It kept telling me the others weren't valid commands.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •