Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Login prompt issue


    I have a Oracle VM virtual box built using the Centos 6.2. To do some of my test, I copied the linux 2.6.32 kernel into a new partition that I have created and just compiled and built the kernel with some extraversion appended to the name. I did not do any code change though. I rebooted the box and selected the new kernel as the image. It comes up and asks for Login prompt. I supplied the "root" as login and password as the one I had created for first time VM box boot up.

    The problem is even after entering the values, the same login prompt screen comes up again and again and I'm unable to login. I tried giving wrong values for login name and then wrong password. But it says login incorrect in that case. I'm stuck up here and unable to figure out the problem. Infact if I reboot the box with the original kernel image it comes up fine.

    Request anyone who could help me a work around for the same.

    Thanks so much in advance.

  2. #2
    Hello and welcome!

    Try this: reboot and select your custom kernel, but before hitting Enter to boot it, select a key ("e" for Edit, I think) to modify the parameters. Then at the end of the "kernel" or "linux" line (it is one or the other), enter " 1" (that's a space followed by the number "one", not a Lower case "L") to boot into single user mode. After the kernel finishes loading, it should just drop you to a bash prompt, no login prompt. The idea here is to just make sure that your custom kernel can get this far. Then you can do something like create a test user, and see if that user can then log in (using "su - newuser"). If/when it fails, you can then check /var/log/messages for any clues as to why.

  3. #3

    Thanks a lot for your help. It worked.
    Also thanks for welcoming

  4. $spacer_open
  5. #4
    Out of my own morbid curiosity, what helped, exactly? I didn't give you any fixes, just troubleshooting ideas. so you must have either done something, or determined it wasn't really a problem.

    do you mind sharing?

  6. #5
    oops sorry for the half reply.
    yes; i was able to login to the bash prompt ; add user name etc. So I left it at that point. Later I tried to create and mount a new filesystem. I was unable to as it said root permission needed. So I tried that also. But it said operation failed. So I rebooted for trying something else. Unfortunately when I tried to boot it again with the native kernel, this time it gave me login prompt which was expected, but it did not take the credentials and again prompted the same screen. looks like my filesystem operation screwed the password file or something. Finally things went wrong.

  7. #6
    --> are things working or aren't they? Are you still having the problem you original posted in this thread? If not, let's go ahead and close this thread. If you still have problems, but they are different, then go ahead and start a new thread, if you haven't already.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts