Find the answer to your Linux question:
Results 1 to 3 of 3
Hello guys, I have a big problem mounting my devices, pease read on before you refer to similar problems. I tried several times to edit the /etc/fstab file as I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    1

    Exclamation Problem with "Automount" option in the Disk utility / Can'


    Hello guys,

    I have a big problem mounting my devices, pease read on before you refer to similar problems.

    I tried several times to edit the /etc/fstab file as I used to do with previous fedora versions but it doesn't work anymore (fedora fails to boot).

    Well, I got used to living with the problem and mounted the devices everytime I restart my PC by double clicking each disk and filling the root password which was OK until I found the "Disks" utility under the "Applications".

    What I did is that I selected each single disk, and chose "Edit Mount options" and turned the "Automount" option from the settings window (as you can see in the image).

    Once I restarted my device, it couldn't login anymore and I got the "Cannot open font file True" error message, tried to solve by replacing this value with "latarcyrheb-sun16" in two files:

    PHP Code:
    /etc/sysconfig/i18  
    /etc/default/grub 
    Once I changed the font option in these two files and rebooted my PC, I got the following message right after the login service started :

    Code:
    [  42.178048]  systemd-readahead-collect [398]: Failed to open pack file : Read-only file system

    I fixed the two files back to their defaults and I'm back to the first error messgae "Cannot open font file True".

    What I need now is to disable the autmount option and get back to the old setting - which I know is impossible- but at least to reverse or undo what the Disk utility has done.

    I'm using the liveuser on my rescu disk right now, and this is the result of my fdisk -l :

    Code:
    Disk /dev/sda: 250.1 GB, 250058268160 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488395055 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0007d514
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            2048     1026047      512000   83  Linux
    /dev/sda2         1026048   241666047   120320000    f  W95 Ext'd (LBA)
    /dev/sda3       241666048   380930047    69632000    7  HPFS/NTFS/exFAT
    /dev/sda4   *   380930048   488392703    53731328    7  HPFS/NTFS/exFAT
    /dev/sda5         1028096   139266047    69118976    7  HPFS/NTFS/exFAT
    /dev/sda6       139268096   241666047    51198976   8e  Linux LVM
    
    Disk /dev/mapper/live-rw: 4294 MB, 4294967296 bytes
    255 heads, 63 sectors/track, 522 cylinders, total 8388608 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    
    Disk /dev/mapper/live-osimg-min: 4294 MB, 4294967296 bytes
    255 heads, 63 sectors/track, 522 cylinders, total 8388608 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    
    Disk /dev/mapper/vg-lv_swap: 6274 MB, 6274678784 bytes
    255 heads, 63 sectors/track, 762 cylinders, total 12255232 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    
    Disk /dev/mapper/vg-lv_root: 46.1 GB, 46137344000 bytes
    255 heads, 63 sectors/track, 5609 cylinders, total 90112000 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes

    I'm very thankful for your help in advance, I need a soution to run my fedora first to get back to work, after that we can solve the disks mounting problem.



    Screenshot_from_2012_11_08_02_12_23.jpg

  2. #2
    Just Joined! rm-rf's Avatar
    Join Date
    Mar 2011
    Posts
    84
    It looks like you just have to set the boot option on the linux partition. you can just use fdisk for that.

  3. #3
    Just Joined!
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    96
    Try this out for your issue.

    Repair linux (fedora) bootloader using rescue disk

    Repair linux (fedora) bootloader using rescue disk. ||RANA SAHOO~~LIFE AROUND SYSTEM||

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •