Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all Am using centos. Just now i installed Vmware virtual Machine. In my server am using two Lan Cards & assigned two ip's for example : 10.10.10.1 (Public IP) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    40

    Virtual Machine Network connection problem


    Hi all

    Am using centos.

    Just now i installed Vmware virtual Machine. In my server am using two Lan Cards & assigned two ip's

    for example : 10.10.10.1 (Public IP)
    192.168.1.20 ( Local ip)

    am accessing internet from public ip

    My ip configuration for one lan card is
    IP Address: 10.10.10.1
    Netmask : 255.255.255.252
    gateway : 10.10.10.2

    Second Lan card
    ip address : 192.168.1.20
    netmask : 255.255.255.0
    gateway : 0.0.0.0

    I can access internet as well as i can connect to local machines which are connected in LAN.

    I installed virtual machine (centos). I Changed Virtual machine network setting as "bridged" and assinged ip as example: 192.168.1.65 & netmsk: 255.255.255.0, gateway: 0.0.0.0, but cannt able to connect internet as well as local machines which connected in LAN. Even i assigned gateway for virutal machine as 192.168.1.20 but cannot get solution.

    Please help me out to solve the problem as soon as possible.

    Thanks & regards

    Jeyachandran M

  2. #2
    Linux Newbie
    Join Date
    Apr 2012
    Posts
    112
    Quote Originally Posted by jeyachandranlinux View Post
    Hi all

    Am using centos.

    Just now i installed Vmware virtual Machine. In my server am using two Lan Cards & assigned two ip's

    for example : 10.10.10.1 (Public IP)
    192.168.1.20 ( Local ip)

    am accessing internet from public ip

    My ip configuration for one lan card is
    IP Address: 10.10.10.1
    Netmask : 255.255.255.252
    gateway : 10.10.10.2

    Second Lan card
    ip address : 192.168.1.20
    netmask : 255.255.255.0
    gateway : 0.0.0.0

    I can access internet as well as i can connect to local machines which are connected in LAN.

    I installed virtual machine (centos). I Changed Virtual machine network setting as "bridged" and assinged ip as example: 192.168.1.65 & netmsk: 255.255.255.0, gateway: 0.0.0.0, but cannt able to connect internet as well as local machines which connected in LAN. Even i assigned gateway for virutal machine as 192.168.1.20 but cannot get solution.

    Please help me out to solve the problem as soon as possible.

    Thanks & regards

    Jeyachandran M
    I would mirror your physical set up on your vm, ie. two nics on the virtualized centos box. may not be what you want.

    You could try setting up VMware NATing, but this would require port forwarding.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •