Find the answer to your Linux question:
Results 1 to 4 of 4
Hi , I have a linux box that simulate a DHCP server for WiMAX CPEs The version is Linux version 2.6.18-238.12.1.el5 (centos.org) My concern is that i want to send ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2

    DHCP Server


    Hi ,
    I have a linux box that simulate a DHCP server for WiMAX CPEs
    The version is
    Linux version 2.6.18-238.12.1.el5 (centos.org)
    My concern is that i want to send the DHCP option 26 (MTU size) in the DHCP offer
    Below is the configuration file
    # DHCP Server Configuration file.
    # see /usr/share/doc/dhcp*/dhcpd.conf.sample
    #
    ddns-update-style none;
    #ddns-update-style interim
    #ignore client-updates
    #always-broadcast on;
    authoritative;
    default-lease-time 10800;
    #max-lease-time 10800;

    ping-check true;

    deny duplicates;

    #log-facility local6;

    shared-network wimax {

    subnet 192.168.30.0 netmask 255.255.255.0 {
    }

    subnet 109.107.136.0 netmask 255.255.248.0 {

    # --- default gateway
    option routers 109.107.136.1;
    option subnet-mask 255.255.248.0;

    option domain-name "mssk.com";
    option domain-name-servers 109.107.128.101, 109.107.131.171;

    option time-offset -18000; # Eastern Standard Time
    #option interface-mtu 1440;
    range 109.107.136.120 109.107.143.254;

    What should i add to ensure that the option is sent via the offer?

    Thanks

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Why are you worried about the MTU settings?
    Is there a special need for this?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2
    Hi , Thanks for the reply
    yes actually i am in need of this as the setup I have needs this
    I have the WiMAX GW (ASN GW) is configured with 1472 MTU and does not support fragmentation
    So , I have to pass by the CPEs individually to change the MTU to cope
    I want this to be sent via my DHCP server

    BR,
    MSSK

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    The setting should be;

    Code:
    option interface-mtu 1472;

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •