Find the answer to your Linux question:
Results 1 to 4 of 4
Hello all, I have a Red Hat 4.10 machine that is giving me the "This account is currently not available" message which is caused by having /sbin/nlogin in the /etc/passwd ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    19

    This account is currently not available


    Hello all,
    I have a Red Hat 4.10 machine that is giving me the "This account is currently not available" message which is caused by having /sbin/nlogin in the /etc/passwd file. Trouble is the RH box is authenticating off a Windows 2003 R2 server. I can login to the Windows box with my login and password. I've even created my Windows account using a known working user. When I do a getent passwd | grep <mylogin> I see where I have a *LK* account with /sbin/nologin, even though the Unix Attributes tab under my Windows Properties on the 2003 server shows the correct shell, home account, and such. Anyone ever dealt with this kind of issue?
    Thanks

  2. #2
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    649
    And what type of authorization is the Red Hat system using. Telling Windows that you have Unix/Linux attributes does not configure your Red Hat to use them.

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Posts
    19
    That is what I can't figure out. When I use authconfig there is nothing configured. No winbind, no kerberos, no ldap, nothing. The user that works does not have an entry in /etc/passwd. The output of id and groups show we have the same values. The nsswitch.conf uses compat for passwd, shadow and group. There is nothing in any of the .deny or .allow files. There is nothing in /etc/security. Firewall is stopped and selinux is disabled.

  4. #4
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    649
    Assuming that you have say ldap configured to be used in during logging their is usually a pecking order as a way to authorize access. This is the "/etc/nsswitch.conf" file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •