Find the answer to your Linux question:
Results 1 to 7 of 7
Hi. New guy here. My group's working on a project that needs SARG installed in Fedora 17. Problem is we can't make SARG work in Fedora 17. We always get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2012
    Posts
    9

    SARG and Fedora 17


    Hi. New guy here. My group's working on a project that needs SARG installed in Fedora 17. Problem is we can't make SARG work in Fedora 17. We always get the error message that access.log can't be found. We installed SARG in root mode so I don't think the problem no longer lies in permissions. Can anyone help us out on how to fix this? We can't use any other OS or tools because we've already stated in our paper that we'll use them for the project. By the way, our project aims to make SARG work in a PC that functions as a transparent bridge with 3 ports.

  2. #2
    Just Joined!
    Join Date
    Jun 2012
    Posts
    32
    post the output of this command as root:
    Code:
    cat /usr/local/etc/sarg.conf

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    32

  4. #4
    Just Joined!
    Join Date
    Dec 2012
    Posts
    9
    Thanks, kareempharmacist. Tried the instructions from the link you provided, but I installed sarg 2.3.3 instead of 2.3.1. No luck. I still got the same error.

    SARG: File not found: /var/log/squid/access.log

    Do I need squid installed as well before I run sarg?

  5. #5
    Just Joined!
    Join Date
    Jun 2012
    Posts
    32
    try installing squid and see what your luck will be!!!

  6. #6
    Just Joined!
    Join Date
    Dec 2012
    Posts
    9
    This is what I got upon entering ./configure after extracting squid:

    checking for g++... no
    checking for c++... no
    checking for gpp... no
    checking for aCC... no
    checking for CC... no
    checking for cxx... no
    checking for cc++... no
    checking for cl.exe... no
    checking for FCC... no
    checking for KCC... no
    checking for RCC... no
    checking for xlC_r... no
    checking for xlC... no
    checking whether the C++ compiler works... no
    configure: error: in `/home/Bobon/squid-3.3.0.2/lib/libTrie':
    configure: error: C++ compiler cannot create executables
    See `config.log' for more details
    configure: error: ./configure failed for lib/libTrie

    I've already got gcc and binutils installed.

  7. #7
    Just Joined!
    Join Date
    Dec 2012
    Posts
    9
    OK... I've gotten past the issues with squid by using yum. I've also gotten past the missing access.log with the help of these commands:

    touch /var/log/squid/access.log
    chown squid:squid /var/log/squid/access.log

    Now, my problem is that there are no records and I can't access the report in my browser. The browser reports it can't connect to the IP I used. It's my wireless adapter's IP, which is what I'm currently using.

    SARG: sarg version: 2.3.3 Nov-13-2012
    SARG: Reading access log file: /var/log/squid/access.log
    SARG: Records in file: 0, reading: 100.00%
    SARG: Records read: 0, written: 0, excluded: 0
    SARG: No records found
    SARG: End
    Last edited by bobon721; 01-02-2013 at 07:55 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •