Find the answer to your Linux question:
Results 1 to 4 of 4
Hi Everybody, I'h ve configured BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5 server. I found a lot of stronge message in my log file since yesterday: Code: too many open file descriptors too many open ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3

    Problem using Bind9


    Hi Everybody,

    I'h ve configured BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5 server.
    I found a lot of stronge message in my log file since yesterday:
    Code:
    too many open file descriptors
    too many open file descriptors
    too many open file descriptors
    too many open file descriptors
    This is cause the server crash and i don't know why it happened.

    By doing a service named status, in found that i reach the limit in term of recursion :

    Code:
    recursive clients: 58042/60000
    Do you have an idea about this issue, i'm facing this problem since yesterday and my server still not working.


    THank you for your help

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Location
    California
    Posts
    98
    Let me ask a bunch of questions.
    0. What version of RedHat are you running. Please include output of "uname -a" and "cat /etc/redhat-release"
    1.. That is a very old version of BIND. Why not upgrade?
    2. Can you post the contents of your /etc/sysconfig/named file (don't include comment lines)
    3. Can you post the output of "ps -ef grep named"
    4. Can you post the output of "cat /proc/sys/fs/file-max"
    5. Which log are you seeing the errors in and can you include the full message.

    Without seeing the answers from the questions above, I can still take a stab at guessing what the problem is. You are probably running with privilege separation turned on. Either you are running into a per-user limit or you are running into a system limit

    If it is a per-user limit, the file you need to edit is /etc/security/limits.conf
    ---
    named hard nofile 20000
    named soft nofile 20000
    ---

    If it is a system limit, the file you need to edit is /etc/sysctl.conf
    ---
    fs.file-max = 350000
    ---

    Then reboot.

    But even if this works, you should still upgrade.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    Quote Originally Posted by abarclay View Post
    Let me ask a bunch of questions.
    0. What version of RedHat are you running. Please include output of "uname -a" and "cat /etc/redhat-release"
    1.. That is a very old version of BIND. Why not upgrade?
    2. Can you post the contents of your /etc/sysconfig/named file (don't include comment lines)
    3. Can you post the output of "ps -ef grep named"
    4. Can you post the output of "cat /proc/sys/fs/file-max"
    5. Which log are you seeing the errors in and can you include the full message.

    Without seeing the answers from the questions above, I can still take a stab at guessing what the problem is. You are probably running with privilege separation turned on. Either you are running into a per-user limit or you are running into a system limit

    If it is a per-user limit, the file you need to edit is /etc/security/limits.conf
    ---
    named hard nofile 20000
    named soft nofile 20000
    ---

    If it is a system limit, the file you need to edit is /etc/sysctl.conf
    ---
    fs.file-max = 350000
    ---

    Then reboot.

    But even if this works, you should still upgrade.
    Goog Morning ,

    The output of /proc/sys/fs/file-max est 1599290
    Concerning /etc/security/limits.conf. There is no available configuration. It's a per user limit ?


    Code:
    options {
            directory       "/var/bind9";
            dump-file       "/var/bind9/cache_dump.db";
            statistics-file "/var/bind9/named-stats.log";
            recursion yes;
            interface-interval 0;
            listen-on-v6 { none; };
            recursive-clients 60000;
            allow-query     {any;};
            allow-recursion {any;};
            max-ncache-ttl 43200; 
            version none;
    };
    
    zone "." IN {
            type hint;
            file "named.racine";
    };

  4. #4
    Just Joined!
    Join Date
    Dec 2009
    Location
    California
    Posts
    98
    You didn't answer all my questions, however, if I had to guess, I would suggest you change recursive-clients from 60000 to 100 and see if that fixes the problem.
    According to the documentation, that value should not need to be set higher than 1000 which is the default in bind 9. I can't think of any legitimate reason to support 60000 concurrent RECURSIVE queries unless your IP address happens to be 8.8.8.8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •