Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, My server is running RHEL6.3, and after shutting down, I am unable to boot up the server. I did not perform any upgrades or changes to the server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    22

    Kernel Panic - not syncing VFS in RHEL6.3


    Hi all,

    My server is running RHEL6.3, and after shutting down, I am unable to boot up the server. I did not perform any upgrades or changes to the server prior to the shut down, and this is a new server without much usage.

    I got this error after the grub screen.

    Code:
    i8042.c: Can't read CTR while initializing i8042.
    RAMDISK: incomplete write (32543 != 32768)
    write error
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    Pid: 1, comm: swapper Not tainted 2.6.32-279.el6.x86_64 #1
    Call Trace: 
       panic
       mount_block_root
       trace_kmalloc
       mount_root
       prepare_namespace
       kernel_init
       child_rip
       kernel_rip
       child_rip
    I am able to boot into Rescue mode, and I followed the instructions on this website (after changing the name of the initrd), but still get the same error.

    What is wrong and what else can I try? If nothing works, I'm going to reinstall the OS.

    Thank you.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,422
    Boot into rescue mode, and run fsck on your / (root) file system. On my RHEL 6 system, that is /dev/sda3. The error indicates that something happened to the root file system. This is rare, unless you shut down the system in an unclean manner (forced power-off for example).
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •