Find the answer to your Linux question:
Results 1 to 4 of 4
I've been trying to compile the Screem web editor and it was literally missing about a dozen dependencies. Well, after about 40 minutes of googling and figuring out which ones ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2012
    Posts
    14

    Struggling to install dependencies


    I've been trying to compile the Screem web editor and it was literally missing about a dozen dependencies. Well, after about 40 minutes of googling and figuring out which ones I need, I've narrowed it down to two which I can't seem to find.
    checking for SCREEM... configure: error: Package requirements ( gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libgnome-2.0 >= 2.13.7 libgnomeui-2.0 >= 2.6.0 libxml-2.0 >= 2.4.3 libglade-2.0 >= 2.3.0 gconf-2.0 >= 2.2.0 gnome-vfs-2.0 >= 2.8.3 gthread-2.0 >= 2.2.0 libgtkhtml-2.0 >= 2.2.0 libgnomeprint-2.2 >= 2.2.0 libgnomeprintui-2.2 >= 2.2.0 gtksourceview-1.0 >= 1.1.90 libgnome-menu >= 2.9.2 ) were not met:

    No package 'libgtkhtml-2.0' found
    No package 'libgnome-menu' found
    Can anybody help?

    Thanks!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hi,

    1. What is your distribution and version?

    2. Have you checked your distro's native software sources/repositories for a pre-packaged SCREEM?

    3. Have you tried using the native package manager (yum, apt-get, etc.) to install those missing files?

  3. #3
    Just Joined!
    Join Date
    Dec 2012
    Posts
    14
    Quote Originally Posted by atreyu View Post
    Hi,

    1. What is your distribution and version?

    2. Have you checked your distro's native software sources/repositories for a pre-packaged SCREEM?

    3. Have you tried using the native package manager (yum, apt-get, etc.) to install those missing files?
    Sorry, yes. I actually told myself to listmy distro and version prior to typing the message, I must have forgot.

    1. F17
    2. Yes
    3. Yes

    For instance, libgtkhtml-2.0 isn't there, however libgtkhtml-3.0 is, which I installed but it hasn't made a difference.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by RetroSpock View Post
    Sorry, yes. I actually told myself to listmy distro and version prior to typing the message, I must have forgot.
    It's all good. The more you post questions, the better you'll get at remembering stuff like that.

    For instance, libgtkhtml-2.0 isn't there, however libgtkhtml-3.0 is, which I installed but it hasn't made a difference.
    I see that Fedora most recently included the gtkhtml-2.0 header files and libs (in the form of the package gtkhtml2-devel) in the 15 release. You can force install the package, as it just install a bunch of header files to /usr/include/gtkhtml-2.0/ and the file /usr/lib/pkgconfig/libgtkhtml-2.0.pc using the rpm command. Or you unpackage the RPM and just temporarily make the files available for compilation. I tend to favor the latter, I don't introducing non-native RPMS if I can help it.

    In either case, first grab the RPM:
    Code:
    cd /tmp
    wget http://dl.fedoraproject.org/pub/fedora/linux/releases/15/Everything/i386/os/Packages/gtkhtml2-devel-2.11.1-11.fc15.i686.rpm
    If you wish to force install the RPM, as root, try:
    Code:
    rpm -ivh --nodeps gtkhtml2-devel-2.11.1-11.fc15.i686.rpm
    If you wish to unpack the RPM and temporarily access the files, try:
    Code:
    rpm2cpio < gtkhtml2-devel-2.11.1-11.fc15.i686.rpm > gtkhtml2-devel-2.11.1-11.fc15.i686.cpio
    mkdir gtkhtml2-devel-2.11.1-11.fc15.i686
    cd gtkhtml2-devel-2.11.1-11.fc15.i686
    cpio -idv < ../gtkhtml2-devel-2.11.1-11.fc15.i686.cpio
    Now create symlinks (which you can remove later):
    Code:
    cd /usr/include
    su -c 'ln -s /tmp/gtkhtml2-devel-2.11.1-11.fc15.i686/usr/include/gtkhtml-2.0'
    cd /usr/lib/pkgconfig/
    su -c 'ln -s /tmp/gtkhtml2-devel-2.11.1-11.fc15.i686/usr/lib/pkgconfig/libgtkhtml-2.0.pc'
    now try to compile screem again. it should now find the gtkhtml-2.0 files it needs. if it doesn't, make sure the symlinks you created are working properly.

    I haven't looked at libgnome-menu yet, but hopefully it will work the same way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •