Find the answer to your Linux question:
Results 1 to 2 of 2
hello, I have had a fedora machine running for a while, and for some reason, when I reference a hostname be it using SSH or ping or scp etc, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15

    Unhappy appending a domain to my hostnames


    hello,

    I have had a fedora machine running for a while, and for some reason, when I reference a hostname be it using SSH or ping or scp etc, the computer is appending a domain on to the end of the hostname.

    I am using a linux router to make DNS assignments throughout my local network and it has been working for all the other computers on the network, except this one.

    for example when I ping hostname

    the result I get is

    PING hostname.domain.com (External IP) etc...

    I didnt want to ping the hostname on any domain, just the host name.

    I have tried looking in my hosts file and in the /etc/resolv.conf and everything looks fine there.

    Any help is appreciated!

  2. #2
    Just Joined!
    Join Date
    Jun 2011
    Posts
    9
    I would check the etc/hosts file on the server you are pinging from. I would do an nslookup on the IP address to see what you get. I would assume the other computers immediately resolve the hostname to the IP address when doing a ping.

    I'm not sure what you mean when you say "I didn't want to ping the hostname on any domain." Wouldn't the hostname and full-qualified domain name resolve to the same computer?

    Have you tried rebooting the computer or doing a DNS flush?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •